roboforum.ru

Технический форум по робототехнике.

 

Проект "Nanobot"

Наше хобби — конструировать и программировать.
Демонстрация готовых роботов и устройств построенных своими руками.

Re: Проект "Nanobot"

Сообщение elmot » 30 мар 2012, 11:15

CiSi писал(а):Два гелиеволсвинцовых аккумулятора 12В 7Ач.

Гелиево???? PbHe??? Я что-то упустил???
Аватара пользователя
elmot
 
Сообщения: 5674
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: Проект "Nanobot"

Сообщение =DeaD= » 30 мар 2012, 11:29

я думаю - "гелево" :)
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Проект "Nanobot"

Сообщение CiSi » 30 мар 2012, 12:06

конечно - "гелево" :)
ПС. прошу прощение за введение в заблуждение.
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение Korbofos » 07 янв 2013, 00:40

CiSi писал(а):Измерил ток в нагрузке первого двигателя(чуть больше 3А) и вторых более меньших (не более 2А )но не менее мощных как оказалось на практике.

Подскажите какой вес у двигателя меньшего размера? Думаю облегчить своего робота.
РАБОТА, РАБОТА перейди на Федота, с Федота на его брата, а ко мне их зарплата.
Аватара пользователя
Korbofos
 
Сообщения: 296
Зарегистрирован: 15 янв 2011, 11:27
Откуда: Челябинск
прог. языки: C/C++
ФИО: Александр

Re: Проект "Nanobot"

Сообщение CiSi » 07 янв 2013, 15:47

точно не могу сказать, но около 1 кг.
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение CiSi » 15 янв 2013, 09:50

Давно пора было заняться электроникой / управлением, но дело до этого дошло только сейчас(
Но возникли некоторые сложности:
=DeaD= писал(а):
CiSi писал(а):Модули перед отправкой проверяются?

Да, но не перед отправкой, а после производства.
Так как они реализуются через несколько магазинов и гарантировать проверку в каждом перед отправкой невозможно.

Неважно когда, главное что проверяются.
=DeaD= писал(а):
CiSi писал(а):Просто заметил что на одном из контактов микросхемы (модуль OR-USB-UART)больше олова чем на других, и возникло такое впечатление что между соседними контактами замыкание.

Там был косяк проектирования печатной платы, из-за чего пришлось такую нашлепку делать, короче это нормально :oops:

Понятно.
=DeaD= писал(а):
CiSi писал(а):Через HyperTerminal ответы на команды не приходят. Посылаю "V" - а в ответ ничего.

Как всё собрано? Какой контроллер? Как выставлены джамперы? Как подано питание?

Через USB->USBmini подключен модуль OR-USB-UART, к нему через шлейф RoboBus подключен модуль OR-AVR-M128-DS. Внешнее питание не какое не подключено, понял так что питание осуществляется от пк.

Фото платы с установленными джамперами:
Изображение
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение =DeaD= » 15 янв 2013, 13:46

Снималось через зеркало для моего удобства? :)

На фото нет модуля USB-UART, как он подключен на шлейф.
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Проект "Nanobot"

Сообщение CiSi » 15 янв 2013, 14:01

Снималось на камеру ноута.
Модуль USB-UART, подключен шлейфом также как и к контроллеру, вечером сделаю фото.

При замыкании на модуле USB-UART выводы rx, tx, терминал так же нечего не выводит.
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение =DeaD= » 15 янв 2013, 16:33

Номер порта точно правильный?
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Проект "Nanobot"

Сообщение CiSi » 15 янв 2013, 17:28

да, менял как написано в инструкции

Добавлено спустя 24 минуты 57 секунд:
если бы порт был неправильным, то программа бы независала.
так то программа работает, видео воспроизводит.
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение =DeaD= » 15 янв 2013, 17:42

Какой терминал?
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Проект "Nanobot"

Сообщение Angel71 » 15 янв 2013, 18:27

CiSi, предпологаю, что проблема софтовая. запускал тот терминал, к порту (встроенный в материнку) ничего не подключено и терминал виснет. хотя бегло просмотрев код заметил, что там таймаут есть и он по идеи должен был сработать. qt в данный момент не стоит, так что дебаггером пройтись пока не могу. в общем, чтобы понять, почему виснет нужно дебажить и эксперементировать. посмотреть, может какие параметры не указаны, возможно ли как-то по другому с портом работать (как вариант, другие ф-и) или даже попробовать написать свою прослойку, работающую напрямую через винапи (у ftdi есть свои обёртки),...
юсб-уарт у вас на какой микре? в 7ке с pl2303 или ftdi проблем вообще не помню. на одной материнке сталкивался, что драйвера на компорт в 7ке ставит, порт виден, но что-то передать чёт не получалось. скорей всего можно было разобраться что к чему и пофиксить, но было лень и просто подключил usb`шный переходник, на котором всё чудно заработало. хз, может и с вашим переходником чего подобного. в других терминалах и с другими железками ваш переходник работает?
Аватара пользователя
Angel71
 
Сообщения: 9231
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: Проект "Nanobot"

Сообщение CiSi » 15 янв 2013, 22:16

=DeaD= писал(а):Какой терминал?

HyperTerminal версия 6.1

>Angel71
Дело даже не в том что программа не работает - виснет при соединении с портом, а в том что даже через стандартный терминал (в хр стандартный, а для 7-ки отдельно скачал) не удается принять ответ, даже если на модуле USB-UART выводы rx, tx - замкнуты.

Добавлено спустя 9 минут 55 секунд:
вот и несколько фото:
Вложения
StillCap0006.jpg
StillCap0002.jpg
StillCap0000.jpg
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение Angel71 » 15 янв 2013, 22:32

т.е. методом исключения, начиная с
Angel71 писал(а):в других терминалах и с другими железками ваш переходник работает?

получается, что данный китавайский usb-uart переходник не пашет?
Последний раз редактировалось Angel71 15 янв 2013, 22:35, всего редактировалось 1 раз.
Аватара пользователя
Angel71
 
Сообщения: 9231
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: Проект "Nanobot"

Сообщение CiSi » 15 янв 2013, 22:35

завтра попробую к другому пк подключить,
переходник от телефона, раньше работал а сейчас железок не каких не осталось чтобы проверить.
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Пред.След.

Вернуться в Наши проекты

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 5

Mail.ru counter