roboforum.ru

Технический форум по робототехнике.

 

Проект "Nanobot"

Наше хобби — конструировать и программировать.
Демонстрация готовых роботов и устройств построенных своими руками.

Re: Проект "Nanobot"

Сообщение =DeaD= » 17 янв 2013, 13:05

CiSi писал(а):Запросы идут на скорости 9600.

А должны на 115200 :pardon:

CiSi писал(а):Непонял, чтоже телать с питанием, подключать не подключать и какое?

Если МК отвечает, значит он запитан :)
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Проект "Nanobot"

Сообщение CiSi » 17 янв 2013, 13:19

=DeaD= писал(а):
CiSi писал(а):Запросы идут на скорости 9600.

А должны на 115200 :pardon:

CiSi писал(а):Непонял, чтоже телать с питанием, подключать не подключать и какое?

Если МК отвечает, значит он запитан :)

Скорость запросов тоже поменял. Все попрежниму. :(

Добавлено спустя 3 минуты 21 секунду:
еще, пробывал перепрошить, шлет попрежнему "домики".

Добавлено спустя 6 минут 37 секунд:
может прошил както неправильно, уж больно быстро она залилась (прям моментально).
вот что написал: "C:\WinAVR-20100110\bin\avrdude.exe" -p m128 -c avr911 -Pcom2 –b115200 -U
flash:w:" C:\Users\ИТС_prog\Desktop\Робот\orfa-v0.9.0-b4\orfa-v0.9.0-b4\orfa_v0.9.0-b4_or-avr-m128-ds_master_b115200.hex":i -U signature:r:con:r -F -v
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение =DeaD= » 17 янв 2013, 14:15

А можно распечатку, что оно пишет, когда шьёт?

И вообще - если оно шьёт нормально, значит порт и МК отлично работают, проблемы потом при работе терминала в софте терминала или настройках ком-порта.
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Проект "Nanobot"

Сообщение CiSi » 17 янв 2013, 14:28

при запуске и прошивке через avrdude, что то пишет (несколько строчек) в консольном окне и закрывается, даже неуспеваю посмотреть что там написано.
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение =DeaD= » 17 янв 2013, 14:37

facepalm...

Откройте через "cmd" или любой файловый менеджер и посмотрите, что там пишется :)
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Проект "Nanobot"

Сообщение CiSi » 17 янв 2013, 15:08

Вот что получилось:
Вложения
AVRDude_скрин.png
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение =DeaD= » 17 янв 2013, 15:19

Не может открыть порт, у вас случаем одновременно терминал не запущен?
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Проект "Nanobot"

Сообщение elmot » 17 янв 2013, 15:32

Порт под названием 115200 и не откроется
-P com<номер> -b 115200

http://www.nongnu.org/avrdude/user-manu ... ude_4.html

Добавлено спустя 2 минуты 10 секунд:
CiSi писал(а):8 бит, скорость выставил 115200

Лажа, в скриншоте окна гипертерма видно, что 7 бит стоит.
Может быть, стОит быть повнимательнее?
Аватара пользователя
elmot
 
Сообщения: 5674
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: Проект "Nanobot"

Сообщение CiSi » 17 янв 2013, 15:37

нет, все терминальные программы закрыты

Добавлено спустя 5 минут 37 секунд:
elmot писал(а):Порт под названием 115200 и не откроется
-P com<номер> -b 115200

http://www.nongnu.org/avrdude/user-manu ... ude_4.html

Добавлено спустя 2 минуты 10 секунд:
CiSi писал(а):8 бит, скорость выставил 115200

Лажа, в скриншоте окна гипертерма видно, что 7 бит стоит.
Может быть, стОит быть повнимательнее?

фигня какаето, биты данных везде 8 установленно и в настройках самого порта и в настройках гипертерминала, уже несколько раз проверил.
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение elmot » 17 янв 2013, 15:44

Внизу окна гипертерма написано - 115200-7-E-1,т.е. 7 бит, четная четность.
Должно быть 115200-8-N-1 или что-то вроде того.

Добавлено спустя 1 минуту 15 секунд:
Возьмите другую терминалку, putty например.
Кста, гипертерм не меняет фактические параметры соединения если порт уже открыт(ЕМНИП).
Аватара пользователя
elmot
 
Сообщения: 5674
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: Проект "Nanobot"

Сообщение CiSi » 17 янв 2013, 16:25

ейчас набил правильно, но ыдал ошибку (

Добавлено спустя 33 минуты 56 секунд:
elmot писал(а):Внизу окна гипертерма написано - 115200-7-E-1,т.е. 7 бит, четная четность.
Должно быть 115200-8-N-1 или что-то вроде того.

Добавлено спустя 1 минуту 15 секунд:
Возьмите другую терминалку, putty например.
Кста, гипертерм не меняет фактические параметры соединения если порт уже открыт(ЕМНИП).

в настройках порта, диспетчера устройств установленно 115200-8-N-1
Вложения
AVRDude_скрин.png
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение =DeaD= » 17 янв 2013, 16:37

Всё выполняется по инструкции? Reset нажимаете прямо перед заливкой?
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Проект "Nanobot"

Сообщение Angel71 » 17 янв 2013, 16:37

на скрине с диспетчером устройств был ком1. на последнем скрине написано ком2, это программатор не на тот порт шлёт или переходник в данный моменет на втором коме?
Аватара пользователя
Angel71
 
Сообщения: 9232
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: Проект "Nanobot"

Сообщение CiSi » 17 янв 2013, 17:20

Angel71 писал(а):на скрине с диспетчером устройств был ком1. на последнем скрине написано ком2, это программатор не на тот порт шлёт или переходник в данный моменет на втором коме?

сейчас сом2 установлен

Добавлено спустя 39 минут 28 секунд:
перезагрузил комп (чтобы наверняка все порты закрылись), проверил настройки ком порта в диспетчере устройств, не какие терминалы не запускал - попробывал перепрошить, таже самая ошибка. :(
Аватара пользователя
CiSi
 
Сообщения: 972
Зарегистрирован: 04 окт 2007, 16:11
Откуда: иваново
Skype: cybsys1
прог. языки: Delphi
ФИО: Павел

Re: Проект "Nanobot"

Сообщение Duhas » 17 янв 2013, 17:26

настройки порта вводить надо в программе открывающей порт, а не в диспетчере устройств.

юзать лучше путти. настройки в путти поставить правильные и сохранить конфигурацию.
«Как сердцу выразить себя? … Мысль изреченная есть ложь!»
В этом мире меня подводит доброта и порядочность...
"двое смотрят в лужу, один видит лужу, другой отраженные в ней звезды"
Аватара пользователя
Duhas
 
Сообщения: 6341
Зарегистрирован: 15 сен 2007, 13:03
Откуда: Красноярск
прог. языки: ASM(МК), C(PC)
ФИО: Гагарский Андрей Александрович

Пред.След.

Вернуться в Наши проекты

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter