roboforum.ru

Технический форум по робототехнике.


Подсветка а-ля Ambilight

Здесь расположены обсуждения и проекты, которые с точки зрения администрации форума представляют наибольший интерес.
Правила форума
В этом форуме новые темы не создаются, однако обсуждение допустимо.

Re: Подсветка а-ля Ambilight

Сообщение mexxR-73 » 16 мар 2010, 21:23

Ок ! Спасибо пцаны! лента работает!! Вот еще в чем вопрос!! где то на 17-18 странице обсуждался софт boblight! Вы мне подскажите как эту проу запустиь? призапуске пишет boblight.conf: No such file or directory!!
mexxR-73
 
Сообщения: 4
Зарегистрирован: 11 мар 2010, 20:33
Откуда: Минеральные воды

Re: Подсветка а-ля Ambilight

Сообщение jarre » 17 мар 2010, 18:48

Создать этот файл :) там в комплекте два примера .conf уже есть - это конфигурации, в текстововм виде.
mexxR-73 писал(а):Ок ! Спасибо пцаны! лента работает!! Вот еще в чем вопрос!! где то на 17-18 странице обсуждался софт boblight! Вы мне подскажите как эту проу запустиь? призапуске пишет boblight.conf: No such file or directory!!
Аватара пользователя
jarre
 
Сообщения: 29
Зарегистрирован: 21 сен 2009, 12:00
Откуда: Екатеринбург

Re: Подсветка а-ля Ambilight

Сообщение skorpionm » 21 мар 2010, 02:32

Kurok писал(а):У кого нибудь есть девайс работающий через USB мост FTDI ?
Добил я до конца свою программу, хотел предложить протестировать.
Теперь программа умеет выводить от 1 до 42 каналов, есть регулировка яркости , насыщенности и баланса белого.
Корректно работает с Windows 7 и темой AERO , не тормозит на разрешениях 1900х1080, корректно выходит из Сна и Hibernation , имеется конфигурационный фаил, с возможностью отключения не нужных каналов и настройкой областей сканирования, изменения времени сканирования и т.д.


А где прогу то качнуть??
skorpionm
 
Сообщения: 18
Зарегистрирован: 24 янв 2010, 00:09
Откуда: саратов

Re: Подсветка а-ля Ambilight

Сообщение Kurok » 22 мар 2010, 01:40

Kurok
 
Сообщения: 21
Зарегистрирован: 24 фев 2010, 00:26
Откуда: Moc

Re: Подсветка а-ля Ambilight

Сообщение Darkblue » 06 апр 2010, 00:04

Уважаемые помогите пожалуйста,собирал по данной статье http://www.hwp.ru/articles/Sozdanie_ana ... mi_rukami/ ,всё один в один ,только кварц брал на 14.745, шью понипрогом-stk200,какие фьюзы(галочки) должны стоять для этого кварца,напишите пожалуйста или скринаните,и ещё подскажите для данного кварца я видел на одной из страниц архив там 3 прошивки на 3 кварца они вообще рабочие или нет?(архив Ambilight_1_2_fixed)
Darkblue
 
Сообщения: 2
Зарегистрирован: 31 дек 2008, 13:19

Re: Подсветка а-ля Ambilight

Сообщение LEV-PRAV » 06 апр 2010, 00:17

Я тоже по этой статье собирал, извини по фузам не подскажу (как то интуитивно с 3 раза попал), нормально работает только 11.059(2).

с 14.745 ацко тормозит.

а 18......МГц даже пробовать не стал, мега по бумажкам до 16 Мгц работает, тут что то про это говорилось но я вьезжать не стал(может кто скажет).

Прошивка в той статье на которую ты ссылаешся хороша тем ,что при старте происходит тест всех каналов, если прошил правильно ,то за 2 секунды пробегут все цвета на всех каналах, если не правильно, то ваще ни че не будет. Если медленно пролыли цвета, то работает от внутреннего кварца.
Программирование без кода www.flowcode.info
Аватара пользователя
LEV-PRAV
 
Сообщения: 30
Зарегистрирован: 15 фев 2010, 20:20
Откуда: С-Пб
прог. языки: flowcode

Re: Подсветка а-ля Ambilight

Сообщение Darkblue » 06 апр 2010, 00:41

Спасибо LEV-PRAV,хорошо допустим кодвиженом шьём,как написал александр открываем проект ,жмём кнопку программатора, вылезает окно там всё так же как и на картинке со страницы 7 ,только графа с кварцем пропадает так как я шью программатором stk200 причём она пропадает когда меняешь настройку программатора на выше указанный,и что всё жмём "Program all"?
Darkblue
 
Сообщения: 2
Зарегистрирован: 31 дек 2008, 13:19

Re: Подсветка а-ля Ambilight

Сообщение LEV-PRAV » 06 апр 2010, 01:03

Вот так работает. На семёрке, но только опция FIXED. AUTO тормозит. Random работает. Если тыкаю в SOUND прога закрывается. Это на квацах 11 и 14.
Вложения
smartprog2.JPG
Программирование без кода www.flowcode.info
Аватара пользователя
LEV-PRAV
 
Сообщения: 30
Зарегистрирован: 15 фев 2010, 20:20
Откуда: С-Пб
прог. языки: flowcode

Re: Подсветка а-ля Ambilight

Сообщение sandro » 06 апр 2010, 01:38

а у меня с кварцем на 14.745 работает как трактор,никаких глюков не наблюдается,с другими не пробовал.работает и через сом или усб
Аватара пользователя
sandro
 
Сообщения: 67
Зарегистрирован: 01 апр 2008, 02:29
Откуда: Тирасполь

Re: Подсветка а-ля Ambilight

Сообщение LEV-PRAV » 06 апр 2010, 13:35

Это я поспешил на 14 кварц грешить.
11 и 14 работают одинаково.
В XP на третем пне всё работало.
Щя новый комп и W7, Работают только опции независимые от системы RND и FIXED.
Программирование без кода www.flowcode.info
Аватара пользователя
LEV-PRAV
 
Сообщения: 30
Зарегистрирован: 15 фев 2010, 20:20
Откуда: С-Пб
прог. языки: flowcode

Re: Подсветка а-ля Ambilight

Сообщение sandro » 06 апр 2010, 14:14

Тестовый вариант у меня был на Compaq Pressario 1700, 700MHz 256RAM Win XP32 SP2,USB-COM CP2303 никаких проблемм
Аватара пользователя
sandro
 
Сообщения: 67
Зарегистрирован: 01 апр 2008, 02:29
Откуда: Тирасполь

Re: Подсветка а-ля Ambilight

Сообщение luser » 06 апр 2010, 19:38

Добрый день уважаемые форумчане!
Собрал сей девайс по схеме Александра, заработал сразу же
т.е. С програмой амбилайт1_2 и 1_3 работает НО СТРАШНО ТОРМОЗИТ (прошивка (1_2))
в режиме fixed(все цвета меняются и регулируются как положено)
в режиме RND тоже работает, меняяет цвета...
в режиме АВТО ТОРМОЗИТ и все!
если оставить по умалчанию значения (в АВТО) практически не видно изменений (ставлю X 200 Y 150) видно что что то меняет, но тормозит.... :(
подскажите кто возился и собаку уже съел на этом девайсе, в чем может быть проблема?
(Система Windows7 ultimate 32bit)

может стоит поставить прошивку (main.xeh) или прошивку (1_3) и использовать bobilight? вобщем помогите если не в напряг :)
luser
 
Сообщения: 4
Зарегистрирован: 06 апр 2010, 19:28

Re: Подсветка а-ля Ambilight

Сообщение Yurik » 07 апр 2010, 14:12

собрaл прогрaммaтор, рaботaющий от LPT портa (мeгa прошивaeтся внe схeмы эмбилaйтa). Прошил chipblasterom, прошивкой 1_2 , фьюзы выстaвлял кaк нa скриншотe у -Алeксaндрa-. Послe чeго я встaвил контроллeр в схeму, всё рaботaeт, прaвдa при вызовe мышкой контeкстного мeню происходит зaтухaниe нa пaру сeкунд. Использовaл квaрц 14,.. Мгц. Хотeл пeрeпрошить мeгу, но понипрог и чипблaстeр пeрeстaли видeть мeгу. Из-зa чeго тaкоe могло произойти? Подскaжитe пожaлстa.
Yurik
 
Сообщения: 11
Зарегистрирован: 27 фев 2010, 02:10
Откуда: Запорожье

Re: Подсветка а-ля Ambilight

Сообщение -= Александр =- » 07 апр 2010, 15:02

Если ты программируешь мегу не на плате - видимо у тебя к ней не подключен кварц. А при настройке фьюзов для кварца - без него уже никак.
Ниндзя - круче всех. Они умеют ходить по воде, делить на ноль и угадывать шаффл в АйПоде.
Аватара пользователя
-= Александр =-
Мастер Самоделкин
 
Сообщения: 3671
Зарегистрирован: 11 окт 2004, 19:20
Откуда: Россия, СПб
прог. языки: C/C++, Python, asm
ФИО: Курмис Александр Андреевич

Re: Подсветка а-ля Ambilight

Сообщение Yurik » 07 апр 2010, 16:30

Дa, квaрцa в прогрaммaторe нe было. Т.e. нaдо прогрaммaтор подключить к плaтe эмбилaйтa, подaть нaпряжeниe и прошивaть, я прaвильно понял?
Yurik
 
Сообщения: 11
Зарегистрирован: 27 фев 2010, 02:10
Откуда: Запорожье

Пред.След.

Вернуться в Золотой фонд

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter