roboforum.ru

Технический форум по робототехнике.

 

А это мой бот (воргколог)

Обсуждаем рождающиеся мысли и результаты экспериментов.

Re: А это мой бот (воргколог)

Сообщение Digit » 10 ноя 2007, 01:36

Короче вот:
критические параметры (absolute maximum ratings)
Vsens Sensing Voltage –1 to 2.3 V
(т.е. измеряемое напряжение от -1 до 2.3 Вольт)

В характеристиках (ELECTRICAL CHARACTERISTICS) ниже написано, что минимум -1 вольт, максимум 2 вольта. А под табличкой меленько приписано, что измеряемое напряжение может быть –1 вольт только в течении времени до 50 микросекунд включительно. (В общем, это в пике получается). А на постоянку минимальное значение Vsens >= – 0.5 вольта.

Как там меняется напряжение я что-то не нашел. Нашел только, что резистор зависит от тока в нагрузке. И что ток, протекающий через нагрузку, "вытекает" :) через вывод SENSE, а внешний резистор позволяет оценить этот ток.
злой полицейский
Аватара пользователя
Digit
 
Сообщения: 3339
Зарегистрирован: 27 ноя 2004, 00:42
Откуда: совсем Москва
ФИО: Григорий

Re: А это мой бот (воргколог)

Сообщение Master » 10 ноя 2007, 17:15

Фигасе. Ниче не понял, получается Sens он вроде как что то меряет. Короче пока не буду его никчиму подключать и все.
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: А это мой бот (воргколог)

Сообщение Master » 11 ноя 2007, 19:06

Ладно раз все молчат буду завтра травить.
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: А это мой бот (воргколог)

Сообщение Master » 22 ноя 2007, 21:42

Короче спаял, жду выходных купить панельку под МК и буду тестить.
Вложения
DSC00046.JPG
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: А это мой бот (воргколог)

Сообщение Master » 03 дек 2007, 10:41

Написал прошивку, ШИМ 100% и полный вперед в Протеусе все ОК в железе не едет :(
Буду думать.

Добавлено спустя 35 минут 9 секунд:
Кажись нашел в чем проблема. Резисторы от SensA и SensB в Н-мосте L298 нада ставить поменьше, а то я впаял на 10К. С таким значение в протеусе моторы еле крутятся.

Добавлено спустя 11 минут 39 секунд:
Нада будет поставить на 1 Ом как в примере протеуса, а то в ДШ нимагу найти какой нада номинал.
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: А это мой бот (воргколог)

Сообщение Master » 08 янв 2008, 14:05

Продолжил седня изыскания, короче когда подаю питание для того чтобы колесики начали крутится нада их пальцем провернуть в чем дело не могу понять напряжение на питания двигателей 5 В!!!!!, в том время как машинка питалась от 3-х. Уже голову сломал.

Добавлено спустя 10 часов 32 минуты 35 секунд:
Хелп? :cry:
Вложения
.JPG
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: А это мой бот (воргколог)

Сообщение Myp » 08 янв 2008, 16:10

ну ты попробуй с минимальной скорости раскручивать...
прям незнаю
у меня мотор не крутился когда я на него сразу импульсы высокой скорости подавал

у тя та жа фигня будет если случайно колесо заклинит то робот второй раз не стартанёт
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 15946
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Re: А это мой бот (воргколог)

Сообщение Master » 08 янв 2008, 17:03

Ну если напрямую батарейку подключить к моторчику он кртится аж бегом. Неужели с Н-мостом может быть такой геморой?
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: А это мой бот (воргколог)

Сообщение =DeaD= » 08 янв 2008, 17:41

Вольтметр что показывает на движке в момент подачи напряжения на него?
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: А это мой бот (воргколог)

Сообщение Master » 08 янв 2008, 17:44

На разьеме к которому движок подключаю 5В, движок при этом отключен. При включенном движке не мерял. Может у движков сильно большой потребляемый ток?
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: А это мой бот (воргколог)

Сообщение Myp » 08 янв 2008, 18:07

здрасте приехали =)


вот ты сначала померь и убедись что у тебя на подключенном моторе напряжение есть и какой там ток течёт
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 15946
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Re: А это мой бот (воргколог)

Сообщение quarz » 08 янв 2008, 21:05

Проверь конденсаторы по шине питания L298 +5В! У меня была трабла когда шаговик подключал. Осциллограф показывал провалы на питании до 4х вольт.
И принципиалку в студию, будет проще )
Типов людей всего 10: те, кто понимает двоичный код, и те кто нет.
Аватара пользователя
quarz
 
Сообщения: 88
Зарегистрирован: 21 окт 2007, 14:29
Откуда: Москва

Re: А это мой бот (воргколог)

Сообщение Master » 09 янв 2008, 09:57

Провел замеры.
1. При двигателе отключенном от разъема L298 на разъеме 5 В.
2. При подключенном двигателе, на двигателе 3 В, типа проседает на 2 В.
3. Если двигатель подключить напрямую к блоку питания, то при 3,3В потребляемый ток 0,1А, а если подключить к 5В, то китайский мультиметр показвает всякую брехню, то 15А, то 0,2, то 1А.

Вот схема включения.
Вложения
.JPG
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: А это мой бот (воргколог)

Сообщение quarz » 09 янв 2008, 10:23

или погорела L298, или одно из двух: помехи от движка влияют на работу МК или моста 0_о
Попробуй вместо движка подключить лампочку (от фонарика, типа 6.3в), или светодиод с резистором.
китайский мультиметр показвает всякую брехню, то 15А, то 0,2, то 1А.

Еще бы! При коммутировании индуктивной нагрузки через мультиметр шел еще и ток самоиндукции
Типов людей всего 10: те, кто понимает двоичный код, и те кто нет.
Аватара пользователя
quarz
 
Сообщения: 88
Зарегистрирован: 21 окт 2007, 14:29
Откуда: Москва

Re: А это мой бот (воргколог)

Сообщение Master » 09 янв 2008, 10:38

Попробуй вместо движка подключить лампочку (от фонарика, типа 6.3в), или светодиод с резистором.

Ну увижу я как лампочка и светик горит, что мне это даст?

Добавлено спустя 1 минуту 22 секунды:
Впринципе если бы помехи от движка влияли на работу МК, то он бы ресетился, а у меня номана работает, можно покрутить моторчики 10 сек вначале в одну сторону потом в другую.

Добавлено спустя 1 минуту 15 секунд:
Тем более я кондер на 220 мФ поставил в цепь питания движка. Можно еще попробывать параллельно движку поставить кондеру по 0,1 мФ.
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Пред.След.

Вернуться в Идеи

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

Mail.ru counter