roboforum.ru

Технический форум по робототехнике.


OR-WRT - Поддержка

Разработка стандартизированных модулей для домашнего робостроения.
Правила форума
Правила раздела OpenRobotics

Re: OR-WRT - Поддержка

Сообщение Tsi329 » 28 мар 2012, 01:27

elmot писал(а):UVC у меня не глючила ни разу. Версия прошивки? Камера?
Что можно проверить:
- питание - напряжение, помехи
- состояние кабеля камеры
- попробовать кабель переложить, чтобы исключить наводки с моторов и прочие радости

Ну вот не знаю, что у меня не так, но камера как не работала, так и не работает.
Отвечаю по пунктам:
- Питание родное от DIR-320. Помех никаких.
- Кабель родной от камеры. Просто воткнул в роутер и всё.
- Кабель как только не перекладывал. И скручивал его, и распрямлял, и наматывал. Результат один - цифровые глюки на экране. Никаких других устройств больше не подключено к роутеру.

Глюки больше всего проявляются если палец нести к объективу. На расстоянии пары сантиметров и ближе верхняя треть изображения камеры "сыплет" квадратами. Это эффект наблюдается и в других случаях, но просто их не так легко словить. Обычно при наведении камеры на однотонные поверхности.

Elmot, спасай. Что не так?
Tsi329
 
Сообщения: 135
Зарегистрирован: 24 авг 2010, 11:48
Откуда: Минск
прог. языки: C++,C,Asm

Re: OR-WRT - Поддержка

Сообщение elmot » 28 мар 2012, 10:06

Пункт раз - взять последнюю версию прошивки
пункт двас - промерить тестером напряжение питания роутера.
пункт трис - проверить качество проводов питания роутера. У меня было такое - дохлый разъем в цепи питания роутера. У роутера внутренний стабилизатор, он работает, а камеру морщит и плющит. Причем видеоэффекты такие же.
пункт четыре - экран перезагрузки(тот, который с параметрами) - мне в личку.
Последний раз редактировалось elmot 28 мар 2012, 10:22, всего редактировалось 1 раз.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение =DeaD= » 28 мар 2012, 10:14

У меня тоже цифровой шум, не сильно конечно, но есть, было бы круто его победить.

Вот тут видно на 25-30 секунде в верхней части кадра:
post236447.html#p236447
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24218
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Re: OR-WRT - Поддержка

Сообщение elmot » 28 мар 2012, 10:29

А если фпс понизить, шум сохраняется?

Добавлено спустя 10 минут 49 секунд:
Вообще про этот шум я не знаю что и думать. У меня такого не было никогда, а я пробовал 2 разные камеры Logitech. Может все-таки какой-то разъем дребезжит? А если робороутер соединить не вайфаем,а ланом, лучше не становится?
Такое впечатление, что он коррелирует с вибрацией. Ну и попробуй тплинк, мож на нем будет лучше.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение =DeaD= » 28 мар 2012, 10:32

TP-Link - Да, обязательно, сегодня. С вибрацией шум не кореллирует, кореллирует только с большими близкими к монотонным областями в кадре. Короче программная проблема, как мне кажется.
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24218
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Re: OR-WRT - Поддержка

Сообщение boez » 28 мар 2012, 10:44

У меня такая проблема была с камерой с210 на винде. Лечилась не то включением, не то выключением авторегулировки яркости в драйвере. Проблема и правда была программная, проявлялась на определенных сценах, вроде как как раз с большими светлыми областями.
boez
 
Сообщения: 1981
Зарегистрирован: 27 авг 2008, 10:45
Откуда: Харьков
прог. языки: С/С++

Re: OR-WRT - Поддержка

Сообщение =DeaD= » 28 мар 2012, 10:53

Хм, если и на винде такое, то наверное проблема в камере? :(
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24218
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Re: OR-WRT - Поддержка

Сообщение Tsi329 » 28 мар 2012, 13:45

Проблема с цифровыми шумами камеры только программная. Я уже не раз об этом писал на этом форуме. Как мне объяснил один из разработчиков прошивки для DIR-320, проблема кроется в ядре. Я проверил. Да, одна из первых кастомных прошивок с поддержкой usb камер для этого роутера данной проблемы не имеет. Если надо, то я могу найти ее билд.

Не везет мне с DIR-320. USB камера шумит. Ethernet камеру подключить на эту прошивку не могу. Или проблема эта уже решена?
Tsi329
 
Сообщения: 135
Зарегистрирован: 24 авг 2010, 11:48
Откуда: Минск
прог. языки: C++,C,Asm

Re: OR-WRT - Поддержка

Сообщение elmot » 28 мар 2012, 16:38

Можно попробовать достать старое ядро.
Tsi329 писал(а): Ethernet камеру подключить на эту прошивку не могу. Или проблема эта уже решена?

Решена для TP-LINK. Сейчас попробую собрать прошивку DIRу с такой фичей.

Добавлено спустя 2 часа 38 минут 17 секунд:
Так, случилась прошивка для DIR-320 с поддержкой проброса трафика IP камеры. Попробовано на камере Wanscam
Камеру надо настраивать на IP 192.168.0.99, порт 80 и подвесить к любому порту LAN. После этого заходим на
http://192.168.1.120:88/ и видим интерфейс камеры.
Прошивка тут:
https://sourceforge.net/projects/orwrt/ ... NK-DIR320/
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение =DeaD= » 28 мар 2012, 21:50

Проверил прошивку 0.60 для WR703n - залилась нормально, к WiFi подцепилась, камера работает, но только в YUV.
В mjpeg это одна сплошная помеха (по крайней мере в 320х240х25fps, сейчас другие режимы попробую):
wr703n-mjpeg-test-fail.jpg
wr703n-mjpeg-test-fail.jpg (27.25 КиБ) Просмотров: 2338


Добавлено спустя 4 минуты 40 секунд:
В режиме 640х480х30fps чуть лучше, но всё равно помехи:
wr703n-mjpeg-test-fail2.jpg
wr703n-mjpeg-test-fail2.jpg (23.15 КиБ) Просмотров: 2331


Добавлено спустя 9 минут 45 секунд:
160x120x30fps - то же, но в другой руке :)
wr703n-mjpeg-test-fail3.jpg
wr703n-mjpeg-test-fail3.jpg (21.32 КиБ) Просмотров: 2325
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24218
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Re: OR-WRT - Поддержка

Сообщение elmot » 29 мар 2012, 00:24

Во, блин. Ни разу такого не видел

Добавлено спустя 2 часа 31 минуту 18 секунд:
Dead, можешь это дело завтра в инет открыть и мне в личку сбросить явки-пароли? Попробую удаленно потыркать.

Добавлено спустя 1 минуту 19 секунд:
Tsi329 писал(а):Проблема с цифровыми шумами камеры только программная. Я уже не раз об этом писал на этом форуме. Как мне объяснил один из разработчиков прошивки для DIR-320, проблема кроется в ядре. Я проверил. Да, одна из первых кастомных прошивок с поддержкой usb камер для этого роутера данной проблемы не имеет. Если надо, то я могу найти ее билд.

А подробнее, что сказал разраб? Или как с ним связаться?
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение =DeaD= » 29 мар 2012, 08:06

elmot писал(а):Dead, можешь это дело завтра в инет открыть и мне в личку сбросить явки-пароли? Попробую удаленно потыркать.


Какие порты надо пробросить кроме 8080 ?
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24218
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Re: OR-WRT - Поддержка

Сообщение elmot » 29 мар 2012, 10:31

22, 80
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение =DeaD= » 30 мар 2012, 00:03

Сегодня протестировал прошивку для TP-Link WR703n в части встроенного UART - всё отлично. Для этого сейчас в выложенной сейчас прошивке конечно нужно поправить пару строк:

elmot в переписке по icq писал(а):/etc/ser2net.conf

у этих строк символ коммента перекинуть
#2000:raw:600:/dev/ttyATH0:115200 NONE 1STOPBIT 8DATABITS -XONXOFF -LOCAL -RTSCTS
#2001:raw:600:/dev/ttyS1:115200 NONE 1STOPBIT 8DATABITS -XONXOFF -LOCAL -RTSCTS
2000:raw:600:/dev/ttyUSB0:115200 NONE 1STOPBIT 8DATABITS -XONXOFF -LOCAL -RTSCTS

у 1й и 3й


Заодно предлагается фотоотчет - как подцепить IDC-14M(R) разъем к роутеру, чтобы его было удобно использовать с модулями Open Robotics:

Шаг 1. Разберем роутер (для этого поддеть ногтем стенку с LAN-разъемом посередине, впихнуть туда небольшую плоскую отвертку, чтобы она уперлась в LAN-разъем, дабы не повредить компоненты и аккуратно раскачивая - вытаскиваем цветную крышку из корпуса роутера).
Шаг 2. Возьмем IDC-14M(R) разъем и вытащим из него все ножки кроме 4 с каждой из 2 сторон.
Шаг 3. Выкусим кусачками ребра жесткости на стенке напротив USB-A разъема все, кроме ближнего к светодиоду;
Шаг 4. Наметим и высверлим 8 дырок под разъем, проверим, что разъем встает нормально, намазываем суперклеем место под разъемом и вставляем разъем, разгибаем контакты с обратной стороны.
Шаг 5. Предварительно залудив провода - подпаиваемся к контактам 1 (GND), 12 (TX=TP_OUT), 13 (RX=TP_IN), 14 (+5V) для питания 8см проводки, для rx/tx - 3-4см;
Шаг 6. В соответствии с изображением подпаиваем GND и +5V контакты на плату:
PowerSolder1.jpg

Шаг 7. Получаем примерно такое:
Power.jpg

Шаг 8. Аккуратно напаиваем шарики припоя на площадки TP_IN, TP_OUT, вставляем плату на место, прижимаем проводки питания:
PreAssembled1.JPG

Шаг 9. Очень аккуратно, предварительно загнув так, чтобы после пайки контакты никуда не тянулись с платы, подпаиваем проводки к площадкам TP_IN, TP_OUT:
PreAssembled2.JPG

Шаг 10. Проверяем роутер в работе и если всё в порядке закрываем крышкой:
Assembled.JPG


Всё :)
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24218
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Re: OR-WRT - Поддержка

Сообщение =DeaD= » 30 мар 2012, 08:08

Да, забыл сказать - глюки с видео исчезли. Есть одна мысль, почему они могли быть, но пока не проверена.
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24218
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Пред.След.

Вернуться в Open Robotics

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter