roboforum.ru

Технический форум по робототехнике.


OR-WRT - Поддержка

Разработка стандартизированных модулей для домашнего робостроения.
Правила форума
Правила раздела OpenRobotics

Re: OR-WRT - Поддержка

Сообщение Rolf74 » 07 авг 2012, 10:02

Видео:
1. Питание проверил, от ПК и от 18V аккумулятора через преобразователь на 5V работает одинаково
2. Как поставить другой канал wifi? Хотя не факт что поможет, через лан идет такое же качество

Serial:
1. В rc.local stty -F /dev/ttyATH0 115200
2. В ser2net такие настройки
2000:raw:600:/dev/ttyUSB0:115200 NONE 1STOPBIT 8DATABITS -XONXOFF -LOCAL -RTSCTS
3001:raw:600:/dev/ttyUSB1:115200 NONE 1STOPBIT 8DATABITS -XONXOFF -LOCAL -RTSCTS
3002:raw:600:/dev/ttyUSB2:115200 NONE 1STOPBIT 8DATABITS -XONXOFF -LOCAL -RTSCTS
3003:raw:600:/dev/ttyUSB3:115200 NONE 1STOPBIT 8DATABITS -XONXOFF -LOCAL -RTSCTS
3004:raw:600:/dev/ttyUSB4:115200 NONE 1STOPBIT 8DATABITS -XONXOFF -LOCAL -RTSCTS
3005:raw:600:/dev/ttyUSB5:115200 NONE 1STOPBIT 8DATABITS -XONXOFF -LOCAL -RTSCTS
Стравнно но пробито у меня 9600 не где не было

Насколько я понял в rc.local заменить просто 115200 на 9600
А вот в ser2net не хватает строчки
1500:raw:600:/dev/ttyATH0:9600 NONE 1STOPBIT 8DATABITS -XONXOFF LOCAL -RTSCTS

Все верно?

=DeaD=, Сейчас буду играться с кнопкой :)

Что то у меня роуер и первый раз грузится не захотел что б я видео проверил, горит только диод питания, а wifi не включился.. Да и по lan подключится не вышло. Кнопка WPS не помогла. Uart в отладочной консоли пустой при погрузке.
При запуске все диоды мигают 2 раза, Питание горит ярко, а остальные гдето на 5% обычной яркости.
Роутер Умер? :(
Изображение
Вывел 3 провда от uart те которыми пользуюсь, VCC serial подаю отдельным проводом когда пользуюсь консолью..


Настройки не менял. Не включился, когда после аккумулятора подключил к пк. Аккум с преобразователем проверены, раньше ими же пользовался на этом же роутере.
Последний раз редактировалось Rolf74 07 авг 2012, 12:23, всего редактировалось 4 раз(а).
Аватара пользователя
Rolf74
 
Сообщения: 59
Зарегистрирован: 27 дек 2011, 11:58
Откуда: Украина
Skype: rolf7474

Re: OR-WRT - Поддержка

Сообщение elmot » 07 авг 2012, 11:05

Rolf74 писал(а): VCC serial подаю отдельным проводом когда пользуюсь консолью..

Неплохой способ спалить роутер.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение Rolf74 » 07 авг 2012, 11:09

Какой еще способ? :shock:

Следуя этому forum88/topic9793-150.html#p246588
Я решил что консоль через uart мне не нужна, по этому и обрезал лишний провод - VCC (см. фото), но всеже когда хочу что то посмотреть там, втыкаю этот же обрезанный провод туда где он и должен быть..

Написал про то что подаю отдельно, только для того что б не было лишних вопросов. Например как я смог проверить отладочную консоль через UART если у меня только 3 провода.

Да и если прочитать внимательней то включатся роутер перестал не после манипуляций с uart-ом..
Аватара пользователя
Rolf74
 
Сообщения: 59
Зарегистрирован: 27 дек 2011, 11:58
Откуда: Украина
Skype: rolf7474

Re: OR-WRT - Поддержка

Сообщение =DeaD= » 07 авг 2012, 11:45

А никто вроде и не утверждал, что 100% роутер спалился из-за этого :)
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24218
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Re: OR-WRT - Поддержка

Сообщение elmot » 07 авг 2012, 11:48

Замечательный способ - подать в роутер 2 разных питания(Vcc и питание USB). После чего стабы в роутере и в usb-uart начинают драться - кто первый сгорит. Кстати, сколько вольт было на Vcc?

Да, а накрыться роутер мог по какой-нибудь другой причине. Померяй напряжение Vcc при отключенном uart и подключенном питании USB. Если там НЕ 3.3В, тогда есть вероятность оживить роутер заменой стаба.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение Rolf74 » 07 авг 2012, 11:57

Для большей наглядности http://www.youtube.com/watch?v=MMdmS9YC7A8&feature=youtu.be

Напряжение при подключенном usb, в uart, между vcc и gnd = 3.4V
Аватара пользователя
Rolf74
 
Сообщения: 59
Зарегистрирован: 27 дек 2011, 11:58
Откуда: Украина
Skype: rolf7474

Re: OR-WRT - Поддержка

Сообщение elmot » 07 авг 2012, 12:03

плохо дело. похоже на сперть пациента.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение Rolf74 » 07 авг 2012, 13:45

Жаль. :( Нечего необычного не делал.. Было б не так обидно, если причина была известна.
Аватара пользователя
Rolf74
 
Сообщения: 59
Зарегистрирован: 27 дек 2011, 11:58
Откуда: Украина
Skype: rolf7474

Re: OR-WRT - Поддержка

Сообщение elmot » 07 авг 2012, 13:50

Что подавалось на vcc?
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение Rolf74 » 07 авг 2012, 13:59

для использования отладочной консоли, использовал прехеходник uart-com от дир320
Изображение
Изображение
В mr3020 подключал все соответственно vcc на vcc и тд.

Но почему то мне думается, что это тут не причем, когда проводил опыты(перед тем как роутер лёг), то uart-ом я вообще не пользовался, а когда и пользовался(до опытов) то все работало.


Единственное что меня смущает так это,то что через преобразователь роутер получал 5.16V, а от usb PC 4.97V, но раньше ж работало..

В сервисном центре его могут оживить?
Аватара пользователя
Rolf74
 
Сообщения: 59
Зарегистрирован: 27 дек 2011, 11:58
Откуда: Украина
Skype: rolf7474

Re: OR-WRT - Поддержка

Сообщение elmot » 07 авг 2012, 15:13

А, т.е. max232 питался от 3.3В изнутри роутера. Тогда это не повод ему прогорать.
Про сервис центр - не знаю. Ничего не могу сказать. Думаю, они там не будут пытаться чинить девайс за $30.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение avr123.nm.ru » 07 авг 2012, 18:09

Я бы на Rx резистор поставил 200-1000 Ом.
Читайте !
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14195
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: OR-WRT - Поддержка

Сообщение Rolf74 » 07 авг 2012, 20:20

По поводу резистора, мне и для дир-а 320 один человек советовал поставить, когда переходник еще не работал(первый раз решил что-то сам спаять), но проблема оказалась в перепутанных RX и TX, так что даже не знаю зачем нагромождать схему.

Отнес роутер в СЦ где покупал, приняли, в течении нескольких дней станет известно возможно ли его оживить.


...............................................................................................


Звонил в СЦ, будут пробовать выпаять чип и прошить через программатор, возможная причина в загрузчике

Данная прошивка вносит какие либо изменения в бутлоадер?
Аватара пользователя
Rolf74
 
Сообщения: 59
Зарегистрирован: 27 дек 2011, 11:58
Откуда: Украина
Skype: rolf7474

Re: OR-WRT - Поддержка

Сообщение svavan » 21 авг 2012, 15:32

Привет всем!

Вопросик есть. На роутере TP-Link TL-MR3020 пользуюсь внутренним UART-ом. Подправил все файлы так чтоб с вебморды все транслировалось на него и с него на микроконтроллер. Все работает, но только если сначала подключится на 2000 порт. Просто подключаешься и сразу отключаешься, после этого работает. Иначе сколько кнопки на нажимай до микроконтроллера ничего не доходит :(
Аватара пользователя
svavan
 
Сообщения: 58
Зарегистрирован: 05 июл 2012, 10:56
Откуда: Украина, Донецк
прог. языки: ASM, С++, C#, Python

Re: OR-WRT - Поддержка

Сообщение elmot » 21 авг 2012, 15:37

Rolf74 писал(а):Данная прошивка вносит какие либо изменения в бутлоадер?

Нет

Добавлено спустя 2 минуты 8 секунд:
svavan писал(а):Привет всем!

Вопросик есть. На роутере TP-Link TL-MR3020 пользуюсь внутренним UART-ом. Подправил все файлы так чтоб с вебморды все транслировалось на него и с него на микроконтроллер. Все работает, но только если сначала подключится на 2000 порт. Просто подключаешься и сразу отключаешься, после этого работает. Иначе сколько кнопки на нажимай до микроконтроллера ничего не доходит :(

Похоже у меня там не хватает одного пакета, поэтому скорость uart не переставляется. Постучись мне в скайп elmot73 часов в 22 по Москве, попробую что-нибудь сделать дистанционно.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Пред.След.

Вернуться в Open Robotics

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter