roboforum.ru

Технический форум по робототехнике.


проблеммы с STK500

Все что связана с заливкой программ в микроконтроллеры.

проблеммы с STK500

Сообщение Тритон » 16 ноя 2010, 01:18

Граждане прошу помощи . Перестал опознаваться программатор-отладчик STK500. Причина- не запускается тактовый генератор ATmega8. Судя по всему не запрограммирована ячейка CKPOT. Слабый выходной сигнал XTAL не может раскачать генератор Что делать? Если стоит защита- ячейку не изменить. Может кто-нибудь сталкивался с такой проблеммой.
Тритон
 
Сообщения: 2
Зарегистрирован: 17 дек 2008, 21:24

Re: проблеммы с STK500

Сообщение galex1981 » 16 ноя 2010, 02:19

Не пытались Мегу8 тактовать с внешнего генератора?
if(!Operate) Read(pDatasheet);
Аватара пользователя
galex1981
 
Сообщения: 4360
Зарегистрирован: 04 дек 2008, 22:44
Откуда: Камышин
Skype: galk-aleksandr1
прог. языки: C, C++, Assm, BasCom, VB, php
ФИО: Галкин Александр Владимирович

Re: проблеммы с STK500

Сообщение avr123.nm.ru » 16 ноя 2010, 02:33

Для начала зашунтировать кварц резистором 2 МОм и можно конденсаторы у кварца отпаять. Или кварц обновить.
А генератор на XTAL1 - это уже наверняка.
Читайте !
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14199
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: проблеммы с STK500

Сообщение Тритон » 16 ноя 2010, 18:27

galex1981 писал(а):Не пытались Мегу8 тактовать с внешнего генератора?

Спасибо, попробую в крайнем случае, если ничего не выйдет.

Добавлено спустя 2 минуты 51 секунду:
avr123.nm.ru писал(а):Для начала зашунтировать кварц резистором 2 МОм и можно конденсаторы у кварца отпаять. Или кварц обновить.
А генератор на XTAL1 - это уже наверняка.

Спасибо, сегодня же попробую.
Тритон
 
Сообщения: 2
Зарегистрирован: 17 дек 2008, 21:24


Вернуться в Программаторы

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter