roboforum.ru

Технический форум по робототехнике.


Проблема с stk200 (не шьется мега16)

Все что связана с заливкой программ в микроконтроллеры.

Проблема с stk200 (не шьется мега16)

Сообщение CALLIKA » 28 мар 2010, 17:08

Решил я вспомнить как программировать микроконтроллеры, перепаял немного свою тестовую платку а именно, перепаял выводы питания на новое место, добавил светодиод, полевик, и впаял дополнительную плату для 20пиновых МК, после пробежался тестером по контакам навсякий случай, замыканий нет! Решил прошить старую мегу 16, все подсоединил, навсякий проверил питание - все в порядке, в коджвижен жму программировать и мне выдает ошибку №1, ну думаю нада еше попробовать (ибо когда я давно шил этуже мегу она мне иногда выдавала ошибку но прошивал я ее с такой ошибкой раз 20), снова пробую зашить прогу и выдает ошибку №2, забеспокоился скачал понипрог попробовал чтение памяти из него - пишет ошибку (-24), ну решил последний раз попробовать кодвиженом и мне выдало ошибку №3...программатор вроде работает лампочки горят....я совсем запутался кто нибудь вообше понимает какой смысл несут эти ошибки и в чем может быть проблема ?
***
Только сейчас увидел что поспешил и фьюз нетото запрограммировал ! на картинке видно что bootrst = 0, вместо bootsz1. В этом проблема ?
Вложения
err2.JPG
err1.JPG
ошибка 2
err.JPG
ошибка 1
CALLIKA
 
Сообщения: 41
Зарегистрирован: 25 янв 2009, 00:08
Откуда: Великий Новгород
прог. языки: PHP

Вернуться в Программаторы

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

Mail.ru counter