roboforum.ru

Технический форум по робототехнике.


Проблема с lpt

Все что связана с заливкой программ в микроконтроллеры.

Проблема с lpt

Сообщение SiemX » 31 май 2009, 15:09

Собрал прогаматор 5 проводков, но неработает. Быстрей всего проблема в самом lpt. Стоит плата pci-lpt. На ножках програматора относительно gnd 3.4 вольта. Скачал прогу чтоб менять напряжение на ножках, но порт на прогу не реагирует как было 3,4 так и есть. Драйвер giveio установлен. windows xp
SiemX
 
Сообщения: 159
Зарегистрирован: 08 май 2009, 21:21
Предупреждения: -1

Re: Проблема с lpt

Сообщение MiBBiM » 31 май 2009, 16:16

шо за прога?
надо попробовать попереключать режимы порта в биосе
Tomorrow will be. Better
Аватара пользователя
MiBBiM
 
Сообщения: 1866
Зарегистрирован: 29 окт 2007, 18:11
Откуда: Пермь
прог. языки: Brainfuck/Basic/Delphi/C++/Lisp/x86asm/JavaScript

Re: Проблема с lpt

Сообщение SiemX » 31 май 2009, 16:54

А в биосе оно будет? Это ж в pci воткнуто а не в материнку встроено. есть еще варьянт попробывать в другой pci слот воткнуть.
Прога lpt_plus.exe запускатся в окошке типа доса
SiemX
 
Сообщения: 159
Зарегистрирован: 08 май 2009, 21:21
Предупреждения: -1

Re: Проблема с lpt

Сообщение MiBBiM » 31 май 2009, 17:05

SiemX писал(а):А в биосе оно будет?

сори, не заметил сразу)
вот прога поцивильнее
на компе есть второй лпт порт (всмысле встроенный в мать)? прст в таком случае надо будет выставлять другой "номер" порта
Tomorrow will be. Better
Аватара пользователя
MiBBiM
 
Сообщения: 1866
Зарегистрирован: 29 окт 2007, 18:11
Откуда: Пермь
прог. языки: Brainfuck/Basic/Delphi/C++/Lisp/x86asm/JavaScript

Re: Проблема с lpt

Сообщение SiemX » 31 май 2009, 17:19

Был бы встроенный плату бы не покупал :)
SiemX
 
Сообщения: 159
Зарегистрирован: 08 май 2009, 21:21
Предупреждения: -1

Re: Проблема с lpt

Сообщение MiBBiM » 31 май 2009, 17:22

может встроенный спалил :D
в диспетчере устройств-то появляется лпт порт?
Tomorrow will be. Better
Аватара пользователя
MiBBiM
 
Сообщения: 1866
Зарегистрирован: 29 окт 2007, 18:11
Откуда: Пермь
прог. языки: Brainfuck/Basic/Delphi/C++/Lisp/x86asm/JavaScript

Re: Проблема с lpt

Сообщение SiemX » 31 май 2009, 17:32

Появился после установки giveio. А при установе дров с диска что с платой был повился com которого на плате реально нет

Добавлено спустя 1 минуту 41 секунду:
А как тот драйвер что с прогой которую ты дал поставить? Где там в мастере нового оборудывания путь к файлу указывать ???
SiemX
 
Сообщения: 159
Зарегистрирован: 08 май 2009, 21:21
Предупреждения: -1

Re: Проблема с lpt

Сообщение MiBBiM » 31 май 2009, 17:35

ставится автоматом при запуске проги
Tomorrow will be. Better
Аватара пользователя
MiBBiM
 
Сообщения: 1866
Зарегистрирован: 29 окт 2007, 18:11
Откуда: Пермь
прог. языки: Brainfuck/Basic/Delphi/C++/Lisp/x86asm/JavaScript

Re: Проблема с lpt

Сообщение SiemX » 31 май 2009, 17:39

В проге нажимаю записать 00 всервано остается везде 1. Надо поискать где режим порта переключить ато сейчас spp а гдето читал что на epp работает
SiemX
 
Сообщения: 159
Зарегистрирован: 08 май 2009, 21:21
Предупреждения: -1

Re: Проблема с lpt

Сообщение MiBBiM » 31 май 2009, 17:44

а адрес порта нужный в проге вбил?
Вложения
scr2.JPG
прога
scr2.JPG (35.95 КиБ) Просмотров: 2607
scr.JPG
вот здесь можно посмотреть, первое число
Tomorrow will be. Better
Аватара пользователя
MiBBiM
 
Сообщения: 1866
Зарегистрирован: 29 окт 2007, 18:11
Откуда: Пермь
прог. языки: Brainfuck/Basic/Delphi/C++/Lisp/x86asm/JavaScript

Re: Проблема с lpt

Сообщение SiemX » 31 май 2009, 17:54

В проге написано в spp в диспетчере устройств ecp :crazy:
А где этот адрес там вбивать? И у меня там две надписи диапазон вовода вывода. В системе порт настроен как lpt1 в програматоре тож но програматор не прошивает

Добавлено спустя 2 минуты 14 секунд:
Скрин

Добавлено спустя 2 минуты 8 секунд:
Ой не заметил где вписывать

Добавлено спустя 2 минуты 21 секунду:
Вписал, ничего не изменилось
Вложения
lpt.JPG
SiemX
 
Сообщения: 159
Зарегистрирован: 08 май 2009, 21:21
Предупреждения: -1

Re: Проблема с lpt

Сообщение MiBBiM » 31 май 2009, 18:01

странно, почему два диапазона вывода :%)
в проге в место, указанное на скрине в предыдущем сообщении попробуй ввести вначале $EC00 , потом $E880
плата как называется?

Добавлено спустя 1 минуту 19 секунд:
вот ещё здесь с такой же проблемой разбираются, советуют виртуальную машину ставить
Tomorrow will be. Better
Аватара пользователя
MiBBiM
 
Сообщения: 1866
Зарегистрирован: 29 окт 2007, 18:11
Откуда: Пермь
прог. языки: Brainfuck/Basic/Delphi/C++/Lisp/x86asm/JavaScript

Re: Проблема с lpt

Сообщение SiemX » 31 май 2009, 18:22

Разобрал комп посмотрел плату. В другой слот не ставил потомучто тогда будет мешать охлаждению видюхи. Плата MCS9865/ Посмтрел там на порте цыферки, сейчас сомнения правильно ли собрал програматор. Вопрос к авр123 Изображение тут распиновка штекера который в порт втавлять или самого порта?

Добавлено спустя 1 минуту 57 секунд:
В прогу пробывал все адреса ввода вывода вводить
SiemX
 
Сообщения: 159
Зарегистрирован: 08 май 2009, 21:21
Предупреждения: -1

Re: Проблема с lpt

Сообщение SERGEY_M » 31 май 2009, 18:34

а плата на каком чипе?
кто производитель?
Попервой я тоже мудохался, правда с Байт-бластером...
не хотело Альтеру шить и программатор был не виден

в общем, пока подходящие дрова не нашел, от проблемы не избавился...
и дрова поверх иногда не ставились, приходилось удалять в сейвмоде полностью, перегружаться и ставить новые...
Аватара пользователя
SERGEY_M
 
Сообщения: 682
Зарегистрирован: 20 мар 2009, 12:45
Откуда: Украина, Одесса
ФИО: Сергей

Re: Проблема с lpt

Сообщение SiemX » 31 май 2009, 18:38

moschip mcs9865
SiemX
 
Сообщения: 159
Зарегистрирован: 08 май 2009, 21:21
Предупреждения: -1

След.

Вернуться в Программаторы

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

Mail.ru counter