roboforum.ru

Технический форум по робототехнике.


Проблема с AVRProg и AVR910

Все что связана с заливкой программ в микроконтроллеры.

Проблема с AVRProg и AVR910

Сообщение Lockdog » 25 мар 2008, 12:20

Купил, значит, себе вот такой программатор:
http://www.masterkit.ru/main/set.php?num=1153
Дрова установил, всё определилось.
Но когда запускаю AVRProg, то он мне выдаёт ошибку:
"No supported board found!".
Помогите мне, пожалуйста.

P.S. программатор установлен на COM1
Аватара пользователя
Lockdog
 
Сообщения: 642
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с AVRProg и AVR910

Сообщение rig » 25 мар 2008, 12:35

тамже если внимательно посмотреть и ссылки с инструкциями есть
http://www.masterkit.ru/info/magshow.php?num=364
Аватара пользователя
rig
 
Сообщения: 1437
Зарегистрирован: 03 авг 2007, 19:43
Откуда: Екатеринбург
прог. языки: Си, асм со словарем

Re: Проблема с AVRProg и AVR910

Сообщение Myp » 25 мар 2008, 12:41

а ты все статьи на сайте прочитал??

http://www.masterkit.ru/info/magshow.php?num=364

прошивку обновил и сделал всё как на картинках??
<telepathmode>На вопросы отвечает Бригадир Телепатов!</telepathmode>
Всё уже придумано до нас!
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 16527
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Re: Проблема с AVRProg и AVR910

Сообщение Lockdog » 25 мар 2008, 12:45

Я не чайник и всё сделал))) Там тем более описан процесс прошивки совершенно другого устройства, с помощью AVR910.
Я подключил AVR910, он определился, установил на него дрова, встали без проблем, в диспетчере устройств он находится на com1, а вот запускаю avrprog - он выкидывает сообщение...
Аватара пользователя
Lockdog
 
Сообщения: 642
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с AVRProg и AVR910

Сообщение Master » 25 мар 2008, 17:09

Юзайте CVavr с ним кажись еще отродясь ниукого проблем не было.
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: Проблема с AVRProg и AVR910

Сообщение Lockdog » 25 мар 2008, 17:44

Он мне тоже ошибку выкидывает)))
Write failed! win error code: 31. Я уже много програм перепробовал...ни одна не хочет определять программатор...в чём ещё косяк может быть?
Аватара пользователя
Lockdog
 
Сообщения: 642
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с AVRProg и AVR910

Сообщение rig » 25 мар 2008, 18:00

он очень похож на прогр-р протоса, я настраивал от безвыходности так:
набрал програмку меняющую состояние всех выводов с частотой 1 сек и смотрел как отрабатывает МК (грешил сначала на кварц - уронил). Прозвонил все сопротивлеия и сверил с номиналом. Прошил поновой пони прогом. есть другой программатор, прочитать МК?
мои косяки оказались
в первом случае шины в сторону ЮСБ коротили, в частности там где 1 МОм получалось меньше.
во втором прошивал кодевиженом, почемуто не прошился МК, понипрогом прошился нормально.
Аватара пользователя
rig
 
Сообщения: 1437
Зарегистрирован: 03 авг 2007, 19:43
Откуда: Екатеринбург
прог. языки: Си, асм со словарем

Re: Проблема с AVRProg и AVR910

Сообщение Lockdog » 25 мар 2008, 20:42

Дело в том, что этот прогромматор полностью готовый, то есть спаянный и прошитый. И предполагается, что работать должен "из коробки"...
Аватара пользователя
Lockdog
 
Сообщения: 642
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с AVRProg и AVR910

Сообщение rig » 25 мар 2008, 21:08

тогда придется вернуть производителю.
Аватара пользователя
rig
 
Сообщения: 1437
Зарегистрирован: 03 авг 2007, 19:43
Откуда: Екатеринбург
прог. языки: Си, асм со словарем

Re: Проблема с AVRProg и AVR910

Сообщение Lockdog » 25 мар 2008, 22:04

А нет ещё каких-то способов проверить? потому что дрова ведь ставятся и в системе он нормально определяется...
Аватара пользователя
Lockdog
 
Сообщения: 642
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с AVRProg и AVR910

Сообщение rig » 26 мар 2008, 07:14

если слева со стороны юсб работает, а справа (выход СПИ) нет самое простое разводка на разъеме не та, может даже не в программаторе дело а в твоем девайсе, там то точно все ок?
пробовал другим программатором шить?
прозвони питание, общие провода, сигнальные в режиме программирвания переключаются.
Аватара пользователя
rig
 
Сообщения: 1437
Зарегистрирован: 03 авг 2007, 19:43
Откуда: Екатеринбург
прог. языки: Си, асм со словарем

Re: Проблема с AVRProg и AVR910

Сообщение Lockdog » 26 мар 2008, 13:28

Если я правильно понимаю, то сам программатор, не подключённый к программируемому девайсу, уже должен определяться программой и не должно вылезать сообщение "No supported device found!". А такого не происходит... Я ничем другим прошить не могу, потому что, я уж полгода мучался с другими программаторами из-за отсутствия на материнке лпт порта, а после покупки карты расширения для лпт, ситуация не улучшилась... Вот я и купил готовый программатор, по разумной цене... А если брать в расчёт неправильность собранного мной девайса, то тут вероятность ИМХО нулевая, потому что я собрал наипростейшую схему мигания светодиода, дабы проверить работу самого программатора. Может проблемы с программным обеспечением или в биосе что-то покрутить надо? Что же за ужас такой, никак не могу нормально заниматься любимым делом, из-за такой ерунды... Помогите, плиз...
Аватара пользователя
Lockdog
 
Сообщения: 642
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с AVRProg и AVR910

Сообщение Myp » 26 мар 2008, 13:36

мб генетическая ошибка? :oops:
<telepathmode>На вопросы отвечает Бригадир Телепатов!</telepathmode>
Всё уже придумано до нас!
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 16527
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Re: Проблема с AVRProg и AVR910

Сообщение Lockdog » 26 мар 2008, 13:51

Пасиба, очень смешно...
Аватара пользователя
Lockdog
 
Сообщения: 642
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с AVRProg и AVR910

Сообщение Master » 26 мар 2008, 15:58

На других компах купленный программатор не опробывал?
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

След.

Вернуться в Программаторы

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter