roboforum.ru

Технический форум по робототехнике.


AVRISP STK500 V2.0 умер?

Все что связана с заливкой программ в микроконтроллеры.

AVRISP STK500 V2.0 умер?

Сообщение Renboo » 20 июл 2011, 19:11

Здравствуйте.
Помогите пожалуйста разобраться с проблемой, которая возникла по собственной дурости.

Имеется AVRISP STK500 V2.0 привезенный из Гонконга. Пытался прошить им ATmega8A-PU через AVRstudio 4. Прошиваться не хотело, как потом выяснил из-за того, что контакты перепутаны китайцами (надо внимательней смотреть их инструкции). В процессе попыток прошить МК в AVRstudio 4 в окне, где выбираются Flash и EEPROM для последующей загрузки, на вкладке Board была нажата кнопка Upgrade. (находится в самом низу). В результате начался апгрейд, 30 секунд спустя на программаторе перестал гореть диод, а компьютер завис. Ожидания ничего не дали, пришлось перегрузиться.
Теперь при подключении программатора компьютер отрабатывает звук, как при подключении USB устройства, но AVRstudio его теперь не видит. Также не загорается диод.
Пытался замкнуть нужные контакты по инструкции для перепрошивке, но AVRstudio ругается: "No supported board found!".

Есть ли идеи как реанимировать? Помогите пожалуйста.
Renboo
 
Сообщения: 2
Зарегистрирован: 20 июл 2011, 18:36

Re: AVRISP STK500 V2.0 умер?

Сообщение avr123.nm.ru » 20 июл 2011, 20:55

У него не аппаратный USB UART ? Просто название похоже на прогер Семенова Михаила но у него аппаратный USB UART на CP2102.

Если у вас програмный то самое лучшее ИМХО для начала попробовать ваш прогер поставить заново на "чистом" ПК. Если чистого нет, то на ваш поставьте как вторую ОСь WinXP и попробуйте.

Вряд ли как то с ПК можно было запороть прошивку прогера, так что скорей всего глюк в ПК и он програмный.
Читайте !
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14199
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: AVRISP STK500 V2.0 умер?

Сообщение Renboo » 21 июл 2011, 02:01

USB UART Тоже аппаратный через FT232RL (насколько я понимаю).

Спасибо за совет, на виртуальной машине удалось перепрошить. Теперь он подает признаки жизни, мигая диодами.
Попробывал прошить ATmega8A-PU, но здесь меня встретила еще одна проблема: Постоянно вылезает ошибка, в которой говорится, чтобы я проверил правильность подключения, чтобы выставил частоту ISP менее 1/4 частоты устройства.
Если нужно, то могу запостить полный текст ошибки.
Если микроконтроллер подключен верно, то как я понимаю не должно быть таких ошибок. Без микроконтроллера проблема вылезает также самая.
Помогите пожалуйста определить работает программатор или нет?
Renboo
 
Сообщения: 2
Зарегистрирован: 20 июл 2011, 18:36

Re: AVRISP STK500 V2.0 умер?

Сообщение avr123.nm.ru » 21 июл 2011, 12:20

Renboo писал(а):Постоянно вылезает ошибка, в которой говорится, чтобы я проверил правильность подключения, чтобы выставил частоту ISP менее 1/4 частоты устройства.


Это значит нет связи с чипом и в этом окне перечислены типовые причины этого.

Надо снизить частоту такта в закладке "мэйн" прогера студии, подать внешний такт на ножку XTAL1

Провериь наличие сигналов на проводах программирования подав из через резистор 10-50 кОм на звуковой вход ПК,
Читайте !
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14199
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: AVRISP STK500 V2.0 умер?

Сообщение avr123.nm.ru » 22 июл 2011, 22:51

Как успехи ?
Читайте !
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14199
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8


Вернуться в Программаторы

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter