roboforum.ru

Технический форум по робототехнике.

 

MS Robotics Studio - вопросы установки и настройки

Обсуждаем рождающиеся мысли и результаты экспериментов.

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение SMT » 01 дек 2008, 17:59

для них я свое разрабатывал (не закончил еще), но старался это внешне похоже на VPL из MSRS сделать
SMT
 
Сообщения: 1158
Зарегистрирован: 23 авг 2008, 22:28
Откуда: Санкт-Петербург
ФИО: Сергей

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение =DeaD= » 01 дек 2008, 19:05

2SMT: А какой дальнейший ваш план? Продолжать делать свой симулятор? В русле MSRS не собираетесь пока дальше двигаться? И до куда в освоении MSRS вы дошли? Кроме тех 5 уроков делали что-нибудь еще?
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение SMT » 01 дек 2008, 20:09

для начала, по традиции, предлагаю мне не выкать 8)

Если-бы я нашел что-то типа своей разработки, и меня это устроило - я бы позавидовал немного, а затем стал этим пользоваться.

(уже вроде описывал) в MSRS попробовал сначала симулятор - погонял трипода, а затем в следующих топиках мануала было предложено подключить реальное железо. Тогда я взялся за сервисы - хотел с их помощью через ZigBee модули управлять "дубовым" устройством - вкл/выкл. двигатели, получить данные с датчиков, реагировать на них и т.п. мануалы потихоньку изучались, тестовые сервисы по ним успешно запускались. Но встала проблема доступностью всех этих приятностей ребенку - тогда все было отложено, стартовал упомянутый выше топик, а затем потребовалось "правильное" железо. И вот вчера Минибот успешно начал ездить под управлением PC терминала по командам передаваемым через UART организованный на канале из пары ZigBee модулей. Энкодеры и датчики линии были оттестированы немного раньше (на прототипе).
Теперь можно вновь взяться за:
1.свою отложенную разработку
2.MSRS
первое - хорошо простотой и сравнительной доступностью, но требует доработки. Не требуется практически никаких специальных знаний и значительных компьютерных ресурсов.
второе - более "модно" (с) EdGull. Что оно требует ты уже рассказал (одна или две студии, память, интернет для закачки и т.п.) Безусловно для меня и некоторого круга [знающих или интересующихся] людей это направление интереснее.
оба направления считаю перспективными и постараюсь совмещать (по мере наличия времени).
Последний раз редактировалось SMT 01 дек 2008, 22:02, всего редактировалось 1 раз.
SMT
 
Сообщения: 1158
Зарегистрирован: 23 авг 2008, 22:28
Откуда: Санкт-Петербург
ФИО: Сергей

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение =DeaD= » 01 дек 2008, 23:04

Пока времени катострофически мало + пока рано мне еще что-то про MSRS говорить, надо сначала пощупать :)

Добавлено спустя 2 часа 9 минут 53 секунды:
2SMT: У меня затык на запуске сервиса, вместо ХМЛя обещенного мне сразу по "http://localhost:50000/servicetutorial1" выдаётся какой-то дэшборд с менюшкой в левом окне:
System Services
Home

Control Panel

Service Directory

Debug and Trace Messages

Manifest Load Results

Security Manager

Resource Diagnostics

Developer Resources
Welcome

What's New

Getting Started

Documentation

Tutorials

Discussion Forums

About Microsoft Robotics


При этом на команду dsshost /port:50000 /manifest:"samplesServiceTutorial1ServiceTutorial1.manifest.xml"
был получен ответ:
* Service started [12/01/2008 23:59:39][http://dead-home:50000/directory]
* Service started [12/01/2008 23:59:40][http://dead-home:50000/constructor]
* Service started [12/01/2008 23:59:40][http://dead-home:50000/console/output]

* Starting manifest load: file:///C:/Documents and Settings/dead.DEAD-HOME/Mic
rosoft Robotics Dev Studio 2008 Express/samples/ServiceTutorial1/ServiceTutorial
1.manifest.xml [12/01/2008 23:59:40][http://dead-home:50000/manifestloaderclient
]
Rebuilding contract directory cache. This will take a few moments ...
Contract directory cache refresh complete
* Service started [12/01/2008 23:59:42][http://dead-home:50000/servicetutorial
1/9f1c76c3-f322-4958-9e07-cd52991bc52f]
* Manifest load complete [12/01/2008 23:59:42][http://dead-home:50000/manifest
loaderclient]


Добавлено спустя 2 минуты 10 секунд:
есть мысли чего это может быть? По идее в туториале написано что я должен увидеть какой-то XML-SOAP ответ.
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение SMT » 01 дек 2008, 23:46

возможно я не правильно понял вопрос, попробую так показать
когда запускаешь сервис (F5 или Run), он компилится и стартует. Затем набираешь в браузере http://YourMachineName:50000/
авторизуешься, и входишь в панель управлениями сервисами.
20081201_1.png

затем щелкни пару раз по нужному сервису и увидишь XML - это то, о чем ты спрашивал?
20081201_2.png

в этой панели можно стартовать\остановить доступные сервисы (пункт "Control Panel"). Щелкни по своему сервису - снова xml. "Drop" - остановить сервис
20081201_3.png

получить доступ к логу (пункт "Debug and Trace messages") - можно фильтровать
20081201_4.png
SMT
 
Сообщения: 1158
Зарегистрирован: 23 авг 2008, 22:28
Откуда: Санкт-Петербург
ФИО: Сергей

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение =DeaD= » 02 дек 2008, 01:37

У меня по адресу localhost:50000 открывается:

Добавлено спустя 1 минуту 54 секунды:
Может у меня кривой IE ? но вроде всё остальное в нём нормально, наверное надо более позднюю версию ставить, чем 6-я.
Вложения
msrs0.jpg
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение SMT » 02 дек 2008, 02:30

у меня и в IE (7) и в Opere открывается - требует авторизацию (стандартным окном - имя\пароль) и дальше открывает список сервисов
была смешная штука поначалу - по умолчанию браузером значилась Opera, и когда я пытался открывать в IE тот url - ничего не происходило, а потом случайно увидел, что в опере меня ожидало окно авторизации. Как только я авторизовался и отметил галку "сохранить пароль" - дальше все было нормально. Теперь по умолчанию IE, так что проблем нет - сразу вижу авторизацию.
Вместо localhost попробуй имя машины (и при авторизации MachineName/YourLoginName)
SMT
 
Сообщения: 1158
Зарегистрирован: 23 авг 2008, 22:28
Откуда: Санкт-Петербург
ФИО: Сергей

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение =DeaD= » 02 дек 2008, 22:54

Короче и правда IE тупил, Firefox нормально работает. Я удивляюсь всё дальше и дальше отличной совместимости продуктов MS :o
SMT писал(а):авторизуешься, и входишь в панель управлениями сервисами.

Авторизоваться как? Т.е. какой логин и пароль там указывать?
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение SMT » 02 дек 2008, 23:13

имя пользователя, под которым ты залогинен - можешь посмотреть в папке "Documents and Settings" (или в "Users" - для Висты)- все имена сущетсвующих пользователей. Еще можно посмотреть в "Управлении пользователями"

Пароль - тот, который ты вводишь, логинясь в комп - если он пустой, наверное его не нужно.
SMT
 
Сообщения: 1158
Зарегистрирован: 23 авг 2008, 22:28
Откуда: Санкт-Петербург
ФИО: Сергей

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение =DeaD= » 02 дек 2008, 23:30

SMT писал(а):имя пользователя, под которым ты залогинен - можешь посмотреть в папке "Documents and Settings" (или в "Users" - для Висты)- все имена сущетсвующих пользователей. Еще можно посмотреть в "Управлении пользователями"

Пароль - тот, который ты вводишь, логинясь в комп - если он пустой, наверное его не нужно.

В том то и фишка, что это не работает :o у меня пароля не было - я даже специально его установил на комп :-(
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение SMT » 02 дек 2008, 23:42

попробуй_имя_компа\имя_пользователя
попробуй завести нового пользователя (администратором)
возможно при установке студий появились новые роли типа "...Debugging..." - добавь себя туда
посмотри что пишется в EventLog
SMT
 
Сообщения: 1158
Зарегистрирован: 23 авг 2008, 22:28
Откуда: Санкт-Петербург
ФИО: Сергей

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение =DeaD= » 02 дек 2008, 23:47

Короче нашел выход временный - в каталог store кидается файл

SecuritySettings.xml

с содержимым:
Код: Выделить всёРазвернуть
<?xml version="1.0"?>
<SecuritySettings xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://schemas.microsoft.com/robotics/2008/02/security.html">
  <AuthenticationRequired>false</AuthenticationRequired>
  <OnlySignedAssemblies>false</OnlySignedAssemblies>
</SecuritySettings>


Что вырубает нафиг систему авторизации.

Как выяснил в англоязычных степях MSDN'а - я не один с такими граблями.

Добавлено спустя 1 минуту 48 секунд:
Вот ссылка на их описание и солюшен к проблеме: http://forums.microsoft.com/MSDN/ShowPo ... 8&SiteID=1

Добавлено спустя 1 минуту 36 секунд:
А вот еще забавная заметка:
It is necessary to have a password, an empty password isn't allowed to log on in the webbrowser.

Охренительно они придумали - я оказывается должен был интуитивно догадаться не только до того какой туда пароль ввести, но еще и что, если у меня пустой пароль, то они его не примут. И это всё безо всяких комментов, сообщений внятных и т.п.
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение SMT » 02 дек 2008, 23:47

еще файрвол проверь - доступен ли порт и приложение

пока на локальном компе, наверное можно и так. Но решение все-же должно быть - я не на одном компе это пробовал (и на разных виндах), но везде пароли присутствовали 8)
SMT
 
Сообщения: 1158
Зарегистрирован: 23 авг 2008, 22:28
Откуда: Санкт-Петербург
ФИО: Сергей

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение =DeaD= » 02 дек 2008, 23:59

Мде, я заинтригован. Сейчас убрал этот файлик, перезапустил службу и всё заработало. Даже авторизации не спросило.

Добавлено спустя 2 минуты 11 секунд:
Красиво идём:

Step 1: Create a Service - на самом деле файл .sln не создаётся. Нужно запускать файл ServiceTutorial1.csproj
Step 2: Start a Service - угадай какой пароль, а еще пустой нельзя :)

Боюсь что будет дальше :) шагов ведь целых 6 штук даже в первом из 12 туториалов :crazy:

Добавлено спустя 7 минут 2 секунды:
Ну вот, не успел обрадоваться, авторизация опять врубилась :) не помог даже перестарт системы, пришлось вырубить её.

Пока вижу в ответе от сервиса:
<?xml version="1.0" encoding="utf-8" ?>
- <ServiceTutorial1State xmlns:s="http://www.w3.org/2003/05/soap-envelope" xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing" xmlns:d="http://schemas.microsoft.com/xw/2004/10/dssp.html" xmlns="http://schemas.tempuri.org/2006/06/servicetutorial1.html">
<Member>This is my State!</Member>
</ServiceTutorial1State>
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: MS Robotics Studio - вопросы установки и настройки

Сообщение SMT » 03 дек 2008, 00:03

дальше все должно быть нормально. авторизация требуется только один раз, если не ошибаюсь - пока не перезапустишь студию.
создание проектов в коммандной строке - это архаизм, оставшийся с прежних CTP, когда MSRS не была интегрированна в студию.
sln файл можно создавать самостоятельно в студии - Create new project\empty solution, затем добавить туда свой проект. Это удобно, когда пару сервисов с подписками будешь создавать - два проекта в одном солюшне. Вообще и проекты я тоже прямо в студии создавал потом.
Еще тонкость с мануалом. Если я не ошибаюсь, каждый новый шаг\проект имеет свой нэймспейс, хотя подразумевается, что они просто развиваются последовательно. По этому я использовал свой нэймспейс - это одновременно мобилизует внимание :)

Пока вижу в ответе от сервиса...

поздравляю :beer: ты в начале большого, но веселого пути!
сначала многое меня озадачивало, но когда начал разрабатывать свою (сильно упрощенную версию) - проявилась логика.
SMT
 
Сообщения: 1158
Зарегистрирован: 23 авг 2008, 22:28
Откуда: Санкт-Петербург
ФИО: Сергей

Пред.След.

Вернуться в Идеи

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter