roboforum.ru

Технический форум по робототехнике.

 

простой робот.....

Раздел создан специально для людей которым интересна робототехника, но в силу разных причин они не знают с чего начать.
Задавайте ваши вопросы, какими бы простыми они не казались, постоянные посетители форума постараются ответить на них по мере своих сил.
Робот своими руками. Самодельный робот.

простой робот.....

Сообщение rain_cbc » 27 фев 2009, 20:07

сделал http://myrobot.ru/stepbystep/r_firstbot1.php
вроди все работает.......только вот маленькая проблемка......
прошил мк.......но моторчики не крутятся......проверил тестером туда доходит всего +0.3V
перепаял чуть подал отдельно питание на Vs сначала +3V......потом+4.5V.......всеравно тоже самое......что это может быть...думал неисправна L293D,поставил другую тоже самое......
убрал сегодня отдельное питание моторов......заработал один моторчик....но крутится безпрерывно......хотя по программе не должен.... :cry:
rain_cbc
 
Сообщения: 22
Зарегистрирован: 22 дек 2007, 09:30
Откуда: Киев
ФИО: Денис

Re: простой робот.....

Сообщение EdGull » 27 фев 2009, 20:09

у нас здесь с незаполненым городом плохая примета совета спрашивать... :wink:
Аватара пользователя
EdGull
 
Сообщения: 10211
Зарегистрирован: 28 дек 2004, 20:33
Откуда: Тольятти
Skype: Ed_Gull
прог. языки: Bascom AVR Basic
ФИО: Гуль Эдуард Викторович

Re: простой робот.....

Сообщение realsystem » 27 фев 2009, 20:14

значит МК не включает мотор, неправильная программа. Это если просто навскидку. А так может быть все что угодно, от плохой пайки, до неправильной схемы и сгоревших компонентов :)
realsystem
 
Сообщения: 629
Зарегистрирован: 01 фев 2009, 01:32
Откуда: Саратов
Skype: realsystem_stas
прог. языки: C, Bash, Perl
ФИО: Станислав

Re: простой робот.....

Сообщение rain_cbc » 27 фев 2009, 20:31

прошу прощения......но с чем незаполненым?
компоненты вроди целые...пробовал на 2-х мк и 2-х l293d....
все сделано на макетке...соединено проводами.....
программа с сайта таамже.......вроди правельная... :pardon:
rain_cbc
 
Сообщения: 22
Зарегистрирован: 22 дек 2007, 09:30
Откуда: Киев
ФИО: Денис

Re: простой робот.....

Сообщение EdGull » 27 фев 2009, 20:41

город у тебя не заполнен
Аватара пользователя
EdGull
 
Сообщения: 10211
Зарегистрирован: 28 дек 2004, 20:33
Откуда: Тольятти
Skype: Ed_Gull
прог. языки: Bascom AVR Basic
ФИО: Гуль Эдуард Викторович

Re: простой робот.....

Сообщение rain_cbc » 27 фев 2009, 20:48

заполнил :)
rain_cbc
 
Сообщения: 22
Зарегистрирован: 22 дек 2007, 09:30
Откуда: Киев
ФИО: Денис

Re: простой робот.....

Сообщение RoboTok » 27 фев 2009, 20:51

Вы неправильно собрали схему или прошили криво...

П.С.
Я тоже эту схему собрал криво потом мучался искал баги :ROFL:
Последний раз редактировалось RoboTok 27 фев 2009, 20:53, всего редактировалось 1 раз.
Аватара пользователя
RoboTok
 
Сообщения: 1060
Зарегистрирован: 04 фев 2008, 13:18
Откуда: Москва
прог. языки: PHP

Re: простой робот.....

Сообщение almazkazan » 27 фев 2009, 20:57

а ты в мейкфайле # MCU name и т.п под мегу8 поменял?

Добавлено спустя 5 минут 49 секунд:
просто если делал как на том сайте сказано, то получается использовал WinAVR- programmers notepad. А там мэйкфайл менять надо, перед компиляцией, под конкретную микруху.
“Но мы же еще ​живы, чувак, это же круто…”
Аватара пользователя
almazkazan
 
Сообщения: 97
Зарегистрирован: 04 окт 2008, 17:47
Откуда: казань, респ. Татарстан, россия
прог. языки: c++, c#, asm

Re: простой робот.....

Сообщение rain_cbc » 27 фев 2009, 21:14

с мейк файлом это я знаю.......делал....
я могу фотку выкинуть...но врядли ктото чтото поймет :D
там проводками соеденено)))))
а вчем у вас баги были?
rain_cbc
 
Сообщения: 22
Зарегистрирован: 22 дек 2007, 09:30
Откуда: Киев
ФИО: Денис

Re: простой робот.....

Сообщение RoboTok » 27 фев 2009, 21:25

не помню
Аватара пользователя
RoboTok
 
Сообщения: 1060
Зарегистрирован: 04 фев 2008, 13:18
Откуда: Москва
прог. языки: PHP

Re: простой робот.....

Сообщение EdGull » 27 фев 2009, 21:41

1. от чего питаешся?
2. драйверами на прямую без МК пробовал рулить?
Аватара пользователя
EdGull
 
Сообщения: 10211
Зарегистрирован: 28 дек 2004, 20:33
Откуда: Тольятти
Skype: Ed_Gull
прог. языки: Bascom AVR Basic
ФИО: Гуль Эдуард Викторович

Re: простой робот.....

Сообщение MiBBiM » 27 фев 2009, 21:58

0.3V - это ж низкий уровень. мб ресет к плюсу питания подтянуть, мало ли мк сбрасывается...
прошивка проходит верификацию после заливки?
фьюзы на внешний такт выставили?
Tomorrow will be. Better
Аватара пользователя
MiBBiM
 
Сообщения: 1866
Зарегистрирован: 29 окт 2007, 18:11
Откуда: Пермь
прог. языки: Brainfuck/Basic/Delphi/C++/Lisp/x86asm/JavaScript

Re: простой робот.....

Сообщение citizen » 27 фев 2009, 22:06

Можно попробовать прошивку в proteus проверить.
Аватара пользователя
citizen
 
Сообщения: 315
Зарегистрирован: 12 окт 2008, 12:40
Откуда: Красногорск, Подмосковье

Re: простой робот.....

Сообщение realsystem » 28 фев 2009, 03:15

И схему :)
realsystem
 
Сообщения: 629
Зарегистрирован: 01 фев 2009, 01:32
Откуда: Саратов
Skype: realsystem_stas
прог. языки: C, Bash, Perl
ФИО: Станислав

Re: простой робот.....

Сообщение rain_cbc » 28 фев 2009, 13:34

еще пару тестов проведу и напишу))))
rain_cbc
 
Сообщения: 22
Зарегистрирован: 22 дек 2007, 09:30
Откуда: Киев
ФИО: Денис

След.

Вернуться в Новичкам или основы основ роботостроения.

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4

Mail.ru counter