roboforum.ru

Технический форум по робототехнике.

 

Почему мой робот не работает????????

Раздел создан специально для людей которым интересна робототехника, но в силу разных причин они не знают с чего начать.
Задавайте ваши вопросы, какими бы простыми они не казались, постоянные посетители форума постараются ответить на них по мере своих сил.
Робот своими руками. Самодельный робот.

Сообщение avr123.nm.ru » 13 авг 2007, 13:11

space9999999 писал(а):это на что - нибудь влияет или без разницы :?:


пофигу.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение space » 13 авг 2007, 17:22

Master писал(а):Нужно подключать к плюсу все что имеет в своем названии VCC, т. е. AVcc тоже нужно подключать.

А почему :?  :?:  в этой схеме + и - не подключали к AGND и AVCC.
Вложения
bot2.gif
Аватара пользователя
space
 
Сообщения: 548
Зарегистрирован: 17 июн 2007, 23:44
Откуда: Тула
прог. языки: Bascom AVR Basic, CodeVisionAVR
ФИО: Замотаев Кирилл Игоревич

Сообщение space » 14 авг 2007, 07:50

space9999999 писал(а):Только вот ещё проблемка :evil: . В AutoProg 16 фьюзов :shock:  ((15)0000000000000000(0)) или может 1 фьюз от нуля, который не считать. И ещё надо нажимать плюс, который находится правее в углу. Я имею в виду после того как записал фьюзы.

Вообщем разобрался я с фьюзами, пробовал их устанавливать, но все равно ни чего не работает. Хочу попробовать с atmega8 может с ним получится, а на atmega16 наверняка что - нибудь испортил поэтому ни одна программа не работает. Так что спасибо всем за помощь!
Аватара пользователя
space
 
Сообщения: 548
Зарегистрирован: 17 июн 2007, 23:44
Откуда: Тула
прог. языки: Bascom AVR Basic, CodeVisionAVR
ФИО: Замотаев Кирилл Игоревич

Сообщение avr123.nm.ru » 14 авг 2007, 11:25

space9999999 писал(а):А почему :?  :?:  в этой схеме + и - не подключали к AGND и AVCC.


Потому что люди не читали  avr123.nm.ru/07.htm  и доку по МК.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение space » 21 авг 2007, 21:32

Всем снова здрасте! Вот разобрался наконец-то с програматором зашил программу в мк ATmega8. Моя программа так как надо не работает, а прога простого моб. робота работает, но не совсем правильно :( , если от переднего бампера поступает сигнал и колёса двигуются назад, то от заднего тоже самое хотя должны крутится вперёд. В программе написано всё как надо. Может подскажете, что не так :?:  :?:  :?:
Кстати вот весь проект со схемой, печаткой и прогой :)
Вложения
Простой мобильный робот.rar
(972.23 КиБ) Скачиваний: 42
Аватара пользователя
space
 
Сообщения: 548
Зарегистрирован: 17 июн 2007, 23:44
Откуда: Тула
прог. языки: Bascom AVR Basic, CodeVisionAVR
ФИО: Замотаев Кирилл Игоревич

Пред.

Вернуться в Новичкам или основы основ роботостроения.

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 6

Mail.ru counter