roboforum.ru

Технический форум по робототехнике.

 

LM393

Резисторы, транзисторы, конденсаторы, микросборки, чип компоненты ...
Вопросы согласования управляющих модулей с периферией.

LM393

Сообщение Smerch44 » 16 окт 2006, 12:59

Всем привет! Уменя такая проблема делаю одну штуковину включаю по схеме компаратор LM393 резистор 5к и питание там ну понятно короче он должен сравнить два сигнала затем подать на транзистор кт371 включеныый с ОБ отфильтровать его через диод и конденсатор, усилить ОУ. Так вот когда я включаю его по схеме включения и НЕ соединию с транзистором осциллограф показывает мне то что я смоделировал в МИкрокапе 7.0. Стоит мне соединить выход компаратора с транзистором схема перестает работать. Но только поменяю точку приложения опорного напряжения комапаратора схема работает те.на транзисторе выходе ОУ то что надо! А на выходе компаратора только 5 в и все осциллограф не берет! Что мне делать все многократно проверено проверил выход компаратора вроде не паленые! Помогите советом!
Smerch44
 
Сообщения: 46
Зарегистрирован: 31 июл 2006, 19:36
Откуда: Ульяновск

Сообщение -= Александр =- » 16 окт 2006, 20:14

Схему в студию!
Аватара пользователя
-= Александр =-
Мастер Самоделкин
 
Сообщения: 3664
Зарегистрирован: 11 окт 2004, 19:20
Откуда: Россия, СПб
прог. языки: C++, VB, asm
ФИО: Курмис Александр Андреевич

Сообщение Smerch44 » 28 окт 2006, 17:42

-= Александр =- писал(а):Схему в студию!

Выношу схему !
Заявляемое устройство включает в себя генератор импульсов 1, выходы которого подключены к аналоговым ключам м1,2,3. Выходы ключа м1 соединены с входами опорного и измерительного плеча датчика, входы ключа м2 соединены с выхода датчика. Оба плеча датчика подключены к общей шине при этом опорное плечо датчика подключено к первому входу компаратора, измерительное плечо к инвертирующему входу. Выход компаратора соединен с базой транзистора, выход транзистора соединен с катодом диода при этом коллектор транзистора подключено к источнику напряжения +Uпит. Анод диода подключен к конденсатору, третьему аналоговому ключу м3 и операционному усилителю. Сигнал с выхода усилителя поступает на АЦП .
Мужики не работает правильно! Помогите!
Вложения
Shem.gif
Shem.gif (9.25 КиБ) Просмотров: 9738
Smerch44
 
Сообщения: 46
Зарегистрирован: 31 июл 2006, 19:36
Откуда: Ульяновск

Сообщение Smerch44 » 19 ноя 2006, 18:13

Братцы! Ну у кого какие мысли будут?Почему эта схема не работает в реале! Выводы я не перепутал диод  правильно включил делал 2 аналогичных платы один и тот же результат! Работает половина схемы! У кого какие мысли все таки будут! Рассмотрю:))
Smerch44
 
Сообщения: 46
Зарегистрирован: 31 июл 2006, 19:36
Откуда: Ульяновск

Сообщение Vovan » 19 ноя 2006, 20:18

Первое что сразу бросилось в глаза - подключение транзистора Q1, он сидит "как воробей на проводе". Через конденсатор к нему никак "-" питания не придёт... Может что-то не дорисовано? И ещё Вы пишите (выше) что транзюк включён по схеме с ОБ - этого не видно! На базу и на коллектор я вижу только "+" питания, а эмитер включён на выход... Чё-то тут непонятное... При включении транзистора по схеме с ОБ, само название (ОБ) говорит о том что на базу должно поступать "напряжение" общего питания (в данном случае "-"). Если транзистор здесь, всё же, включён по схеме с ОЭ, то тоже не верно. Иными словами: транзистор по-любому остался без питания. И чего от него хотеть? :)
Разберитесь с вопросом правильного включения транзистора и всё.
___________
С уважением
Vovan
Аватара пользователя
Vovan
 
Сообщения: 3340
Зарегистрирован: 05 окт 2005, 12:03
Откуда: Литва
прог. языки: asm

Сообщение Smerch44 » 20 ноя 2006, 11:02

Vovan писал(а):Первое что сразу бросилось в глаза - подключение транзистора Q1, он сидит "как воробей на проводе". Через конденсатор к нему никак "-" питания не придёт... Может что-то не дорисовано? И ещё Вы пишите (выше) что транзюк включён по схеме с ОБ - этого не видно! На базу и на коллектор я вижу только "+" питания, а эмитер включён на выход... Чё-то тут непонятное... При включении транзистора по схеме с ОБ, само название (ОБ) говорит о том что на базу должно поступать "напряжение" общего питания (в данном случае "-"). Если транзистор здесь, всё же, включён по схеме с ОЭ, то тоже не верно. Иными словами: транзистор по-любому остался без питания. И чего от него хотеть? :)
Разберитесь с вопросом правильного включения транзистора и всё.
___________
С уважением
Vovan

Здраствуйте! Спасибо за ответ! Нет согласно микрокапу все работает. А вот в реале! Транзистор кт371 вчера попробовал подменить его 315 .
Соединил с компаратором на эммитере есть характеристика вроде все верно! Подключаю к остальной части схемы и все пропвдает.. А транзистор походу сгорел(((
Smerch44
 
Сообщения: 46
Зарегистрирован: 31 июл 2006, 19:36
Откуда: Ульяновск

Сообщение -= Александр =- » 20 ноя 2006, 15:50

Вы скажите лучше что это такое и для чего делается, мож чего по-проще предложим...  :wink:
Аватара пользователя
-= Александр =-
Мастер Самоделкин
 
Сообщения: 3664
Зарегистрирован: 11 окт 2004, 19:20
Откуда: Россия, СПб
прог. языки: C++, VB, asm
ФИО: Курмис Александр Андреевич

Сообщение Smerch44 » 20 ноя 2006, 17:20

-= Александр =- писал(а):Вы скажите лучше что это такое и для чего делается, мож чего по-проще предложим...  :wink:

Что это такое? отвечаю! Я учусь в универе занимаюсь разработкой датчиков индуктивностей. Для чего ? Тестирование эл. машин. Была создана схема до той которой вы видите в файле все отлично работает !
устройство содержит генератор импульсов, выходы которого соединены с  ключами,  собственно индуктивный датчик, состоящий из опорного и измерительного плеча, схему обеспечивающую сравнения импульсов и их усиления. Изменение индуктивности чувствительного элемента зависит от длительности переходного процесса, управляемое  ключами. Каждое плечо содержит катушку индуктивности, и конденсатор. Каждый ключ соединен с генератором импульсов. Выходы плеч датчиков подключены к входам схемы сравнения компаратора. Остальные выходы к общей шине. Выходы компаратора соединены с базой транзистора, эмиттер с фильтрующей цепью и усилителем сигнала.  
Катушки обычные намотанные на пермаллой ( жуть) или дроссели дпм,
компаратор LM 393, трнз кт 371 диодный мост микросхемы ключи, усилок 1401уд2 все просто! Импульсы создает или генератор на АГ3 или Атмега 16 (128) . На первый ключ мы импульс подаем он открывает ключ в LC контуре происходит переходной процесс тем временем остальные ключи закрыты (могу скришот вывесить) компаратор выделяет разность между двумя плечами датчика . На выходе получается переходной процесс (такая затухаящая  синусоида:))) ТРАНЗ должен усилить по идеи третий ключ управляет
сигналом который идет на ОУ затем уже он должен оцифровываться.
Какие еще вопросы :)?
Smerch44
 
Сообщения: 46
Зарегистрирован: 31 июл 2006, 19:36
Откуда: Ульяновск

Сообщение Vovan » 24 ноя 2006, 21:27

Нет согласно микрокапу все работает
многие программы на ПК на некоторых деталях и микросхемах ужЕ подразумевают питание, которое не обязательно показывать в программе. Так например в Протеусе не надо подводить питание к каждой микрухе (оно там подразумевается, но не рисуется), встречал этот же эффект и в других программах. Отсюда вывод: то что работает виртуально, не всегда будет работать в реале из-за самоподразумевающейся обвязки.
Подключаю к остальной части схемы и все пропвдает
это ещё раз подтверждает мой предыдущий пост: разберитесь с включением транзистора, определитесь по какой схеме он включён и как запитывается. Судя по схеме (ИМХО) он должен быть включён по схеме с ОЭ, но не ОБ.
А транзистор походу сгорел
биполярный транзистор легко проверить даже простым омметром...
PS: настаиваю! - нельзя копировать 1:1 схемы построенные в компьютерных программах! Обязательно есть дополнительные элементы схемы которые должны присутсвовать в реале, но их отсутствие в виртуале не играет рояля...
PSS: если уж полный тупик, то я мог бы, конечно, предложить схему включения Q1, но настоятельно рекомендую самому разобраться, наконец, с работой транзисторов и правилами их включения в схему...
___________
С уважением
Vovan
Аватара пользователя
Vovan
 
Сообщения: 3340
Зарегистрирован: 05 окт 2005, 12:03
Откуда: Литва
прог. языки: asm

Сообщение Smerch44 » 25 ноя 2006, 18:58

Спасибо за ответ!
Транзистор включен по схеме с ОЭ неверно я написал (прошу прощения)!
Пробовал включить по другому транзистор ! Пропал один косяк связанный с наличием постоянного состовляющей какой то!
Совершенно согласен с Вами насчет того что схема требует дополнительных элементов отличных от компьютерной модели (микрокап протеус). Но получить работу этой схемы мне пока не удается:(((
Спасибо!
С уважением!
Smerch44
 
Сообщения: 46
Зарегистрирован: 31 июл 2006, 19:36
Откуда: Ульяновск

Сообщение Smerch44 » 28 ноя 2006, 17:43

Попробовал включить транзистор вот так! см рисунок. Исчезла состовляющая на выходе компаратора)) Это хорошо!
Но нашел еще один косяк на выходе первого ключа 0 вольт . Конденсатор не заряжается переходного процесса нет!
Но почему ? Ключ микросхема к561КП2.
Вложения
Схема2.JPG
Smerch44
 
Сообщения: 46
Зарегистрирован: 31 июл 2006, 19:36
Откуда: Ульяновск

Сообщение Smerch44 » 28 ноя 2006, 17:44

Попробовал включить транзистор вот так! см рисунок. Исчезла состовляющая на выходе компаратора)) Это хорошо!
Но нашел еще один косяк на выходе первого ключа 0 вольт . Конденсатор не заряжается переходного процесса нет!
Но почему ? Ключ микросхема к561КП2.
Вложения
Схема2.JPG
Smerch44
 
Сообщения: 46
Зарегистрирован: 31 июл 2006, 19:36
Откуда: Ульяновск

Сообщение Vovan » 02 дек 2006, 11:34

ТРАНЗ должен усилить по идеи

поэтому предлагаю подобрать резистор между выходом компаратора и базой транзистора, на эмитере транзистора резистор остаётся, но в зависимости от напряжения питания его номинал (рекомендую) уточнить, между базой и коллектором транзистора предлагаю включить резистор от 100кОм до 1мОм (подобрать эксперементально).
Если же транзистор должен работать в ключевом режиме, то всё уже правильно, а резистор на базе транзистора можно исключить.
Но нашел еще один косяк на выходе первого ключа 0 вольт . Конденсатор не заряжается переходного процесса нет!
проверить ключ, микросхемы серии 561 также как и 176 серии, катастрофически боятся статического электричества, может "умерла"?
___________
С уважением
Vovan
Аватара пользователя
Vovan
 
Сообщения: 3340
Зарегистрирован: 05 окт 2005, 12:03
Откуда: Литва
прог. языки: asm

Сообщение Smerch44 » 02 дек 2006, 20:47

Здраствуйте !
Проверил я ключ просто имульсы управляющие в фазе были!
Вот он и не работал теперь хоть конткр работает магнити подносишь или железку какую амплитуда меняется не сильно правда . Но это ладно я  зная как поправить))
Вот только опять старый косяк LM393 не "компарирует" если можно так сказать . Включен по схеме согласно даташиту_ вроде бы все правильно! Не сгорела кажись !
Может быть кто еще что насчет компаратора скажет?
Vovan огромное спасибо за ответы!
С уважением!
Smerch44
 
Сообщения: 46
Зарегистрирован: 31 июл 2006, 19:36
Откуда: Ульяновск

Сообщение Vovan » 03 дек 2006, 11:48

Вот только опять старый косяк LM393 не "компарирует" если можно так сказать

Думаю что тут возможны два варианта:
1.Напряжение питания компаратора должно быть строго стабилизированым и соответствовать ДШ, если это не так, то неправильная его работа гарантирована.
2.Компаратор неисправен.
___________
С уважением
Vovan
Аватара пользователя
Vovan
 
Сообщения: 3340
Зарегистрирован: 05 окт 2005, 12:03
Откуда: Литва
прог. языки: asm

След.

Вернуться в Электроника, электротехника

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter