roboforum.ru

Технический форум по робототехнике.

 

Балансирующий бот

Наше хобби — конструировать и программировать.
Демонстрация готовых роботов и устройств построенных своими руками.

Балансирующий бот

Сообщение Sazabi » 16 ноя 2015, 16:38

Господа знающие!

Прошу Вашей помощи!
Есть Ардуино Уно, модуль с L298N.
Делаю балансирующего робота. Питание ардуины и модуля раздельное, земля общая. И вот в чем проблема: сама по себе ардуина работает отлично, а стоит подать питание на модуль с L298N и ардуина виснет. Жму сброс, хватает на несколько секунд и снова виснет.
Порты на выход настроены. В чем заморочка - не понятно.
Подключение такое:
ардуино:
пин 2 - прерывание с mpu6050
пин 3 - enA на модуле l298N
пин 4 - in1 на модуле l298N
пин 5 - in2 на модуле l298N
пин 6 - in3 на модуле l298N
пин 7 - in4 на модуле l298N
пин 9 - enB на модуле l298N
SCL ардуино на scl модуля mpu.
SDA ардуино на sda модуля mpu.
Питание ардуины от кроны, модуля l298 через dc-dc преобразователь на LM2596S-ADJ, с 11,1 (Ли-По) на 6В(моторчики на 6В).
Земля модуля и ардуино соединена.
Питание mpu с 5В пина от ардуины.
Программа честно слизана с http://lukagabric.com/arduino-self-balancing-robot/. Только распиновку поменял.
А ну и подстроечные поты для PID не использую.
Моторы или сразу или почти сразу начинают тупо вращаться в одну сторону, не реагирую на покачивания бота.
Почему-то не получается питать ардуино по юсб и при этом смотреть на реакию моторов - они вообще не начинают вращаться. Если питаю ардуину от кроны, без юсб, то начинают крутиться.
Еще непонятная фигня - если касаюсь руками кабеля юсб, то иногда моторы срабатывают при питании ардуины от юсб.

Картинка:
IMG_20151116_181309.jpg
Sazabi
 
Сообщения: 11
Зарегистрирован: 16 ноя 2015, 16:35

Re: Балансирующий бот

Сообщение lorry » 17 ноя 2015, 00:26

Думается мне, что, что то все же не верно сделано. Вот хорошая статья по подключению вашего драйвера к ардуино. Сделайте все не меняя пинов, добейтесь стабильной работы примеров из статьи, а потом экспериментируйте.
Ссылка:

http://zelectro.cc/Motor_shield_L298N_Arduino

Ну и еще совет: попробуйте все же запитать ардуино и драйвер от разных источников.
Аватара пользователя
lorry
 
Сообщения: 419
Зарегистрирован: 04 фев 2014, 13:53
Откуда: Комсомольск-на-Амуре
прог. языки: машинные коды
ФИО: Иван Иваныч

Re: Балансирующий бот

Сообщение Sazabi » 17 ноя 2015, 09:26

Я и не спорю, что что-то сделано не верно. Иначе вопроса бы не было.
Статью эту читал, с модулем игрался, все крутится.
Касательно Вашего совета: Вы, видимо, невнимательно читали мой вопрос. А там я указал, то питание раздельное, ардуино от кроны (9В), модуль через стабилизатор. Земля кинута общая.
Sazabi
 
Сообщения: 11
Зарегистрирован: 16 ноя 2015, 16:35

Re: Балансирующий бот

Сообщение Sazabi » 17 ноя 2015, 15:44

По непонятной мне причине моторы начали работать при питании ардуины от юсб. Раньше отказывались. При выводе в порт показаний вижу, что ардуину тупо клинит в один момент и моторы шуруют согласно этому последнему сигналу. При физическом отключении моторов от l298n ардуина не виснет.
Может ли причина быть в отсутствии фильтрующих кондеров на моторчиках?

Кондеры не помогли.
Sazabi
 
Сообщения: 11
Зарегистрирован: 16 ноя 2015, 16:35

Re: Балансирующий бот

Сообщение Madf » 17 ноя 2015, 16:52

питайте дуню через dc-dc источника/стаба на 5В
если работать не будет, значит где-то физически неправильно подключили, или сопля..
Madf
 
Сообщения: 2158
Зарегистрирован: 03 янв 2012, 12:55
Откуда: Москва
прог. языки: VB6, BASCOM, ASM...

Re: Балансирующий бот

Сообщение Sazabi » 20 ноя 2015, 13:11

Припаял первый же найденый сторонний мотор - все заработало. Без фильтров и т.д.
Померял обмотки - у работающего нормално мотора ~50кОм, у мотора, с которым канючит ~10 Ом.
Sazabi
 
Сообщения: 11
Зарегистрирован: 16 ноя 2015, 16:35

Re: Балансирующий бот

Сообщение lorry » 21 ноя 2015, 02:09

Еще раз повторяю: запитайте контроллер от другого источника, только минусовые провода источников соедините.
Неужели не понятно, что ваши двигатели при работе садят питание ардуины ниже критического уровня, вот она и зависает или перезагружается постоянно при запуске двигателей.
Аватара пользователя
lorry
 
Сообщения: 419
Зарегистрирован: 04 фев 2014, 13:53
Откуда: Комсомольск-на-Амуре
прог. языки: машинные коды
ФИО: Иван Иваныч

Re: Балансирующий бот

Сообщение Sazabi » 21 ноя 2015, 16:33

lori писал(а):Еще раз повторяю: запитайте контроллер от другого источника, только минусовые провода источников соедините.
Неужели не понятно, что ваши двигатели при работе садят питание ардуины ниже критического уровня, вот она и зависает или перезагружается постоянно при запуске двигателей.


Еще раз отвечаю - читайте ВНИМАТЕЛЬНЕЙ вопрос!!
Пишу еще раз: ардуино питается от кроны (это такая батарейка на 9В, если не в курсе). Модуль L298N питается через DC-DC преобразователь (понижает до 7В, рассчитан на 3А) от ЛиПо аккума на 11,1.
Земля модуля и ардуины соединены.
Sazabi
 
Сообщения: 11
Зарегистрирован: 16 ноя 2015, 16:35

Re: Балансирующий бот

Сообщение elmot » 21 ноя 2015, 16:40

Sazabi писал(а):у работающего нормално мотора ~50кОм

Эт чо за мотор такой????777
Позовите срочно Dmitry__, мотор его мечты найден!
Аватара пользователя
elmot
 
Сообщения: 5674
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: Балансирующий бот

Сообщение Madf » 23 ноя 2015, 12:59

топикстартер - жжот :D
Madf
 
Сообщения: 2158
Зарегистрирован: 03 янв 2012, 12:55
Откуда: Москва
прог. языки: VB6, BASCOM, ASM...

Re: Балансирующий бот

Сообщение lorry » 24 ноя 2015, 00:32

Sazabi писал(а):
lori писал(а):Пишу еще раз: ардуино питается от кроны (это такая батарейка на 9В, если не в курсе)

Умничать, дорогой, не надо, иначе с такими амбициями вас здесь заклюют. А вот то, что прислушаться к рекомендациям стоит это факт. Вы ведь за этим сюда пришли?
По всем описаниям видно, что ардуино, после запуска двигателей перезагружается. У вас явно не хватает тока для питания ардуино. Причины могут быть следующие:
1. не исправны двигатели - попробуйте поменять
2. не вытягивают или не исправны преобразователи напряжения - попробуйте заменить
3. необходимый ток не выдается источником напряжения (аккумуляторами) - для тестирования лучше всего запитать схему от блока питания, причем опять же используйте разные источники для питания ардуино и двигателей.
4. попробуйте поставить конденсаторы на моторы.
Аватара пользователя
lorry
 
Сообщения: 419
Зарегистрирован: 04 фев 2014, 13:53
Откуда: Комсомольск-на-Амуре
прог. языки: машинные коды
ФИО: Иван Иваныч

Re: Балансирующий бот

Сообщение Sazabi » 24 ноя 2015, 10:36

Madf писал(а):топикстартер - жжот :D

Что же Вас рассмешило?

Добавлено спустя 11 минут 3 секунды:
lori писал(а):
Sazabi писал(а):
lori писал(а):Пишу еще раз: ардуино питается от кроны (это такая батарейка на 9В, если не в курсе)

Умничать, дорогой, не надо, иначе с такими амбициями вас здесь заклюют. А вот то, что прислушаться к рекомендациям стоит это факт. Вы ведь за этим сюда пришли?
По всем описаниям видно, что ардуино, после запуска двигателей перезагружается. У вас явно не хватает тока для питания ардуино. Причины могут быть следующие:
1. не исправны двигатели - попробуйте поменять
2. не вытягивают или не исправны преобразователи напряжения - попробуйте заменить
3. необходимый ток не выдается источником напряжения (аккумуляторами) - для тестирования лучше всего запитать схему от блока питания, причем опять же используйте разные источники для питания ардуино и двигателей.
4. попробуйте поставить конденсаторы на моторы.


Амбиции амбициями, а советовать не прочитав до конца (или невнимательно) вопрос - тоже не дело. Конструктивным такой совет не наовешь.
По предложенным пунктам:
1. Двигатели исправны. Простой скетч на управление моторами это доказал. Проблемы начинаются, когда нужна быстрая реакция моторов на изменение положения бота. Другие моторы пробовал, все работает, но они без редукторов, поэтому не подходят. Как я уже написал, у проблемных моторов сопротивление обмотки всего 10 Ом, у работающих корректно больше 50 кОм. Полагаю проблема в этом. При резкой смене направления вращения ток скачет и вешает мозги.
2. Преобразователь напряжения, как я уже писал, 3А. Больше у меня нет. Моторы, согласно описанию с интернетов, больше 500мА не кушают.
3. Аккумулятор на 11,1В 1,8Ач 30С, т.е. 54А ток разряда - явно за глаза таким моторчикам.
4. на моторах по 3 конденсатора - по одному на ногу/корпус и один между ножками. Не помогает. Кондер на питании модуля тоже не помог.
Но мне категорически непонятно как и почему может виснуть ардуина, если питание раздельное, а общее только земля и сигнальные провода, причем пины у ардуины явно указаны на выход.
Sazabi
 
Сообщения: 11
Зарегистрирован: 16 ноя 2015, 16:35

Re: Балансирующий бот

Сообщение gandalvab » 24 ноя 2015, 11:57

Мотор с сопротивлением 50кОм это неправильно 100%.
Моторы не проблемные, 10 Ом это нормальное сопротивление для обмотки 6В мотора.В остановленном состоянии они как раз и будут потреблять заявленные 500мА.
Может ардуина виснет не от питания а от криво отредактированного скетча или как его там.
Ну и можно еще померять ток от выводов ардуины до драйвера моторов, ток не должен превышать 20мА по даташиту на атмеги.
А перемычка на модуле 298-м по питанию стоит?
gandalvab
 
Сообщения: 13
Зарегистрирован: 12 апр 2013, 06:01
прог. языки: C# C

Re: Балансирующий бот

Сообщение Madf » 24 ноя 2015, 12:14

Запитайте дуню от нормального источника питания (не от кроны) и ещё выше описал, что надо попробовать.
А вы ничего не делаете или не знаете, что это...
Madf
 
Сообщения: 2158
Зарегистрирован: 03 янв 2012, 12:55
Откуда: Москва
прог. языки: VB6, BASCOM, ASM...

Re: Балансирующий бот

Сообщение lorry » 24 ноя 2015, 12:53

Madf писал(а):Запитайте дуню от нормального источника питания (не от кроны)

Да ему все об этом говорят, а он тупит.
Аватара пользователя
lorry
 
Сообщения: 419
Зарегистрирован: 04 фев 2014, 13:53
Откуда: Комсомольск-на-Амуре
прог. языки: машинные коды
ФИО: Иван Иваныч

След.

Вернуться в Наши проекты

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter