roboforum.ru

Технический форум по робототехнике.

 

USB > COM порт, проблема со скоростью?

USB > COM порт, проблема со скоростью?

Сообщение edwardoid » 22 авг 2011, 20:12

У меня на компе нет COM-порта. Зато есть переходник, USB > COM. Но, подключив Mini2440 через переходник к компу в режиме NOR я не вижу ничего понятного. Какие-то иероглифы.
Пробовал и под винду, все одно.
Под linux использовал minicom.
Настройки ровно такие, как на этой картинке: Изображение

В то же время на Mini2440 я могу нормально видеть текст(с загруженной ОС) через Serial Assistent с настройками 115200 8N1 нормальный текст после команды:
Код: Выделить всёРазвернуть
ls >> /dev/ttyUSB0


Подскажите, в чем может быть проблема?
edwardoid
 
Сообщения: 15
Зарегистрирован: 22 авг 2011, 12:33

Re: USB > COM порт, проблема со скоростью?

Сообщение linvinus » 22 авг 2011, 21:47

Попробуй G-Software Flow Control - Yes

мой конфиг cat ~/.minirc.dfl
Код: Выделить всёРазвернуть
 
# Автоматически сгенерированный файл - используйте меню настройки minicom
# для изменения параметров.
pu port             /dev/ttyUSB0
#pu baudrate         2000000
pu baudrate         115200
pu rtscts           No
pu xonxoff          Yes
#pu addlinefeed      Yes
pu answerback       eeeeeeee
R3 forum87/topic15337.html
R2 roboforum.ru/forum102/topic13980.html
R4 roboforum.ru/post336339.html#p336339
Делать надо хорошо - плохо получится само!
Аватара пользователя
linvinus
 
Сообщения: 1581
Зарегистрирован: 29 апр 2011, 12:37
Откуда: Москва
прог. языки: С

Re: USB > COM порт, проблема со скоростью?

Сообщение edwardoid » 22 авг 2011, 21:58

бесполезно, то же самое...
edwardoid
 
Сообщения: 15
Зарегистрирован: 22 авг 2011, 12:33

Re: USB > COM порт, проблема со скоростью?

Сообщение linvinus » 22 авг 2011, 22:07

rx с tx местами не перепутали?
иероглифы могут быть в том случае если скорости не согласованны.
А что на другой стороне запущено? Загрузчик?
R3 forum87/topic15337.html
R2 roboforum.ru/forum102/topic13980.html
R4 roboforum.ru/post336339.html#p336339
Делать надо хорошо - плохо получится само!
Аватара пользователя
linvinus
 
Сообщения: 1581
Зарегистрирован: 29 апр 2011, 12:37
Откуда: Москва
прог. языки: С

Re: USB > COM порт, проблема со скоростью?

Сообщение edwardoid » 22 авг 2011, 22:20

Да, загрузчик, и даже когда ос, все одно...
RX TX? Это как понять?
edwardoid
 
Сообщения: 15
Зарегистрирован: 22 авг 2011, 12:33

Re: USB > COM порт, проблема со скоростью?

Сообщение linvinus » 22 авг 2011, 22:56

какой переходник usb->rs232 вы используете?
может это поможет http://code.google.com/p/mini2440-frien ... nsoleSetup
R3 forum87/topic15337.html
R2 roboforum.ru/forum102/topic13980.html
R4 roboforum.ru/post336339.html#p336339
Делать надо хорошо - плохо получится само!
Аватара пользователя
linvinus
 
Сообщения: 1581
Зарегистрирован: 29 апр 2011, 12:37
Откуда: Москва
прог. языки: С

Re: USB > COM порт, проблема со скоростью?

Сообщение hloroform » 04 сен 2011, 17:19

Иероглифы бывают когда без преобразователя уровней к миньке пытаешься подключиться к разъему DB9. Там уровни +-12В, а у преобразователя 0 - 5В.
hloroform
 
Сообщения: 6
Зарегистрирован: 20 авг 2011, 15:42

Re: USB > COM порт, проблема со скоростью?

Сообщение edwardoid » 04 сен 2011, 19:12

Обычный USB->COM переходник, один конец(USB) к компу, другой(COM, соответственно) к проводу, который ведет к mini2440.
edwardoid
 
Сообщения: 15
Зарегистрирован: 22 авг 2011, 12:33

Re: USB > COM порт, проблема со скоростью?

Сообщение hloroform » 12 сен 2011, 01:08

я на коленках собрал из переходника USB to UART на PL2303 и преобразователь уровней на MAX232. все заработало. Про уровни просто не сразу вспомнил, поэтому и получались иероглифы когда без MAX-а пробовал соединяться))
hloroform
 
Сообщения: 6
Зарегистрирован: 20 авг 2011, 15:42


Вернуться в mini2440

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter