roboforum.ru

Технический форум по робототехнике.


OR-WRT - Поддержка

Разработка стандартизированных модулей для домашнего робостроения.
Правила форума
Правила раздела OpenRobotics

Re: OR-WRT - Поддержка

Сообщение Kinstintin » 14 июн 2012, 12:39

Пока ничем не могу подцепиться по лану, а вскрывать и паять UART скорее всего буду вечером, надо немного и основную работу поработать.
Kinstintin
 
Сообщения: 21
Зарегистрирован: 12 июн 2012, 11:11
прог. языки: HiAsm
ФИО: Константин

Re: OR-WRT - Поддержка

Сообщение elmot » 14 июн 2012, 13:09

Вот не очень верится. Еще пробуй по LAN. Отключи файрволлы, убедись, что лезешь именно telnetом, а не ssh, что на компе правильный ip, что он пигает сам себя, что пингается роутер и тд. Частое моргание - это safe mode, специальная загрузка из исходной прошивки, никакие изменения прошивки в силу не вступили, даже из флэша еще не прочитались. UART - это хорошо, конечно, но там маеты много больше, и шанс запороть роутер совсем - много выше.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение Kinstintin » 14 июн 2012, 14:43

Никак не получается, ни просто telnet 192.168.0.1, ни патти в режиме телнета, пинги то-же не проходят. Такое ощущение, что я каким-то образом сломал именно лан интерфейс.
Итак имеем два разных режима.
1. Светит повер мигает wps 2 раз.сек.
2. Светит повер мигает wpc быстро-быстро.
Пробовал в обоих режимах putty ssh, telnet - глухо, cmd -> telnet 192.168.0.1 пишет ошибку. Подставлял IP 192.168.0.1, 192.168.1.1, 192.168.1.120(чудес не бывает). Даже пробовал пингануть по wifi(то-же для успокоения совести).
Никакой ответки, одна надежда через uart. Хотя ща поробую через другой комп.
Kinstintin
 
Сообщения: 21
Зарегистрирован: 12 июн 2012, 11:11
прог. языки: HiAsm
ФИО: Константин

Re: OR-WRT - Поддержка

Сообщение _Pirra » 14 июн 2012, 14:59

Вово. У мменя таже проблема, флешка не становится... :o
Восстановить роутер можно так http://intervito.blogspot.com/2010/11/t ... 743nd.html (команды вводить с клавиатуры!!!) НЕ ЗАБЫВАЙТЕ ПРО НАПРЯЖЕНИЯ У РОУТЕРА 3.3В У СОМ порта -12...+12В в UART 0...+5

Судя по всему после перезагрузки роутер просто не видит файловой системы... и не находит с чего грузится.

У кого получится с флешкой, пожалуйсто инструкцию в форум :)
Это не дым канифоли. Это души погибших транзисторов...
Аватара пользователя
_Pirra
 
Сообщения: 29
Зарегистрирован: 23 май 2012, 15:46
Откуда: Ростов-на-Дону
прог. языки: Delphi

Re: OR-WRT - Поддержка

Сообщение Kinstintin » 14 июн 2012, 15:52

Подключился через UART, через putty просит логин и пасворд, но пасворд не подходит
Kinstintin
 
Сообщения: 21
Зарегистрирован: 12 июн 2012, 11:11
прог. языки: HiAsm
ФИО: Константин

Re: OR-WRT - Поддержка

Сообщение elmot » 14 июн 2012, 16:13

Значит это не моя прошивка. Моя никаких логинов не спрашивает.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение Kinstintin » 14 июн 2012, 16:57

Итак, все завелось. Больное спасибо elmot за терпение и поддержку и отдельное спасибо _Pirra за ссылку на инструкцию. Я думаю не стоит так бояться UART(тем более, что openwrt при недостаточно "ровных" руках, валит наши mr3020 на ровном месте).
Делал все точно по инструкции, но есть пару нюансов которые стоит знать.
Распиновку UART берем на openwrt mr3020.
Запитывать роутер можно от отдельного блока 3,3 Вольта на + и - UART.
Хотя я не пробовал, может можно просто запитать от родного бп и не трогать + UART.
И почему-то putty не правильно реагировала на ввод с клавиатуры, поэтому проще копировать команды из описания и вставлять в терминал, кстати только так удалось уловить момент ввода tpl.
Если нужна заметка для Wiki, можно написать просто и по шагам, хотя по ссылке вроде все внятно разжевано.
Kinstintin
 
Сообщения: 21
Зарегистрирован: 12 июн 2012, 11:11
прог. языки: HiAsm
ФИО: Константин

Re: OR-WRT - Поддержка

Сообщение bekrutt » 14 июн 2012, 17:29

У меня Тплинк 3020 стоит прошивка от elmot еще одна из первых наверно..... Хотел спросить, вы ставите прошивку уже с поддержкой звука? Если да, то вы каждый сам под себя ее собираете, или гдето она лежит!? Я просто думаю мне тоже самому нужно собирать или можно скачать ее готовую?
bekrutt
 
Сообщения: 58
Зарегистрирован: 29 мар 2012, 20:01
Откуда: Ижевск
ФИО: Алексей

Re: OR-WRT - Поддержка

Сообщение Kinstintin » 14 июн 2012, 17:46

Я брал прошивку с этого форума, ветку репозитория то-же, но звук не завелся. Прошивка и пакеты должны совпадать 100%, не знаю почему так.
elmot даже сказал что постарается выдать все вместе.
Я считаю, что все-таки главное организовать поддержку дополнительной памяти, а то слишком мало 4метра для реализации все задумок.
Сам я собирать прошивку пробовал(собралась часа за 3), но не рискнул заливать в силу того, говорят последние версии не дружат с лан(а это опять-же может закончится uart бр...). Вообщем лучше это доверить профи, а мы в свою очередь будем тестить и допиливать.
Kinstintin
 
Сообщения: 21
Зарегистрирован: 12 июн 2012, 11:11
прог. языки: HiAsm
ФИО: Константин

Re: OR-WRT - Поддержка

Сообщение elmot » 14 июн 2012, 17:47

Нету поддержки звука. не лезет во флэш.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение bekrutt » 15 июн 2012, 08:07

Все понятно, будем ожитать новую прошивку. Я тут http://h-wrt.com/ru/doc почитал как собирают думаю, все просто хоп хоп, значит не все так просто..... ладно поэксперементируем))))
bekrutt
 
Сообщения: 58
Зарегистрирован: 29 мар 2012, 20:01
Откуда: Ижевск
ФИО: Алексей

Re: OR-WRT - Поддержка

Сообщение Kinstintin » 15 июн 2012, 09:24

Приятная новость. Сегодня заметил интересные изменения в http://wiki.openwrt.org/toh/tp-link/tl-mr3020 , исчезла надпись о том что на новых версиях прошивки отваливается лан, думаю это дело профиксили и можно работать с транком. А кто все - же решает, стабильная версия или нет?
Kinstintin
 
Сообщения: 21
Зарегистрирован: 12 июн 2012, 11:11
прог. языки: HiAsm
ФИО: Константин

Re: OR-WRT - Поддержка

Сообщение _Pirra » 18 июн 2012, 09:44

Доброго времени суток.
Никак не подключу к роутеру флешку.

В сети написанно, что для того чтоб флешка определилась в роутере необходимы следующие модули:kmod-usb-core kmod-usb-ohci kmod-usb-uhci kmod-usb2 kmod-scsi-core kmod-usb-storage
В прошивке уже есть всё кроме последних двух. После установки недостающих модулей флэшка не появляется в /dev/

Чего ещё нехватает чтобы просто обнаружить флешку устройством? Доустановка e2fsprogs и kmod-fs-ext3 также результатов не дали. Источник модулей вроде нормальный, по крайней мере звук и FTDI с него заработали.

Заранее благодарна.
Это не дым канифоли. Это души погибших транзисторов...
Аватара пользователя
_Pirra
 
Сообщения: 29
Зарегистрирован: 23 май 2012, 15:46
Откуда: Ростов-на-Дону
прог. языки: Delphi

Re: OR-WRT - Поддержка

Сообщение elmot » 18 июн 2012, 09:57

_Pirra писал(а):Чего ещё нехватает чтобы просто обнаружить флешку устройством? Доустановка e2fsprogs и kmod-fs-ext3 также результатов не дали.

эти модули не нужны, они для не для той файловой системы. Скорее нужен
kmod-fs-vfat.

Что сейчас есть в /dev/?
что в файле /proc/partitions?
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: OR-WRT - Поддержка

Сообщение Kinstintin » 18 июн 2012, 10:31

Для то-го, чтобы заработала флеха нужно собирать прошивку с модулем kmod-fs-ext4. Я так и сделал, вот инструкция по непосредственному подключению флехи(выдрана из инета и мной допилена).
Для того, что-бы полноценно использовать железку для работы. Нужно в процессе компиляции прошивки обязательно подключить несколько модулей:
Kernel modules:
USB Support:
<*> kmod-usb-storage (Flash-диск в OpenWrt)
Filesystems:
<*> kmod-fs-ext4(этот модуль включает поддержку ext2-4)
Base system:
<*> block-extroot
Utilities:
Filesystem:
<*> e2fsprogs
Это позволит нам подключить флешку и расширить память роутера до наших амбиций.

Флешка должна быть размечена любым способом с такими параметрами:
1 – своп 128Мб
2 раздел под корень 150Мб
3 раздел под home все остальное пространство

Отформатировать можно и после подключения к роутеру:
mkswap /dev/sda1
mkfs.ext3 /dev/sda2
mkfs.ext3 /dev/sda3

Теперь после загрузки нашего роутера и подключения флешки заходим по SSH и вводим последовательно набор команд:
mount -t ext3 /dev/sda2 /mnt
mkdir /tmp/root/
mount -o bind /rom /tmp/root
cp /tmp/root/* /mnt -a
umount /mnt

Теперь нужно сконфигурировать файл /etc/config/fstab так:

config global automount
option from_fstab 1
option anon_mount 1

config global autoswap
option from_fstab 1
option anon_swap 0

config mount
option target /
option device /dev/sda2
option fstype ext3
option options rw,sync
option enabled 1
option enabled_fsck 1
option is_rootfs 1

config mount
option target /home
option device /dev/sda3
option fstype ext3
option options rw,sync
option enabled 1
option enabled_fsck 1

config swap
option device /dev/sda1
option enabled 1

Перегружаемся:
reboot

И тут начинаются чудеса, система стартует с чистого листа, т.е. нужно заново заходить телнетом по адресу 192.168.0.254 и вводить команду:
passwd
После чего вводим новый пароль, подтверждаем его и выходим.
Теперь входим через ssh и вводим
User: root
Password: введенный в предыдущем шаге пароль

Опять изменяем айпишник на нужный:
vi /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.120'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'
обращаем внимание, что для доступа к интернет нужно добавить две строки в секции lan
option gateway '192.168.1.1'
option dns '192.168.1.1'
Опять корректируем файл vi /etc/config/fstab как описано выше.
Kinstintin
 
Сообщения: 21
Зарегистрирован: 12 июн 2012, 11:11
прог. языки: HiAsm
ФИО: Константин

Пред.След.

Вернуться в Open Robotics

Кто сейчас на конференции

Сейчас этот форум просматривают: Yandex [Bot] и гости: 1

Mail.ru counter