roboforum.ru

Технический форум по робототехнике.


Вопрос по настройке сети с файрволом на OpenWRT

ARM7, ARM9, ARM11 etc.

Вопрос по настройке сети с файрволом на OpenWRT

Сообщение MiRRoR » 04 янв 2013, 03:56

Здравствуйте! TP-Link TL-MR3020 Прошил на OpenWRT. Стал настраивать Network, Wireless, Firewall.

Network

Код: Выделить всёРазвернуть
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option dns '192.168.1.1'
option ipaddr '192.168.2.99'
option gateway '192.168.1.20'
list dns '8.8.8.8'
list dns '8.8.4.4'

config interface 'wwan'
option proto 'static'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'
option ipaddr '192.168.1.20'

Wireless

Код: Выделить всёРазвернуть
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'TX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option channel '1'
option country 'RU'
option txpower '20'

config wifi-iface
option ssid 'WiFi'
option device 'radio0'
option mode 'sta'
option bssid 'C8:6C:87:72:C4:EC'
option key 'qwert'
option encryption 'psk2+tkip+aes'
option network 'wwan'

Firewall

Код: Выделить всёРазвернуть
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network ' '

config zone
option name 'wan'
option network 'wan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config forwarding
option src 'wan'
option dest 'lan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

После чего перезапустил роутер и теперь Windows пишет Неопознанная сеть. Что делать?!
MiRRoR
 
Сообщения: 1
Зарегистрирован: 04 янв 2013, 03:25

Re: OR-WRT - Поддержка

Сообщение elmot » 04 янв 2013, 20:42

Эта не та ветка. Заведите свою, пожалуйста. Здесь поддержка or-wrt, в котором файрволл не установлен вообще.
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: Вопрос по настройке сети с файрволом на OpenWRT

Сообщение =DeaD= » 04 янв 2013, 20:50

Перенес в отдельную ветку. Автору сообщения - устное предупреждение.
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24215
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Re: Вопрос по настройке сети с файрволом на OpenWRT

Сообщение elmot » 04 янв 2013, 21:16

Спасибо.

Ошибок очень много в конфигах, я тут пальцы по плечи сотру разъясняючи.
ТС, определитесь - чего Вы хотите?
Бридж между lan и wifi?
Статические адреса и там и там? Для чего это все должно применяться?
Аватара пользователя
elmot
 
Сообщения: 5691
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья


Вернуться в ARM

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter