roboforum.ru

Технический форум по робототехнике.


Не работает BEAM, прошу проконсультивать

Робот на простых аналоговых элементах.

Не работает BEAM, прошу проконсультивать

Сообщение koston » 02 янв 2013, 07:53

Всем привет, друзья, с наступившим вас)) Смысл проблемы вот в чём: схема с Myrobot (самая простая, с одним фототранзистором) собранная моими пока кривыми гуманитарными руками не работает с фотоэлементом. То есть если ему ноги замкнуть, моторчик крутится (я пока не на тележке всё собираю, а так, на столе, грубо говоря), фотоэлементы пробовал двух разных видов, один из них точно фототранзистор, второй может оказаться и фотодиодом. Разницы нет, все равне не работает. Названия фотоэлементов где то записаны, найду, скажу. Вопрос: как найти неисправность и с чего начать её поиски? В поиске вроде конкрктно такой проблемы не встретил. Спасибо!
koston
 
Сообщения: 11
Зарегистрирован: 08 дек 2012, 18:17
Откуда: Малоярославец

Re: Не работает BEAM, прошу проконсультивать

Сообщение MegaBIZON » 02 янв 2013, 18:14

И тебя с новогодом ))

если с замкнутыми проводками крутит, то вроде как и негде ошибку искать. Полярность, думаю, ты и сам уже повертел...
Вопчем непонятно. Фотка бы помогла штоль...
.............солнце светит, птички поют, я - зелёный бамбук меня тянет к солнцуЯ - зелёный бамбук, я - зелёный бамбук , меня тянет к солнцу. Я - не огурчик и не лягушка, я - зелёный бамбук. Меня курят...............
Аватара пользователя
MegaBIZON
 
Сообщения: 6253
Зарегистрирован: 12 янв 2007, 00:34
Откуда: Масква

Re: Не работает BEAM, прошу проконсультивать

Сообщение koston » 02 янв 2013, 19:30

Добавлю. Питание-крона 9 вольт, резистор поставил переменный, килоомный, не работает в любом положении ползунка, фотку позже выложу
koston
 
Сообщения: 11
Зарегистрирован: 08 дек 2012, 18:17
Откуда: Малоярославец

Re: Не работает BEAM, прошу проконсультивать

Сообщение Vovan » 02 янв 2013, 20:23

1.Какую именно 293-ю применил? Возможно не хватает pull-down резистора?
2.ФТ можно проверить мультиметром, равно и ФД тоже.
_________
Sincerely,
Vovan
Аватара пользователя
Vovan
 
Сообщения: 3340
Зарегистрирован: 05 окт 2005, 12:03
Откуда: Литва
прог. языки: asm

Re: Не работает BEAM, прошу проконсультивать

Сообщение koston » 02 янв 2013, 20:38

L293D,нужен на нее pull-down? Да у меня чего то не выходит проверить, я думаю что нибудь неправильно делаю при проверке

Добавлено спустя 1 минуту 14 секунд:
В статье, как я понял резистор нужен от 100 до 200 Ом, я правильно понимаю?

Добавлено спустя 3 минуты 50 секунд:
И ещё, я так понимаю хорошо бы глянуть напряжение приходящее на input? то есть согласно даташита на микросхему определить 1 там или 0. так вот, надо один щуп мультиметра на вывод input, а второй на минус истоника питания?
koston
 
Сообщения: 11
Зарегистрирован: 08 дек 2012, 18:17
Откуда: Малоярославец

Re: Не работает BEAM, прошу проконсультивать

Сообщение Vovan » 02 янв 2013, 21:13

L293D пул-даун (в данном случае) не нужен.
Ох уж эта 293! :x
Питание "крона" на Vs и Vss - 9в подаётся???
Это плохо. Если на них общее питание подавать, то не должно превышать (см. д\ш, точно не помню) не более 5в. Потому что один +пит. используется для ТТЛ логики микросхемы, а второй +пит для Н-мостов микросхемы, т.е. конкретно для моторов.
Напряжение на инпут померять - не возбраняется. Причем, при свете 1, в темноте 0. Величины напряжений 0 и 1 см. д\ш.
_________
Sincerely,
Vovan
Аватара пользователя
Vovan
 
Сообщения: 3340
Зарегистрирован: 05 окт 2005, 12:03
Откуда: Литва
прог. языки: asm

Re: Не работает BEAM, прошу проконсультивать

Сообщение koston » 02 янв 2013, 23:02

Напряжение на батарейке-7 вольт, видать подсела. на ФТ приходит 7 вольт, с него на input при интенсивном освещении уходит 1 вольт, на output (обоих) по 0,16 вольт. на Vs и Vss по 7 вольт. Пойду осмысливать))) Еще раз прошу прощения за тупые вопросы, но больше даже спросить некого, так что если кто нибудь поможет разобраться, буду благодарен
koston
 
Сообщения: 11
Зарегистрирован: 08 дек 2012, 18:17
Откуда: Малоярославец

Re: Не работает BEAM, прошу проконсультивать

Сообщение MegaBIZON » 02 янв 2013, 23:29

госпади да зачем там ваще микросхема эта ниччастная?
никогда не понимал, если честно.
пары транзисторов для той цели более чем достаточно - и неработать нечему совершенно...
.............солнце светит, птички поют, я - зелёный бамбук меня тянет к солнцуЯ - зелёный бамбук, я - зелёный бамбук , меня тянет к солнцу. Я - не огурчик и не лягушка, я - зелёный бамбук. Меня курят...............
Аватара пользователя
MegaBIZON
 
Сообщения: 6253
Зарегистрирован: 12 янв 2007, 00:34
Откуда: Масква

Re: Не работает BEAM, прошу проконсультивать

Сообщение Vovan » 02 янв 2013, 23:33

Лучший консультант - даташит! :good:
И там есть схемы подключения 1-го, 2-х, 3-х моторов.
Также, там на каждой схеме 16-й вывод правильно обозначен Vcc1 и на него подается +5в. (на схеме майробот Vss). На Vcc2 (на майробот Vs) - можно подавать до 24в, это питание мостов и моторов.
Плохо что на входа подается повышенное напряжение, т.к. оно тоже не должно превышать +5в. А кроме того оно походу и не снижается до лог. 0 при переходе светло\темно. Также и на eneble - повышенное питание не хорошо. Очевидно пока крона была в норме, логика ужЕ подпалилась... 7в на логику - это тоже много. Возможно крона и небольшой ток выдает, однако для неверной работы логики, которой достаточно неск.мА, этого хватает чтобы всё работало криво...
Правильное питание схемы - залог ее правильной работы :)

MegaBIZON: +100500! абс. по-нашему! :good:
Для минимальных задач - минимальное решение!
В некоторых случаях возможно 1 мотор и на 1-м транзисторе ...
Гы... эк меня на лозунги в 13-м прорвало....
_________
Sincerely,
Vovan
Аватара пользователя
Vovan
 
Сообщения: 3340
Зарегистрирован: 05 окт 2005, 12:03
Откуда: Литва
прог. языки: asm

Re: Не работает BEAM, прошу проконсультивать

Сообщение koston » 02 янв 2013, 23:43

Vovan, понял, работаем над питанием)) Ты думаешь, попалил микруху?
Megabizon, я в общем согласен, что можно на транзисторах собрать, но во первых я решил начать свои эксперименты с этой микросхемы потому что вроде как самый проторенный путь, а во вторых мне это самым простым вариантом показалось, я пока не решаюсь усложнять, хотелось одну работающую схему получить, а потом дальше двигаться, а так-то да, минимализм рулит))
koston
 
Сообщения: 11
Зарегистрирован: 08 дек 2012, 18:17
Откуда: Малоярославец

Re: Не работает BEAM, прошу проконсультивать

Сообщение Vovan » 02 янв 2013, 23:52

Ну да. Организуй каким-то образом питание +5в и тогда можно Vss и Vs вместе объединить. Можно и от 9в, но тогда на Vss нужно от 9в-ого ист. питания подавать через регулятор напряжения типа 7805, на +5в енеблы тож повесить надо. Затем, добившись правильного питания начинать отлаживать узел с ФТ(или ФД), которые тоже на шину +5в вешаются. Однако при правильном питании и подключении отладки никакой не требуется, за исключением "загрубления", порой, повышенной чувствительности фотодатчика...
Мождь и правильно, сначала один мотор запустить, а потом уже и лайнтрайсера состроить...
Насчёт подпалил\неподпалил трудно сказать... Если правильно всё построить м\сх сама сообщит: здорова она или нет :wink:
_________
Sincerely,
Vovan
Аватара пользователя
Vovan
 
Сообщения: 3340
Зарегистрирован: 05 окт 2005, 12:03
Откуда: Литва
прог. языки: asm

Re: Не работает BEAM, прошу проконсультивать

Сообщение MegaBIZON » 02 янв 2013, 23:57

koston писал(а): я решил начать свои эксперименты с этой микросхемы потому что вроде как самый проторенный путь...

судя по количеству вопросов по этой схеме это ещё и самый проблемный путь.. это при его-то видимой простоте.
Я сам это собирал, и мне совершенно не понравилось как оно срабатывает и рулит. Транзисторный вариант плавнее и точнее показался.
А драйверный вариант хорош, на мой непросвещённый взгляд, лишь тем, что при дальнейших усложнениях туда моно МК пихнуть, ничего особо не перекапывая.
.............солнце светит, птички поют, я - зелёный бамбук меня тянет к солнцуЯ - зелёный бамбук, я - зелёный бамбук , меня тянет к солнцу. Я - не огурчик и не лягушка, я - зелёный бамбук. Меня курят...............
Аватара пользователя
MegaBIZON
 
Сообщения: 6253
Зарегистрирован: 12 янв 2007, 00:34
Откуда: Масква

Re: Не работает BEAM, прошу проконсультивать

Сообщение koston » 03 янв 2013, 00:05

Megabizon, спасибо, задумаюсь...

Добавлено спустя 2 минуты 2 секунды:
Вариантов то куча)))
koston
 
Сообщения: 11
Зарегистрирован: 08 дек 2012, 18:17
Откуда: Малоярославец

Re: Не работает BEAM, прошу проконсультивать

Сообщение Vovan » 03 янв 2013, 00:09

Да ваще эта м\сх полный ацтой... Ну можно и с ней поиграться. Особенно просто с ней работать да, именно с МК, тогда и ШИМ можно легко устроить и реверс. Но если только вперед (без реверса и ШИМа), как например лайнтрайсер или светофилл - транзисторы реально рулят.
А с другой стороны опыт лишним не бывает: чтобы узнать что такое хорошо, нужно познать и что такое плохо :wink: ну или наоборот...
_________
Sincerely,
Vovan
Аватара пользователя
Vovan
 
Сообщения: 3340
Зарегистрирован: 05 окт 2005, 12:03
Откуда: Литва
прог. языки: asm

Re: Не работает BEAM, прошу проконсультивать

Сообщение koston » 03 янв 2013, 00:21

Ну реверс наверное можно на транзисторах сделать? Просто на данный момент моя цель конечная- два моторчика (Ходовой и руль) с реверсом и 4 фотоэлемента. Типа в каком направлении свет ярче-туда и едем. Надеюсь разобраться и сварганить)))
Так вот для такого функционала что оптимальнее, м/с или транзисторы?

Добавлено спустя 1 минуту 3 секунды:
Тут наверное микроконтроллер просится, но не хотелось бы пока с ними связываться, охота основы изучить
koston
 
Сообщения: 11
Зарегистрирован: 08 дек 2012, 18:17
Откуда: Малоярославец

След.

Вернуться в BEAM роботы

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter