roboforum.ru

Технический форум по робототехнике.

 

ARDUINO и Xbee

В разделе рассматриваются вопросы информационного обмена в робототехнике.
Аппаратный уровень, протоколы.

Re: ARDUINO и Xbee

Сообщение max_b » 02 апр 2011, 08:01

Добрый день!
Как ваши дела с XBee? Прошел также по вашему пути около трех недель назад, и только вчера увидел ваше сообщение. Но видимо я рыл немного глубже, т.к. в день, когда мне привезли модуль для программирования XBee, я нашел альтернативное решение. Нужно на Arduino залить программку, которая 0-ой и 1-ый выводы Arduino (собственно порты, к которым подключается модуль к Arduino) переводит в режим входов (ниже листинг найденный мною в сети :)).

void setup()
{
pinMode(0, INPUT);
pinMode(1, INPUT);
}
void loop()
{
}

На XBee Shield нужно использовать соответствующие джамперы (у меня это положение "Arduino ext i-face"). Да, и в случае, если XBee не отвечает (скорость не соответствует) нужно нажимать ресет или на модуле программирования, или на ХВ шилде. XBee Shield я купил от freeduino.ru, т.к. на него можно поставить модули Nano, что экономит несколько грамм веса и несколько сотен рублей денег :).
Удачи,
Макс.
max_b
 
Сообщения: 1
Зарегистрирован: 02 апр 2011, 07:37

Re: ARDUINO и Xbee

Сообщение Rujin » 21 апр 2011, 11:28

:cry:
Последний раз редактировалось Rujin 30 апр 2011, 09:24, всего редактировалось 1 раз.
Rujin
 
Сообщения: 3
Зарегистрирован: 21 апр 2011, 11:16

Re: ARDUINO и Xbee

Сообщение Rujin » 21 апр 2011, 11:34

Вот так же столкнулся с проблемой XBee-шки. Сейчас остановился на этапе когда вынул из arduino-вской платы микроконтроллер, воткнул XBee в плату и через X-CTU общаюсь с нею. Хоть удалось получить отклик на +++. Вообще удручает подобная "тяжелость" в работе по сравнению с работой Ардуинки. Кто-нибудь может подсказать как организовать передачу данных с компа на удаленную XBee, когда они обе установлены на Arduino (Использую Arduino UNO и XBee Shield v.1 (http://garden.seeedstudio.com/index.php?title=XBee%C2%AE_Shield). Честно говоря без помощи - уже вряд ли разберусь. :o
Rujin
 
Сообщения: 3
Зарегистрирован: 21 апр 2011, 11:16

Re: ARDUINO и Xbee

Сообщение Rujin » 15 июн 2011, 11:04

Проблема оказалась в одном из модулей xBee. После приобретения еще пары - стало нормально работать - при установленной (или без) платы с xBee заливаю
void setup()
{
pinMode(0, INPUT);
pinMode(1, INPUT);
}
void loop()
{
}
или
void setup()
{
DDRB=0;
DDRC=0;
DDRD=0;
}
void loop()
{
}
джамперы п положение 1)USB 2)UART_RxTx - запускаю две ардуинки и общаюсь через COM порты. Если надо без использования компа - джампер необходимо перевести в положение 1)UART 2)UART_RxTx
Плату использовал следующую: http://garden.seeedstudio.com/index.php ... %AE_Shield
Rujin
 
Сообщения: 3
Зарегистрирован: 21 апр 2011, 11:16

Пред.

Вернуться в Коммуникации

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter