roboforum.ru

Технический форум по робототехнике.

 

Вопрос по управлению двигателей с помощью L298N ШИМом.

Обсуждение и примеры готовых и самосборных компонент для построения роботов.

Вопрос по управлению двигателей с помощью L298N ШИМом.

Сообщение alexkov87 » 04 окт 2013, 23:55

Добрый вечер! Я тут новенький во всём этом.

Делаю "робомашинку". Подключил Китайский модуль (драйвер) на L298N. Вот такой:

Изображение

Он работает, но на мой взгляд как-то странно. А именно:

если подаю 0 (на направление), то скорость работает нормально (0..255)
если подаю 1 (на направление), то скорость работает наоборот (255..0)
то есть подаю 1 (направление) и 255 (скорость ШИМ) - стоит
подаю 1 (направление) и 0 (скорость ШИМ) - крутит на всю.

Подскажите, это нормально или нет, если нет - то буду приводить скетчи и т.д.

Спасибо.

P.S. Простите, если ошибся разделом.
alexkov87
 
Сообщения: 7
Зарегистрирован: 04 окт 2013, 23:44

Re: Вопрос по управлению двигателей с помощью L298N ШИМом.

Сообщение alexkov87 » 06 окт 2013, 00:56

Пока тему одобрили - мне уже подсказали:) Подключал по неправильной инструкции - вот: http://cxem.net/arduino/arduino70.php
Может, новичкам, таким как я будет полезно знать, что в этом "уроке" ошибка.

ШИМ должен подаваться на ENABLE A и ENABLE B, а четыре INPUT'а отвечают за направление.
alexkov87
 
Сообщения: 7
Зарегистрирован: 04 окт 2013, 23:44


Вернуться в Готовые модули

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter