roboforum.ru

Технический форум по робототехнике.

 

AVR studio проблемы с функциями

Программирование микроконтроллеров AVR, PIC, ARM.
Разработка и изготовление печатных плат для модулей.

AVR studio проблемы с функциями

Сообщение Crushor » 24 окт 2009, 23:49

Подскажите пожалуйста как решить такую проблему: в АВР студии функции банально не хотят выполняться, когда с помощью дебаггера делаю пошаговую отладку происходит следуещее: все шаги нормально проходят кроме тех на которых идет выход из функции(то есть никакой стрелочки напротив следующей строки после функции не появляется а программа просто виснет в состоянии Running).
P/S/ Поналачу пока не поставил __attribute__((noinline))перед каждой функцией и не засунул функции в мэйн файл аналогичный зависон был при попытке во время дебага step into в функцию плюс к тому же бряки напротив функций убирались компилятором.
PSS компилятор WinAvr.
Последний раз редактировалось Crushor 24 окт 2009, 23:54, всего редактировалось 1 раз.
Crushor
 
Сообщения: 9
Зарегистрирован: 24 окт 2009, 22:43
Откуда: Феодосия

Re: AVR studio проблемы с функциями

Сообщение avr123.nm.ru » 24 окт 2009, 23:49

Проект прицепите архивчиком.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: AVR studio проблемы с функциями

Сообщение Crushor » 25 окт 2009, 00:06

Main file "speedometr.c"
Вложения
speedometr.rar
(17.48 КиБ) Скачиваний: 10
Crushor
 
Сообщения: 9
Зарегистрирован: 24 окт 2009, 22:43
Откуда: Феодосия

Re: AVR studio проблемы с функциями

Сообщение avr123.nm.ru » 25 окт 2009, 00:07

лучше проект.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: AVR studio проблемы с функциями

Сообщение Crushor » 25 окт 2009, 00:10

В архиве весь проект
Crushor
 
Сообщения: 9
Зарегистрирован: 24 окт 2009, 22:43
Откуда: Феодосия

Re: AVR studio проблемы с функциями

Сообщение Crushor » 25 окт 2009, 18:54

Ща снова убрал noinline и во время дебага стрелочка зацыкливается на функции, а если сделать step into в функцию то все внутренные функции пошагово обрабатываются, но опять же при выходе из самой функции прога виснет в состоянии Running. При попытке установить бряк за функцией, и запустить эмуляцию программа на бряке не останавливается. .
Очень прошу помогите, ибо на Си пишу не первый год, но с AVR софтом связался недавно, и таких проблем с функциями не видал. Можна конечно писать все линейным кодом, но зачем тогда Си...
Crushor
 
Сообщения: 9
Зарегистрирован: 24 окт 2009, 22:43
Откуда: Феодосия

Re: AVR studio проблемы с функциями

Сообщение Drunya » 26 окт 2009, 10:12

Попробовал, у меня все нормально работает. На брейкпоинте останавливается, из функций выходит. Какая у Вас версия студии?
Глюк по-немецки означает "счастье"...
Аватара пользователя
Drunya
 
Сообщения: 196
Зарегистрирован: 05 июн 2007, 12:20
Откуда: Киев
прог. языки: C/C++, ASSEMBLER

Re: AVR studio проблемы с функциями

Сообщение Crushor » 26 окт 2009, 21:47

версия последняя - 4.17, программатор JTAG ICE.
Люди 7 скачиваний и 1 ответ, скажите плз пашет, не пашет или ниче не понятно?
Crushor
 
Сообщения: 9
Зарегистрирован: 24 окт 2009, 22:43
Откуда: Феодосия

Re: AVR studio проблемы с функциями

Сообщение Drunya » 27 окт 2009, 01:03

Ах, JTAG ICE... Я симулятором пробовал...
Глюк по-немецки означает "счастье"...
Аватара пользователя
Drunya
 
Сообщения: 196
Зарегистрирован: 05 июн 2007, 12:20
Откуда: Киев
прог. языки: C/C++, ASSEMBLER


Вернуться в Микроконтроллеры

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 9

Mail.ru counter