roboforum.ru

Технический форум по робототехнике.

 

Проблема с ШИМ Mega8

Программирование микроконтроллеров AVR, PIC, ARM.
Разработка и изготовление печатных плат для модулей.

Re: Проблема с ШИМ Mega8

Сообщение avr123.nm.ru » 07 сен 2009, 13:23

R5 ИМХО вообще тут нипричем - через него ток не превысит 5 мА. Помешать работе ни как не может ИМХО.

Схема нормальная просто подкорректируйте резисторы токоограничительные. Наверно 50 мА максимальный ток через ИК диод - но надо уточнаять в даташите конкретных компонентов.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: Проблема с ШИМ Mega8

Сообщение D1mcon » 07 сен 2009, 13:46

Через ИК диод по ДШ 100 мА. Пересчитал по Вашему совету резисторы, получил 13Ом. Вроде как мои 11 Ом здесь уместны. :oops:

Повторюсь, номиналы резиторов - приина моей проблемы?
Язык Ада - официально был признан министерством обороны США для создания ПО военной техники
Аватара пользователя
D1mcon
 
Сообщения: 700
Зарегистрирован: 08 фев 2009, 10:13
Откуда: Воротынск
прог. языки: C,C++,C#,Java
ФИО: Дмитрий

Re: Проблема с ШИМ Mega8

Сообщение avr123.nm.ru » 07 сен 2009, 13:52

Ну как же тогда транзистор вы выбрали ? Он по моему на 100 мА у вас.

Я выше писал попробуйте bc817 bc337 на 500 мА или КТ815 1А КТ817 3А
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: Проблема с ШИМ Mega8

Сообщение yak-40 » 07 сен 2009, 14:04

Дык, может светодиоды уже сгорели?
Поработали немного с певышением тока, и ага?
- Этот человек - не человек! это робот!
- Как? уже делают?!
- Делают!!!
Аватара пользователя
yak-40
 
Сообщения: 3019
Зарегистрирован: 23 окт 2007, 22:03
Откуда: Москва
прог. языки: С
ФИО: Евгений Яковец

Re: Проблема с ШИМ Mega8

Сообщение avr123.nm.ru » 07 сен 2009, 14:13

Лучше даташит прицепите сюда - посмотрим какие там 100 мА.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: Проблема с ШИМ Mega8

Сообщение Master » 07 сен 2009, 14:17

Кстатит, проверить работают диоды или нет, можно камерой с мобильника или вэб-камерой они ИК видят как белый свет.
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: Проблема с ШИМ Mega8

Сообщение avr123.nm.ru » 07 сен 2009, 14:34

наверно и тестером можно проверить + падение напряжения на резисторах.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: Проблема с ШИМ Mega8

Сообщение Master » 07 сен 2009, 14:35

У него же там вроде сигнал для ТСОПа, кетайский тестер не отреагирует скорее всего.
Аватара пользователя
Master
 
Сообщения: 4468
Зарегистрирован: 21 дек 2006, 19:56
Откуда: Украина, г.Одесса
прог. языки: Delphi и С

Re: Проблема с ШИМ Mega8

Сообщение D1mcon » 07 сен 2009, 14:38

Диоды работают, об этом я писал в самом начале. :) Транзистор заменил на 2N4401, он держит 1А.
Вот только ситуация не изменилась.
ДШ в прицепе.
Вложения
tsal 5100.pdf
(82.05 КиБ) Скачиваний: 8
Язык Ада - официально был признан министерством обороны США для создания ПО военной техники
Аватара пользователя
D1mcon
 
Сообщения: 700
Зарегистрирован: 08 фев 2009, 10:13
Откуда: Воротынск
прог. языки: C,C++,C#,Java
ФИО: Дмитрий

Re: Проблема с ШИМ Mega8

Сообщение avr123.nm.ru » 07 сен 2009, 15:18

5 - 0.9 ( с запасо так как ток большой ) - 1.4 = 2.7 вольт на резисторе.


2.7 / 11 = 245 мА ток и на резисторе будет рассеиваться 0,66 Вт - транзистор ваш должен был быстро сгорать наверно.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: Проблема с ШИМ Mega8

Сообщение D1mcon » 07 сен 2009, 15:40

Извините, забыл упомянуть, на транзистор не 5в подается а 3.35в.
Но я нашел свою ошибку: схема была от старого алгоритма подсчета импульсов, в нем ШИМ подавался еще и на PB3, запрограммированный на вход. Но в своей программе я по ошибке его запрограммировал его на выход. Разорвав дорожку между PB1 и РВ3, я решил проблему,все заработало.

Всем, кто помогал,особенно avr123.nm.ru, спасибо!!!

P.S. Сильно не браните, да лопухнулся немножко. :)
Язык Ада - официально был признан министерством обороны США для создания ПО военной техники
Аватара пользователя
D1mcon
 
Сообщения: 700
Зарегистрирован: 08 фев 2009, 10:13
Откуда: Воротынск
прог. языки: C,C++,C#,Java
ФИО: Дмитрий

Re: Проблема с ШИМ Mega8

Сообщение Myp » 07 сен 2009, 17:58

хыхы
существует всего 2 возможные неисправности
есть сигнал там где не надо и отсутствие сигнала там где надо :lol:

*закрыто
<telepathmode>На вопросы отвечает Бригадир Телепатов!</telepathmode>
Всё уже придумано до нас!
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 15918
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Пред.

Вернуться в Микроконтроллеры

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4

Mail.ru counter