roboforum.ru

Технический форум по робототехнике.

 

VMLAB подсадка напряжения

Программирование микроконтроллеров AVR, PIC, ARM.
Разработка и изготовление печатных плат для модулей.

VMLAB подсадка напряжения

Сообщение rock » 10 мар 2009, 19:02

В VMLAB симулирую работу Atmega128. Выход PC0 подключен через кнопку на вход PC6. Уровень на PC0 почти 5V, как только нажимаю кнопку (соединяю PC0 с PC6) вместо почти 5V всего 2.2V. Больше сюда не чего не подключено. Может кто сталкивался с таким, это глюк какой-то или я чего-то недопонимаю. Спасибо. :(
rock
 
Сообщения: 25
Зарегистрирован: 13 фев 2009, 14:51
Откуда: Minsk

Re: VMLAB подсадка напряжения

Сообщение avr123.nm.ru » 11 мар 2009, 02:23

Прожек то ГДЕ ? Че смотреть тА ?
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: VMLAB подсадка напряжения

Сообщение rock » 11 мар 2009, 13:58

; ------------------------------------------------------------
.POWER VDD=5 VSS=0 ; Power nodes
.CLOCK 15meg ; Micro clock
.STORE 2000m ; Trace (micro+signals) storage time

; ------------------------------------------------------------
K1 PC0 PC3
K2 PC1 PC3
K3 PC2 PC3
K4 PC0 PC4
K5 PC1 PC4
K6 PC2 PC4
K7 PC0 PC5
K8 PC1 PC5
K9 PC2 PC5
KA PC0 PC6
K0 PC1 PC6
KB PC2 PC6
;-------------------------------------------------------------
.PLOT V(PC0) V(PC2) V(PC6)
;---------------------------------
Xdisp LCD(20 2 250K) PA0 PA1 PA2 PA7 PA6 PA5 PA4 nc3 nc2 nc1 nc0
; ------------------------------------------------------------
Последний раз редактировалось rock 11 мар 2009, 15:14, всего редактировалось 1 раз.
rock
 
Сообщения: 25
Зарегистрирован: 13 фев 2009, 14:51
Откуда: Minsk

Re: VMLAB подсадка напряжения

Сообщение avr123.nm.ru » 11 мар 2009, 14:35

Попробуй через резистор кнопку подключить.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: VMLAB подсадка напряжения

Сообщение rock » 11 мар 2009, 15:42

Не понял в чем дело, но сейчас запустил по новому VMLAB и все правильно работает. Вчера весь день провозился так и не разобрался. Бред какой-то. :?:
rock
 
Сообщения: 25
Зарегистрирован: 13 фев 2009, 14:51
Откуда: Minsk


Вернуться в Микроконтроллеры

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter