roboforum.ru

Технический форум по робототехнике.

 

Проблема с WinAVR

Программирование микроконтроллеров AVR, PIC, ARM.
Разработка и изготовление печатных плат для модулей.

Проблема с WinAVR

Сообщение Denis777 » 30 окт 2006, 22:10

Здравствуйте.
Не пинайте сильно за ламерские вопросы, только начал разбираться

Столкнулся со следующей проблемой: устанавливаю WinAvr на диск С:, при попытке компилировать какой-либо файл ругается. Выводит следующее:
> "make.exe" all AllocationBase 0x71590000, BaseAddress 0x71590000, RegionSize 0x1000, State 0x1000 C:WinAVRutilsinsh.exe: *** Couldn't reserve space for cygwin's heap, Win32 error 487
-------- begin -------- avr-gcc (GCC) 3.4.3 Copyright (C) 2004 Free Software Foundation, Inc. This is free software; see the source for copying conditions.  There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
AllocationBase 0x71590000, BaseAddress 0x71590000, RegionSize 0x1000, State 0x1000 C:WinAVRutilsinsh.exe: *** Couldn't reserve space for cygwin's heap, Win32 error 487 make.exe: *** [sizebefore] Error 1
> Process Exit Code: 2

Странно что когда ставлю WinAvr на дрогой раздел(E:) все компилируется прекрасно. Все было бы хорошо но мне нужно все таки заставить ее работать с диска С. Помогите кто знает в чем причина...
Denis777
 
Сообщения: 3
Зарегистрирован: 30 окт 2006, 21:39
Откуда: Таганрог

Re: Проблема с WinAVR

Сообщение aesok » 31 окт 2006, 01:02

Denis777 писал(а):...
Couldn't reserve space for >>>>>cygwin's<<<<< heap, Win32 error 487
.....
.


У вас стоит на диске С cygwin? Возможно WinAVR и cygwin конфликтуют.

Анатолий.
aesok
 
Сообщения: 69
Зарегистрирован: 11 авг 2006, 01:02
Откуда: ----

Сообщение Denis777 » 31 окт 2006, 10:57

Все что есть с таким именем на диске C это insight-6_1-cygwin-build.patch и cygwin1.dll в папке WinAVR
Denis777
 
Сообщения: 3
Зарегистрирован: 30 окт 2006, 21:39
Откуда: Таганрог

Сообщение Denis777 » 31 окт 2006, 12:00

Cегодня попробовал откомпилировать на одном из компов лаборатории в универе пишет следующее

Clean, make all

"make.exe" clean

> Failed to create process: Не удается найти указанный файл.

> Process Exit Code: 0

Кто знает как лечить? Где прописать пути? Пробовал в меню Tool не получилось.
Denis777
 
Сообщения: 3
Зарегистрирован: 30 окт 2006, 21:39
Откуда: Таганрог

Сообщение Tracer » 31 окт 2006, 13:24

У меня та же фигня
Это на утилиту rm.exe - ругается она запускается при make clean
В принципе не мешает но нужно разобраться таки
Аватара пользователя
Tracer
 
Сообщения: 195
Зарегистрирован: 24 ноя 2004, 12:36
Откуда: Харьков


Вернуться в Микроконтроллеры

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter