roboforum.ru

Технический форум по робототехнике.

 

помогите решить проблему с платой ардуино мега

Программирование микроконтроллеров AVR, PIC, ARM.
Разработка и изготовление печатных плат для модулей.

помогите решить проблему с платой ардуино мега

Сообщение Shaman » 04 ноя 2015, 21:58

Железо: Arduino Mega 2560 R3 от SaintSmart

Проблема в следующем:
На ногах 5в и 3,3в приходит почти тоже самое напряжение.

То что я уже проверил:
При подачи 6в: на выходе AMS1117-5.0 получаю со 2 ноги(Vout)=4.78в, на 3ю(Vin)=4.97в,
При 7,5в: получаю с 2pin(Vout)=6.05в; на 3pin(Vin)=6.38в
Также оба выхода (2 и 3) между собой соединены. Что судя из оригинального Ардуино плана, нормально.

На регулятор lp2985 lpf3, который я как понял отвечает за 3,3в, приходит напряжение со 2 ноги (Vout) от AMS1117-5.0.
У lp2985 lpf3 выходы 1 и 2 соединены, что в принципе нормально, только вот они также соединены и 5й ногой (Vout), что не есть нормально

Вывод: Пробиты оба регулятора или только один из них?


Документацию которую я нарыл в интернете:
http://www.advanced-monolithic.com/pdf/ds1117.pdf
http://www.farnell.com/datasheets/89912.pdf
https://www.arduino.cc/en/uploads/Main/ ... R3-sch.pdf

По поводу замены: Я так понимаю, что заместо AMS1117-5.0 можно взять к примеру STMicroelectronics LD1117S33TR (SOT-223)
а вместо lp2985 lpf3 должен подойти Texas Instruments LP2985-33DBVR Positiv (SOT-23-5)
Shaman
 
Сообщения: 5
Зарегистрирован: 04 ноя 2015, 21:54

Re: помогите решить проблему с платой ардуино мега

Сообщение Myp » 04 ноя 2015, 23:05

ты бы написал, а в чём собственно проблема?
<telepathmode>На вопросы отвечает Бригадир Телепатов!</telepathmode>
Всё уже придумано до нас!
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 15944
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Re: помогите решить проблему с платой ардуино мега

Сообщение Shaman » 05 ноя 2015, 00:09

Ну так вроде написал же всё

На ногах 5в и 3,3в приходит почти тоже самое напряжение. Вместо ожидаемых 3,3в и 5в приходит слишком высокое напряжение. (Остальное можно прочитать выше)

П.С.Плату я никогда не подключал выше 7.5в (рабочее напряжение 7-12в)
Shaman
 
Сообщения: 5
Зарегистрирован: 04 ноя 2015, 21:54

Re: помогите решить проблему с платой ардуино мега

Сообщение Angel71 » 05 ноя 2015, 02:42

мультиметр и паяльник в руки и искать с чем проблема. неужели так сложно было выпаять для начала хотя бы 1-2 стаба и проверить? и стабы не единственное, что могло загнуться.
Аватара пользователя
Angel71
 
Сообщения: 9232
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: помогите решить проблему с платой ардуино мега

Сообщение Madf » 05 ноя 2015, 12:40

или залипала-сопля где, прозвони точки стаба
Madf
 
Сообщения: 2157
Зарегистрирован: 03 янв 2012, 12:55
Откуда: Москва
прог. языки: VB6, BASCOM, ASM...

Re: помогите решить проблему с платой ардуино мега

Сообщение Shaman » 05 ноя 2015, 23:20

"мультиметр и паяльник в руки и искать с чем проблема. неужели так сложно было выпаять для начала хотя бы 1-2 стаба и проверить? и стабы не единственное, что могло загнуться."
-Ну во первых смысл что то спаивать, когда пока нет деталей, чтобы их заменить.
Ну а поводу может еще что загнулось: может быть, хотя я вчера включал плату и запускал на ней часы. Сам стабилизатор должен теоретически в случае повреждения полностью передавать напряжение, которое на входе, но почему то он его частично поглощает. Как уже писал выше при входе 7.5в на выходе получаются чуть больше 6в, что не есть нормально. Также имеется соединение между верхней металической частью и выходами 2 и 3, хз как эта часть называется. (на картинки отметил)
Изображение

"или залипала-сопля где, прозвони точки стаба"
-Уже, сверху описал, где и с чем имеется соединение и какое напряжение куда приходит

П.С. По поводу замены, как думаете можно ли взять заместо AMS1117-5.0 к примеру STMicroelectronics LD1117S33TR (SOT-223). Судя по параметрам они довольно таки похожи. Да и достать AMS1117-5.0 гораздо сложнее (дольше, пусть и дешевле), чем LD1117
Shaman
 
Сообщения: 5
Зарегистрирован: 04 ноя 2015, 21:54

Re: помогите решить проблему с платой ардуино мега

Сообщение Angel71 » 06 ноя 2015, 00:03

:) и без выпайки много можно проверить. только там всего 6 деталюшек, ладно, с транзистором 7. уже давно можно было найти, что именно нагнулось.
Аватара пользователя
Angel71
 
Сообщения: 9232
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: помогите решить проблему с платой ардуино мега

Сообщение Shaman » 06 ноя 2015, 02:36

И так никто и не ответил, что это за подложка(картинка сверху)? Это случаем не 4я нога?
Если это 4я нога, то и на 5 вольтовом стабилизаторе закорочены 3(вход) и 2(выход), а это скорее всего означает, что обоим стабилизаторам настал писец. Так как в обоих случаях напрямую связаны вход и выход.
Единственное, что я не могу понять каким образом происходит уменьшение напряжения, ведь вход и выход соединены?
Shaman
 
Сообщения: 5
Зарегистрирован: 04 ноя 2015, 21:54

Re: помогите решить проблему с платой ардуино мега

Сообщение Angel71 » 06 ноя 2015, 04:05

Аватара пользователя
Angel71
 
Сообщения: 9232
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: помогите решить проблему с платой ардуино мега

Сообщение Madf » 06 ноя 2015, 12:16

Shaman писал(а):И так никто и не ответил, что это за подложка(картинка сверху)?

http://www.advanced-monolithic.com/pdf/ds1117.pdf
Судя из доки следует:

1 нога - минус/общий;
2 нога - выход стабилизированной напряжение (в вашем случае 5В);
3 нога - вход (где-то от 7 до 15В, но макс.напряжение лучше не использовать, греться сильно будет).

Ушко сверху обычно связывается с центральной (второй) ногой, получается, что это "выход"!
Соответственно, между ногами: 1,2 и 3 не должно быть короткого замыкания (коротко звониться должна 2-я нога и верхнее "ушко").
Madf
 
Сообщения: 2157
Зарегистрирован: 03 янв 2012, 12:55
Откуда: Москва
прог. языки: VB6, BASCOM, ASM...

Re: помогите решить проблему с платой ардуино мега

Сообщение Angel71 » 06 ноя 2015, 13:47

Madf, это есть у ti в даташите
Аватара пользователя
Angel71
 
Сообщения: 9232
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: помогите решить проблему с платой ардуино мега

Сообщение Shaman » 07 ноя 2015, 00:35

Понятно, но увы 2 и 3 ноги звонят, а этого быть не должно. Да и соплей нависшего припоя там не имеется, вся плата чистая и все детали на удивление были ровно впаяны. Китайцы теперь должны научится впаивать нормальные детали. Походу lm1117 выпускают все подряд. Но в магазине в соседнем городе есть только lm1117 от StMicroelectronics поэтому возьму его и стаб на 3,3в от Texas Instruments LP2985-33DBVR(SOT-23-5)

П.С. Спасибо что помогли разобраться.
Shaman
 
Сообщения: 5
Зарегистрирован: 04 ноя 2015, 21:54

Re: помогите решить проблему с платой ардуино мега

Сообщение Angel71 » 07 ноя 2015, 13:12

китайцы вам что-то должны? :ROFL: наивный
Аватара пользователя
Angel71
 
Сообщения: 9232
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: помогите решить проблему с платой ардуино мега

Сообщение Madf » 09 ноя 2015, 12:01

Возможно брак в плате (дорожках) или под корпусом чипа сопля пасты. Попробуйте просто выпаять и посмотреть (всё равно это делать придется).
Madf
 
Сообщения: 2157
Зарегистрирован: 03 янв 2012, 12:55
Откуда: Москва
прог. языки: VB6, BASCOM, ASM...

Re: помогите решить проблему с платой ардуино мега

Сообщение tomitota » 08 дек 2015, 11:13

Здравствуйте!
Купил комплект для сборки 3D принтера, мозги Mega 2560 + RAMPs 1.4.
Попытался прошить в Mega 2560 марлина, в ответ ide выдает:
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

драйвер для ch340g установлен, пробовал с Ubuntu, результаты те же.
Порт находит, данные отправляются с монитора последовательного порта, TX моргает. Меня смущает, что нет реакции на нажатие кнопки reset. При замыкании RX0-TX0 между собой отсутствует эхо в мониторе - данные отправляются, но обратно ничего не возвращается. Постоянно горят светодиоды L и ON, даже при нажатии на RESET.
Что это может быть, никто не сталкивался?
Вложения
IMG_20151208_114255.jpg
Фото платы
tomitota
 
Сообщения: 2
Зарегистрирован: 29 июн 2015, 20:10
Откуда: Сургут
ФИО: Андрей


Вернуться в Микроконтроллеры

Кто сейчас на конференции

Сейчас этот форум просматривают: Bing [Bot], Rambler [Bot] и гости: 6

Mail.ru counter