roboforum.ru

Технический форум по робототехнике.

 

НЕLР! Не могу запустить ATMega16 !!!

Программирование микроконтроллеров AVR, PIC, ARM.
Разработка и изготовление печатных плат для модулей.

НЕLР! Не могу запустить ATMega16 !!!

Сообщение Janus999 » 10 июл 2006, 12:58

:(
... Не могу запустить ATMega16 - подключение через LPT с STK200/300 на 555АП5, Мега16 стоит на плате с разведёнными портами, подключенной кнопой Reset, БЕЗ КВАРЦА, обвязка по питанию - избыточная, питается всё (плата и буфер) стабильным 5В, ВСЁ ПОДКЛЮЧЕНО ПРАВИЛЬНО, Микроконтроллер НОВЫЙ...
При попытке запрограммить\считать память с помощью VRAsm/PonyProg первый говорит "Can`t resinc", Пони говорит просто "не могу идентифицировать МК"  :(  :?  
Прозвонил\проверил\перепроверил всё - ВСЁ РАБОТАЕТ!
Что за "№;";";??? :x
...
Если есть в Херсоне кто-то зннающий - плиз, свяжитесь со Мной - проверим схему совместно...

... Вобщем, ПОМОГИТЕ, КТО МОЖЕТ ПЛИИИЗЗЗЗЗ!!! ...

Заранее спасибо, жду с нетерпением!..
Janus999
 
Сообщения: 16
Зарегистрирован: 10 июл 2006, 12:36
Откуда: Kherson
ФИО: Nikishin Ernest Vladimirovich

Сообщение KiCom » 10 июл 2006, 16:55

Проверь еще раз, отложи все дело на час и проверь еще раз. Если все собрано правильно, я бы отключил буфер и проверил простыми 5-ю проводками. Попробуй через другую программку прошить, у тебя скорее всего есть компилятор прошей через компилятор.
KiCom
 
Сообщения: 345
Зарегистрирован: 22 окт 2005, 11:15
Откуда: Красноярск

Сообщение -= Александр =- » 10 июл 2006, 19:43

Схему программатора в студию!
Какая длина шлейфа от буфера до платы?
Шьет ли он другие контроллеры?
Не мешают ли какие-нить детали прошиванию? (не висит ли чего-нибудь на ногах через которые шьешь)
Аватара пользователя
-= Александр =-
Мастер Самоделкин
 
Сообщения: 3664
Зарегистрирован: 11 окт 2004, 19:20
Откуда: Россия, СПб
прог. языки: C++, VB, asm
ФИО: Курмис Александр Андреевич

Сообщение Janus999 » 19 июл 2006, 16:28

Шлейф комп - буффер ~ 1м. Буффер - МК ~ 20см.
...Схема - чуть позже.. ..Щас без компа сижу... :?
..На шлейфе SPI висит только пустой разъём с разводкой порта...

...Щас купил 90S2313, попробую с ним... :roll:

...
...Тем не менее если появятся какие-то мысли - велкам...

:wink: Спасибо!
Janus999
 
Сообщения: 16
Зарегистрирован: 10 июл 2006, 12:36
Откуда: Kherson
ФИО: Nikishin Ernest Vladimirovich

Сообщение avr123.nm.ru » 19 июл 2006, 19:03

Cделать нормальные "5 проводков" как у меня

avr123.nm.ru/07.htm    

и пользоваться из CVAVR.  Или авреал на худой конец...
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8


Вернуться в Микроконтроллеры

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 5

Mail.ru counter