roboforum.ru

Технический форум по робототехнике.

 

Proteus 6.9sp3 и эмуляция DS18S20

Программирование микроконтроллеров AVR, PIC, ARM.
Разработка и изготовление печатных плат для модулей.

Proteus 6.9sp3 и эмуляция DS18S20

Сообщение AndySa » 31 май 2006, 18:17

Попробывал простой примерчик от CodeVision - НЕ Работает (
Может у кого получилось? Подскажите где грабли...
AndySa
 
Сообщения: 8
Зарегистрирован: 31 май 2006, 18:13
Откуда: Брянск

Сообщение avr123.nm.ru » 31 май 2006, 18:53

попробуй отладку как в задаче 4 в курсе - и сообщи что не работает.

или подожди пока экстрасенсы по товоему вопросу дадут ответ.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение AndySa » 31 май 2006, 20:00

Ничего не понимаю............(
p.s. пример CV
Вложения
DS1820.rar
(60.18 КиБ) Скачиваний: 132
AndySa
 
Сообщения: 8
Зарегистрирован: 31 май 2006, 18:13
Откуда: Брянск

Сообщение avr123.nm.ru » 31 май 2006, 23:16

че там напихано что после рара 60 кб ???
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение AndySa » 01 июн 2006, 11:41

Всё :oops:
не посмотрел, можно и поменьше сделать
AndySa
 
Сообщения: 8
Зарегистрирован: 31 май 2006, 18:13
Откуда: Брянск

Сообщение avr123.nm.ru » 01 июн 2006, 13:23

если не затруднит посмотри архив к задаче 5 - там необходимые файлы для CVAVR.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение AndySa » 01 июн 2006, 13:48

посмотрел..., но у меня именно с датчиком ds1820 проблема (не видит) :x
AndySa
 
Сообщения: 8
Зарегистрирован: 31 май 2006, 18:13
Откуда: Брянск

Сообщение avr123.nm.ru » 01 июн 2006, 14:19

я понял про датчик. я о том какие файлы достаточно включить в архив к топику.

в PROTEUS есть модель датчика и МК.

в проектах на 1-й стр курса есть подробнейшее описание на русском этого датчика и примеры.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение AndySa » 19 июн 2006, 10:55

примерчик для BascomAvr работает....., бред.....
AndySa
 
Сообщения: 8
Зарегистрирован: 31 май 2006, 18:13
Откуда: Брянск

Сообщение Vooon » 19 июн 2006, 15:36

Интересно но у меня все работает в cvavr
только я сам проект создавал (с помощью кодвизарда)
а не из примеров
Аватара пользователя
Vooon
Site Admin
 
Сообщения: 3324
Зарегистрирован: 09 фев 2006, 15:36
Откуда: Москва
Skype: vooon341
прог. языки: Python, C, Bash, JavaScript, C++, PHP
ФИО: Владимир Ермаков

Сообщение avr123.nm.ru » 19 июн 2006, 17:47

в нескольких из 210 примеров ПРОТЕУС есть 1-wire сеть и этот прибор.

Прога как раз на CVAVR  - посмотри, там все работает.

папка One-wire  далее  NETWORK

Для вас! Краткие курсы: Микроконтроллеры AVR первые шаги.  PROTEUS - мощный симулятор электроники без покупки компонентов и без их сжигания.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение AndySa » 21 июн 2006, 13:27

Открыл я этот проект в Proteus. Да все работает замечательно...
Далее, открыл в кодевижн его же НИЧЕГО не менял, просто скомпилировал заново (скомил. без ошибок вроде нормально) и ВСЕ перестало работать
:shock:  версия 1.24.8b Professional, вот такие пироги....
AndySa
 
Сообщения: 8
Зарегистрирован: 31 май 2006, 18:13
Откуда: Брянск

Сообщение avr123.nm.ru » 21 июн 2006, 13:58

А у меня после перекомпиляции работает. я для курса делал изменения.  у меня CV 1.24.8 d.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение avr123.nm.ru » 21 июн 2006, 13:59

Кстати а что перестало работать ? датчик не работает или симуляция не запускается ?
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение AndySa » 21 июн 2006, 14:33

Поставил 1.24.8d...тот же результат...
Симуляция работает, только пишет хрень...не так как раньше
AndySa
 
Сообщения: 8
Зарегистрирован: 31 май 2006, 18:13
Откуда: Брянск

След.

Вернуться в Микроконтроллеры

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 7

Mail.ru counter