roboforum.ru

Технический форум по робототехнике.

 

Светодиоды еле горят MCR40

Раздел создан специально для людей которым интересна робототехника, но в силу разных причин они не знают с чего начать.
Задавайте ваши вопросы, какими бы простыми они не казались, постоянные посетители форума постараются ответить на них по мере своих сил.
Робот своими руками. Самодельный робот.

Светодиоды еле горят MCR40

Сообщение wan0 » 25 фев 2010, 22:32

Здравствуйте!
Помогите разобраться с проблемой.
Есть Универсальный робо-контроллер MRC-40 (ATmega 16/32/644) http://robozone.su/index.php?newsid=27
Прошил fuse, затем шью тест-программу мигание светодиодами. Прошивается..
После прошивки включаю и наблюдаю, светодиоды горят, но еле-еле, как буд-то питания не хватает. (Питание проверял)
Подскажите что это может быть.
Есть подазрение на кнопку RESET (при пайке немного флюса просочилось), или он не дала бы такого результата?
Аватара пользователя
wan0
 
Сообщения: 13
Зарегистрирован: 10 дек 2007, 00:44
Откуда: Украина, Симферополь
Skype: vokforever
прог. языки: PHP, VB, С++, BASCOM

Re: Светодиоды еле горят MCR40

Сообщение galex1981 » 25 фев 2010, 22:38

А какие фузи биты прошили?
if(!Operate) Read(pDatasheet);
Аватара пользователя
galex1981
 
Сообщения: 4360
Зарегистрирован: 04 дек 2008, 22:44
Откуда: Камышин
Skype: galk-aleksandr1
прог. языки: C, C++, Assm, BasCom, VB, php
ФИО: Галкин Александр Владимирович

Re: Светодиоды еле горят MCR40

Сообщение кулер 23 » 25 фев 2010, 22:50

Кстати такая же проблема токо с мегой 8ой :pardon:
Аватара пользователя
кулер 23
 
Сообщения: 798
Зарегистрирован: 17 апр 2009, 19:44
Откуда: Югорск
Skype: rizhykot
ФИО: Аксютин Юрий

Re: Светодиоды еле горят MCR40

Сообщение wan0 » 25 фев 2010, 22:53

galex1981
Изображение
кулер 23
У меня же, мега8 мигает нормально)
Аватара пользователя
wan0
 
Сообщения: 13
Зарегистрирован: 10 дек 2007, 00:44
Откуда: Украина, Симферополь
Skype: vokforever
прог. языки: PHP, VB, С++, BASCOM

Re: Светодиоды еле горят MCR40

Сообщение galex1981 » 25 фев 2010, 22:55

Тогда код в студию. Фузы нормальные
if(!Operate) Read(pDatasheet);
Аватара пользователя
galex1981
 
Сообщения: 4360
Зарегистрирован: 04 дек 2008, 22:44
Откуда: Камышин
Skype: galk-aleksandr1
прог. языки: C, C++, Assm, BasCom, VB, php
ФИО: Галкин Александр Владимирович

Re: Светодиоды еле горят MCR40

Сообщение wan0 » 25 фев 2010, 22:56

Код: Выделить всёРазвернуть
$regfile = "m32def.dat"                                     'используем Mega32
$crystal = 16000000                                         'частота кварцевого резонатора 16mHz


     Config Portd = Output
Do
     Portd.0 = 0
  Waitms 100
    Portd.0 = 1
Loop

End
Аватара пользователя
wan0
 
Сообщения: 13
Зарегистрирован: 10 дек 2007, 00:44
Откуда: Украина, Симферополь
Skype: vokforever
прог. языки: PHP, VB, С++, BASCOM

Re: Светодиоды еле горят MCR40

Сообщение Michael_K » 25 фев 2010, 22:58

Ноги на выход не забыли поставить?
Схему - тоже в студию :)

Добавлено спустя 1 минуту 22 секунды:
А после portd.0 = 1 не нужно "немножко" подождать???
Последний раз редактировалось Michael_K 25 фев 2010, 23:03, всего редактировалось 1 раз.
Аватара пользователя
Michael_K
 
Сообщения: 6034
Зарегистрирован: 07 окт 2009, 00:29
Откуда: СПб

Re: Светодиоды еле горят MCR40

Сообщение wan0 » 25 фев 2010, 23:00

Ноги на GND и на PortD.0
Изображение
Изображение
Спасибо за оперативность!
Аватара пользователя
wan0
 
Сообщения: 13
Зарегистрирован: 10 дек 2007, 00:44
Откуда: Украина, Симферополь
Skype: vokforever
прог. языки: PHP, VB, С++, BASCOM

Re: Светодиоды еле горят MCR40

Сообщение Michael_K » 25 фев 2010, 23:02

Не.. эту то схему я видел, я имел в виду, куда и откуда светодиоды растут :)

Добавлено спустя 33 секунды:
А после portd.0 = 1 не нужно "немножко" подождать???
Последний раз редактировалось Michael_K 25 фев 2010, 23:03, всего редактировалось 1 раз.
Аватара пользователя
Michael_K
 
Сообщения: 6034
Зарегистрирован: 07 окт 2009, 00:29
Откуда: СПб

Re: Светодиоды еле горят MCR40

Сообщение galex1981 » 25 фев 2010, 23:02

Вообще неверно сконфигурирована нога, нужно так:
Код: Выделить всёРазвернуть
Config Pind.0 = Output

И целый порт сконфигурировать не сможешь
if(!Operate) Read(pDatasheet);
Аватара пользователя
galex1981
 
Сообщения: 4360
Зарегистрирован: 04 дек 2008, 22:44
Откуда: Камышин
Skype: galk-aleksandr1
прог. языки: C, C++, Assm, BasCom, VB, php
ФИО: Галкин Александр Владимирович

Re: Светодиоды еле горят MCR40

Сообщение avr123.nm.ru » 25 фев 2010, 23:03

wan0 писал(а): Есть подазрение на кнопку RESET
Дак тестером померяйте на нем напряжение.

wan0 писал(а): прошивки включаю и наблюдаю, светодиоды горят, но еле-еле
Они еле-еле горят или по программе мигают но тускло ?

Проверьте ваш код в PROTEUS.

Если резисторы 1 кОм и светодиоды тусклые то могут и совсем слабо гореть.

Измеряйте напруги и докладывайте а лучше на схему нанесите в любом редакторе картинок.
Читайте !
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: Светодиоды еле горят MCR40

Сообщение galex1981 » 25 фев 2010, 23:03

после
Код: Выделить всёРазвернуть
Portd.0 = 1

нужно
Код: Выделить всёРазвернуть
waitms 100
if(!Operate) Read(pDatasheet);
Аватара пользователя
galex1981
 
Сообщения: 4360
Зарегистрирован: 04 дек 2008, 22:44
Откуда: Камышин
Skype: galk-aleksandr1
прог. языки: C, C++, Assm, BasCom, VB, php
ФИО: Галкин Александр Владимирович

Re: Светодиоды еле горят MCR40

Сообщение Michael_K » 25 фев 2010, 23:04

Блин, как тут все быстро происходит :)
Аватара пользователя
Michael_K
 
Сообщения: 6034
Зарегистрирован: 07 окт 2009, 00:29
Откуда: СПб

Re: Светодиоды еле горят MCR40

Сообщение avr123.nm.ru » 25 фев 2010, 23:10

wan0 писал(а):Универсальный робо-контроллер
А что в нем РОБО ? Растолкуйте пожалуйста.
Кстати на схеме нет такого слова. Это обычная макетка.

Кстати ATmega16 стоит 80 рублей а ATmega32 стоит 110 рублей, а эта великолепная плата в какую цену ?
Читайте !
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: Светодиоды еле горят MCR40

Сообщение wan0 » 25 фев 2010, 23:15

Спасибо большое за оперативность! Заработало!
Оказалась наивная ошибка в коде)
Код: Выделить всёРазвернуть
$regfile = "m32def.dat"                                     'используем Mega32
$crystal = 16000000                                         'частота кварцевого резонатора 16mHz

Config Pind.0 = Output
Do
     Portd.0 = 0
  Waitms 100
    Portd.0 = 1
       Waitms 100
Loop
End


avr123.nm.ru
давно делал, достал из ящика)
Аватара пользователя
wan0
 
Сообщения: 13
Зарегистрирован: 10 дек 2007, 00:44
Откуда: Украина, Симферополь
Skype: vokforever
прог. языки: PHP, VB, С++, BASCOM


Вернуться в Новичкам или основы основ роботостроения.

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter