roboforum.ru

Технический форум по робототехнике.

 

Что не так с H-мостом?

Раздел создан специально для людей которым интересна робототехника, но в силу разных причин они не знают с чего начать.
Задавайте ваши вопросы, какими бы простыми они не казались, постоянные посетители форума постараются ответить на них по мере своих сил.
Робот своими руками. Самодельный робот.

Что не так с H-мостом?

Сообщение muzhig » 01 май 2013, 13:07

Добрый день и с первомаем всех!

В общем, делаю свой H-мост на N-мосфетах (примерная схема).

Есть:
4 x N-мосфета, открываемых логическим уровнем (40TO3GP)
2 x Драйвера нижнего и верхнего ключа (кажется, это называется half bridge?) (IR2301)

В даташите к драйверу указаны конденсаторы, однако емкость не указана. один из них, насколько я понимаю - сглаживает питание логики, а назначение второго мне не совсем понятно. Но насколько я нагуглил, в драйвере есть некая помпа которая заряжает этот кондер, и он используется для того чтобы выдать напряжение больше чем на истоке, дабы открыть мосфет верхнего ключа.

Однако, я так и не нашел, какая емкость нужня для bootstrap-конденсатора? (да и какая для шунтирования нужна, я тоже не знаю :D)

Если что, сильно не пинайте - это моя первая схема (кроме прямого включения лампочек и моторчиков к источнику питания :) )
Последний раз редактировалось muzhig 02 май 2013, 11:30, всего редактировалось 1 раз.
Аватара пользователя
muzhig
 
Сообщения: 7
Зарегистрирован: 30 апр 2013, 19:48
Откуда: Екатеринбург
Skype: arseny.potapov
прог. языки: python, c++

Re: Емкость конденсаторов на драйвере N-мосфетов

Сообщение Duhas » 01 май 2013, 20:47

100нан для начала )
«Как сердцу выразить себя? … Мысль изреченная есть ложь!»
В этом мире меня подводит доброта и порядочность...
"двое смотрят в лужу, один видит лужу, другой отраженные в ней звезды"
Аватара пользователя
Duhas
 
Сообщения: 6341
Зарегистрирован: 15 сен 2007, 13:03
Откуда: Красноярск
прог. языки: ASM(МК), C(PC)
ФИО: Гагарский Андрей Александрович

Re: Емкость конденсаторов на драйвере N-мосфетов

Сообщение muzhig » 02 май 2013, 11:29

Пробовал разные - от 1мкф до 100мкф. Мост ведет себя странно: 1 подаю на один верхний ключ и один нижний, с другой стороны. При включении питания либо вообще ничего не происходит, либо двигатель пытается стартануть, причем начальный импульс зависит от bootstrap-емкости, после чего плавно останавливается, и третий вариант развития событий - двигатель работает очень медленно (видимо мосфеты в линейном режиме, недооткрылись). Что странно, проверял каждый из 4 ключей: по отдельности все нормально работают, как нижние так и верхние, правда верхние работают при bootstrap-емкости 68 и 100, а с 1мкф не работает.

Вообще то я собирался управлять ШИМ-ом, но мост тестировал простым подтягиванием ножки драйвера до 5В. После повторного прочтения даташита драйвера у меня сложилось впечатление, что ему нужна некая не 100% скважность, чтобы перезаряжать bootstrap-емкость. Это может быть так?

UPD: Кстати, попробовал управлять ШИМ-ом - мосфеты еле открываются на максимальной скважности, двигатель еле еле работает.
Аватара пользователя
muzhig
 
Сообщения: 7
Зарегистрирован: 30 апр 2013, 19:48
Откуда: Екатеринбург
Skype: arseny.potapov
прог. языки: python, c++

Re: Что не так с H-мостом?

Сообщение Duhas » 02 май 2013, 12:41

у меня ощущение что вы все делаете не так. да еще и не понимаете почему. прикиньте по схеме как и когда заряжаются эти емкости. их заряд позволяет открывать полевик.. если в драйвере есть накачка то емкость подзаряжать должно быть не обязательно.
«Как сердцу выразить себя? … Мысль изреченная есть ложь!»
В этом мире меня подводит доброта и порядочность...
"двое смотрят в лужу, один видит лужу, другой отраженные в ней звезды"
Аватара пользователя
Duhas
 
Сообщения: 6341
Зарегистрирован: 15 сен 2007, 13:03
Откуда: Красноярск
прог. языки: ASM(МК), C(PC)
ФИО: Гагарский Андрей Александрович


Вернуться в Новичкам или основы основ роботостроения.

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4

Mail.ru counter