roboforum.ru

Технический форум по робототехнике.

 

Проблема с ХМегой на монтажке

Учиться можно на своих ошибках, но учиться на чужих — быстрее и дешевле ;)

Проблема с ХМегой на монтажке

Сообщение EIN_ENGEL » 19 окт 2010, 01:26

Возникла проблема:
на монтажке под корпус tqfp64 собрал ХМегу 256А3. По всем правилам, на каждой ножке питания 0.1 мкФ, на входе 10 мкФ, питание на плату через феррит, аналоговая часть через катушку. Ресет подтянут к питанию через 10к. Кварц 16 МГц рядом с контроллером, конденсаторы 22пФ прямо на ножки повесил.
Все детали смд.

Так вот, осциллограф показывает, что напряжение на подтянутой ножке ресета гуляет от 0 до самого питания.
При этом, контроллер отлично прошивается и иногда даже работает. То есть сам включается и какое-то время выдаёт то, что должен. И в моменты его пробуждений на ресете где-то около 1,7В.

Перепробовал всё, осталась только одна идея, что контроллер дохлый.
Аватара пользователя
EIN_ENGEL
 
Сообщения: 495
Зарегистрирован: 06 янв 2006, 03:02
Откуда: Москва
прог. языки: VHDL, C++, Matlab

Re: Проблема с ХМегой на монтажке

Сообщение galex1981 » 19 окт 2010, 01:29

Похоже на нестабильность питания. Не проверяли блок питания?

Добавлено спустя 35 секунд:
Кстати, не требуется у ХМег подтягивать Reset к питанию
if(!Operate) Read(pDatasheet);
Аватара пользователя
galex1981
 
Сообщения: 4360
Зарегистрирован: 04 дек 2008, 22:44
Откуда: Камышин
Skype: galk-aleksandr1
прог. языки: C, C++, Assm, BasCom, VB, php
ФИО: Галкин Александр Владимирович

Re: Проблема с ХМегой на монтажке

Сообщение EIN_ENGEL » 19 окт 2010, 01:31

galex1981 писал(а):Похоже на нестабильность питания. Не проверяли блок питания?

Добавлено спустя 35 секунд:
Кстати, не требуется у ХМег подтягивать Reset к питанию



Питание пробовал от регулиремого трансформаторного источника, от ЮСБ и от аккумулятора, не помогает ничего.
Опять же, осциллограф на питании показывает идеально ровную прямую.

Ресет и подтягивал, и отпаивал от питания. И даже выключал фьюзами. Не помогает ничего.
Аватара пользователя
EIN_ENGEL
 
Сообщения: 495
Зарегистрирован: 06 янв 2006, 03:02
Откуда: Москва
прог. языки: VHDL, C++, Matlab

Re: Проблема с ХМегой на монтажке

Сообщение galex1981 » 19 окт 2010, 01:33

А схему привести не сможешь? А то может что то незначительное и сразу не видно
if(!Operate) Read(pDatasheet);
Аватара пользователя
galex1981
 
Сообщения: 4360
Зарегистрирован: 04 дек 2008, 22:44
Откуда: Камышин
Skype: galk-aleksandr1
прог. языки: C, C++, Assm, BasCom, VB, php
ФИО: Галкин Александр Владимирович

Re: Проблема с ХМегой на монтажке

Сообщение EIN_ENGEL » 19 окт 2010, 01:36

sch.jpg


похожая схема, но контроллер А4 и изготовленная плата работают стабильно.
Аватара пользователя
EIN_ENGEL
 
Сообщения: 495
Зарегистрирован: 06 янв 2006, 03:02
Откуда: Москва
прог. языки: VHDL, C++, Matlab

Re: Проблема с ХМегой на монтажке

Сообщение galex1981 » 19 окт 2010, 01:41

По схеме вроде бы порядок, смотреть на монтаже - мож где сопля есть
if(!Operate) Read(pDatasheet);
Аватара пользователя
galex1981
 
Сообщения: 4360
Зарегистрирован: 04 дек 2008, 22:44
Откуда: Камышин
Skype: galk-aleksandr1
прог. языки: C, C++, Assm, BasCom, VB, php
ФИО: Галкин Александр Владимирович

Re: Проблема с ХМегой на монтажке

Сообщение Сергей » 19 окт 2010, 02:06

А где GND_A соединяется с GND?

Добавлено спустя 1 минуту 59 секунд:
А, видимо это внизу. Запаян ferrit bead в месте соединения земель? Я так понял в алтиуме делаете - проверьте цепи питания на плате, это легко делается подсвечиванием линии.
Сергей
 
Сообщения: 3741
Зарегистрирован: 29 дек 2004, 23:15
Откуда: Санкт-Петербург
прог. языки: C, C++, C#, Asm
ФИО: Кашликов Сергей

Re: Проблема с ХМегой на монтажке

Сообщение EIN_ENGEL » 19 окт 2010, 02:12

Сергей писал(а):А где GND_A соединяется с GND?

на схематике через феррит, его видно под контроллером.
На монтажке вся земля цифровая.

Добавлено спустя 4 минуты 56 секунд:
Сергей писал(а):Добавлено спустя 1 минуту 59 секунд:
А, видимо это внизу. Запаян ferrit bead в месте соединения земель? Я так понял в алтиуме делаете - проверьте цепи питания на плате, это легко делается подсвечиванием линии.



В том и дело, что собираю на монтажке, а не на готовой плате. Питание и землю проверил и мультиметром, и осциллографом.
Аватара пользователя
EIN_ENGEL
 
Сообщения: 495
Зарегистрирован: 06 янв 2006, 03:02
Откуда: Москва
прог. языки: VHDL, C++, Matlab

Re: Проблема с ХМегой на монтажке

Сообщение Сергей » 19 окт 2010, 02:16

Каждую ножку питания на МК проверили? Напряжение 3.3? Заземлить осциллограф или мультиметр не забыли?
Сергей
 
Сообщения: 3741
Зарегистрирован: 29 дек 2004, 23:15
Откуда: Санкт-Петербург
прог. языки: C, C++, C#, Asm
ФИО: Кашликов Сергей

Re: Проблема с ХМегой на монтажке

Сообщение EIN_ENGEL » 19 окт 2010, 02:27

Сергей писал(а):Каждую ножку питания на МК проверили? Напряжение 3.3? Заземлить осциллограф или мультиметр не забыли?


Да, мерял каждую ножку, везде 3.3, причём держится стабильно. На осциллографе идеальная прямая.

Сам осциллограф заземлён через шнур питания. Земли с платой соединяются земляным зажимом на щупе.
А как дополнительно заземлять батареечный мультиметр, это надо думать :)
Аватара пользователя
EIN_ENGEL
 
Сообщения: 495
Зарегистрирован: 06 янв 2006, 03:02
Откуда: Москва
прог. языки: VHDL, C++, Matlab

Re: Проблема с ХМегой на монтажке

Сообщение Duhas » 19 окт 2010, 08:09

у меня А3 вообще гикнулась на макетке.. но я грешил на то что флюс под ней был ...
«Как сердцу выразить себя? … Мысль изреченная есть ложь!»
В этом мире меня подводит доброта и порядочность...
"двое смотрят в лужу, один видит лужу, другой отраженные в ней звезды"
Аватара пользователя
Duhas
 
Сообщения: 6341
Зарегистрирован: 15 сен 2007, 13:03
Откуда: Красноярск
прог. языки: ASM(МК), C(PC)
ФИО: Гагарский Андрей Александрович

Re: Проблема с ХМегой на монтажке

Сообщение $ilent » 19 окт 2010, 09:20

Похоже на обрыв подтягивающего резистора на резете и она (нога) как антенна всё ловит.
Встречал такое на восьмой меге.
И вообще, питание не правильное.
  • Общее питание после фильтра, а подтяжка перед;
  • Резет на цифровой земле через ёмкость, когда питание на аналоговой.
$ilent
 

Re: Проблема с ХМегой на монтажке

Сообщение EIN_ENGEL » 19 окт 2010, 15:30

$ilent писал(а):Похоже на обрыв подтягивающего резистора на резете и она (нога) как антенна всё ловит.
Встречал такое на восьмой меге.
И вообще, питание не правильное.
  • Общее питание после фильтра, а подтяжка перед;
  • Резет на цифровой земле через ёмкость, когда питание на аналоговой.


Схема из даташита. На общем входе стоит феррит, его на схематике не видно. Эта катушка только для отвода аналогового питания.
На макетке вся земля цифровая и ёмкости у ресета нет. На схематике я её воткнул чтобы на всякий случай была на будущей плате. При использовании ПДИ её впаивать не нужно.

Добавлено спустя 2 часа 10 минут 21 секунду:
Сейчас включил, работает, выдаёт всё правильно.
Ресет показывает 1В.
А теперь опять вылетела, причём перед этим поплыла длительность генерируемого импульса.
Аватара пользователя
EIN_ENGEL
 
Сообщения: 495
Зарегистрирован: 06 янв 2006, 03:02
Откуда: Москва
прог. языки: VHDL, C++, Matlab

Re: Проблема с ХМегой на монтажке

Сообщение Duhas » 19 окт 2010, 15:40

попробуй перешить на внутренний генератор
«Как сердцу выразить себя? … Мысль изреченная есть ложь!»
В этом мире меня подводит доброта и порядочность...
"двое смотрят в лужу, один видит лужу, другой отраженные в ней звезды"
Аватара пользователя
Duhas
 
Сообщения: 6341
Зарегистрирован: 15 сен 2007, 13:03
Откуда: Красноярск
прог. языки: ASM(МК), C(PC)
ФИО: Гагарский Андрей Александрович

Re: Проблема с ХМегой на монтажке

Сообщение EIN_ENGEL » 19 окт 2010, 16:48

Duhas писал(а):попробуй перешить на внутренний генератор

пробовал, работает постабильнее, но при этом сама частота гуляет. На разных каналах осциллографа идут импульсы с ШИМ, один с платы, работающей от внутренней РЦ на 32Мгц без всяких калибровок. Второй от ПЛЛ и кварца на 16 МГц. Так вот нестабильность РЦ видно "невооружённым глазом".

Хотя да, так оно работает стабильнее. То есть без вылетов как у ПЛЛ.



Более-менее работает при внутреннем генераторе 32МГц и отключенном фьюзами ресете.
Аватара пользователя
EIN_ENGEL
 
Сообщения: 495
Зарегистрирован: 06 янв 2006, 03:02
Откуда: Москва
прог. языки: VHDL, C++, Matlab


Вернуться в Осторожно — грабли ;)

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter