roboforum.ru

Технический форум по робототехнике.

 

Пять проводков, ЛПТ порт и некоторые настройки биоса

Учиться можно на своих ошибках, но учиться на чужих — быстрее и дешевле ;)

Пять проводков, ЛПТ порт и некоторые настройки биоса

Сообщение =DeaD= » 02 авг 2005, 21:53

Одной из причин неработоспособности программатора "пять проводков", а скорее и других работающих через LPT-порт может быть настройка режима работы этого самого порта в БИОСе - выбирайте там "Нормальный" режим, а не всякие "ECS" которые могут быть по умолчанию (про ЕЦС - название по памяти пишу, но что-то такое).

Я убил 3 часа и много нервных клетов в попытках понять - а не сжег ли я ЛПТ порт в новом компе... и почему если не сжег не работает программатор "5 проводков", который без всякой модификации работал на предыдущем компе.
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Пять проводков, ЛПТ порт и некоторые настройки биоса

Сообщение Pegasus » 03 авг 2005, 06:54

=DeaD= писал(а):...а скорее и других работающих через LPT-порт ...

Могу подтвердить, такая же фигня была, когда пытался прошить ПЛИС от ALTERA самодельным байтбластером из 5-ти проводков.
Pegasus
 
Сообщения: 26
Зарегистрирован: 05 июл 2005, 08:06
Откуда: Пермь

Сообщение -= Александр =- » 03 авг 2005, 21:38

Надо туда SN74HC244 вставить буфером и все будет ОК!
Аватара пользователя
-= Александр =-
Мастер Самоделкин
 
Сообщения: 3664
Зарегистрирован: 11 окт 2004, 19:20
Откуда: Россия, СПб
прог. языки: C++, VB, asm
ФИО: Курмис Александр Андреевич

Сообщение =DeaD= » 03 авг 2005, 22:28

-= Александр =- писал(а):Надо туда SN74HC244 вставить буфером и все будет ОК!

Да не было бы все ОК, при таких настройках биоса оно вообще черти-как перекраивало пины в ЛПТ-порту, даже между 3 и 25 пином постоянно было 0.18В вместо положеных ~5.0В

Так что правильные настройки биоса и все ок безо всяких SN74HC244, хотя я чуть было не повелся брать в руки паяльник и без пользы потратить еще 2-3 часа...
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Сообщение setar » 04 авг 2005, 14:03

Прикольно :)
не знал. а у меня и так работало!
EPP и ECP характерны включением двунаправленности у шины данных в порту а обычный только на запись
(приём там есть по специальным ногам, имеется ввиду только запись по битам данных)
Аватара пользователя
setar
Site Admin
 
Сообщения: 9246
Зарегистрирован: 04 окт 2004, 12:58
Откуда: St.Petersburg
Skype: taranenko.sergey
ФИО: Сергей Тараненко

Сообщение KiCom » 16 ноя 2005, 18:03

Вообще спаял я этот програматор но он не хочет работать, в биосе все так, порт не спалил принтер на нем нормально работает. В чем может быть причина? Проводки не перепутал, короткого замыкания нет, все проверил на сто рядов, может косяк в программе пользую PonyProg v 1.17h
KiCom
 
Сообщения: 345
Зарегистрирован: 22 окт 2005, 11:15
Откуда: Красноярск

Сообщение setar » 18 ноя 2005, 15:23

KiCom писал(а):Вообще спаял я этот програматор но он не хочет работать, в биосе все так, порт не спалил принтер на нем нормально работает. В чем может быть причина? Проводки не перепутал, короткого замыкания нет, все проверил на сто рядов, может косяк в программе пользую PonyProg v 1.17h

вариантов много. помехи на проводе, не запускается конторолер, неисправен контроллер и т.д.
Аватара пользователя
setar
Site Admin
 
Сообщения: 9246
Зарегистрирован: 04 окт 2004, 12:58
Откуда: St.Petersburg
Skype: taranenko.sergey
ФИО: Сергей Тараненко

Сообщение KiCom » 18 ноя 2005, 15:26

Что понимать под словом незапускаеться контролер? Контролел должен быть исправен т.к. новый только что из магазина.
KiCom
 
Сообщения: 345
Зарегистрирован: 22 окт 2005, 11:15
Откуда: Красноярск

Сообщение setar » 18 ноя 2005, 19:10

KiCom писал(а):Что понимать под словом незапускаеться контролер? Контролел должен быть исправен т.к. новый только что из магазина.

1. не факт
2. правильно ли подведено питание, имеется ли фильтр от помех?
3. имеется ли подтягивающее сопротивление на ноге ресет?
4. уж не через ноутбук ли вы всё это пытаетесь делать ? у меня через раз проблеммы были.
Аватара пользователя
setar
Site Admin
 
Сообщения: 9246
Зарегистрирован: 04 окт 2004, 12:58
Откуда: St.Petersburg
Skype: taranenko.sergey
ФИО: Сергей Тараненко

Сообщение KiCom » 18 ноя 2005, 20:26

Питания правильно
Фильтра нет разве могут фонить батарейки подключеные через КРЕН или всетаки могут? Если да то куда ставить конденсатор на выход между землей и плюсом?
Сопротивления нет, а что разве надо? Сколько ом?
Нет на обычном настольном компе.

Вообещ он себя как-то странно ведет через Pony Prog  не работает а через IMCC работает но через раз, провода экранированые поставил.
KiCom
 
Сообщения: 345
Зарегистрирован: 22 окт 2005, 11:15
Откуда: Красноярск

Сообщение Outcaster » 18 ноя 2005, 21:12

KiCom писал(а):Вообещ он себя как-то странно ведет через Pony Prog  не работает а через IMCC работает но через раз, провода экранированые поставил.
Нужно внимательно сигнальные линии посмотреть - иногда на них грязноватый нулик получаеться (не факт что у всех, но мой ЛПТ-шник вообще по нулю в Z линию почему-то переводит :? ), поэтому подпираю 5К на землю - и порядок :)
Outcaster
 
Сообщения: 267
Зарегистрирован: 13 ноя 2004, 01:10
Откуда: Ривне, Украина

Сообщение KiCom » 18 ноя 2005, 21:39

Очень трудно было понять, тоесть каждый сигнальный провод замкнуть через резистор на 5 кОм на землю, тоесть ноги MOSI,MISO, SCK,RST черех 5 кОм на землю? так или нет?
KiCom
 
Сообщения: 345
Зарегистрирован: 22 окт 2005, 11:15
Откуда: Красноярск

Сообщение KiCom » 20 ноя 2005, 14:32

Все работает !!! Поставил резистор на reset и конденсатор на питание. Толькочто залил простую "мигалку"  что удивительно работает :)
KiCom
 
Сообщения: 345
Зарегистрирован: 22 окт 2005, 11:15
Откуда: Красноярск

Сообщение testers » 20 ноя 2005, 15:45

Вывесь пожалуйста итогово рабочую схему - у меня нифига не пашет...
Аватара пользователя
testers
 
Сообщения: 97
Зарегистрирован: 27 июл 2005, 19:29
Откуда: Москва

Сообщение KiCom » 20 ноя 2005, 16:04

R1 - резистор 10 кОм
С1 - конденсатор электролит 4.7 uf (в диаметре 3-4 мм) я взял какой был
Вложения
1.jpg
KiCom
 
Сообщения: 345
Зарегистрирован: 22 окт 2005, 11:15
Откуда: Красноярск

След.

Вернуться в Осторожно — грабли ;)

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter