roboforum.ru

Технический форум по робототехнике.

 

Не работает ни один программатор!

Учиться можно на своих ошибках, но учиться на чужих — быстрее и дешевле ;)

Не работает ни один программатор!

Сообщение Snake_sx_1 » 29 дек 2007, 19:03

В общем так,был программатор на LPT c применением микрухи 74HC244 в качестве буфера(чтоб не горел порт),все работало,он прошивал и читал Atmega8,а когда я стал прошивать Attiny2313 то выскочила ошибка Device missing or unknown device (-24),поставил Atmega8 и опять та же ошибка,тест в Pony Prog OK,купил я JONISPROG,точно не знаю какой там кабель ему надо(написано DB9M-DB9F),соединил все проводки 1-1 2-2 3-3 4-4 ...9-9,тест OK,но при чтении или прошивании Device missing or unknown device (-24),переустановил Windows,опять ошибка!!!И даже сходил к другу проверить на его компьютере,оба программатора выдают ту же самую ошибку!Кто нубудь может помоч?Может у кого нибудь есть JONIS PROG,как же его все таки запустить?А вообще хоть бы какой нибудь заработал....
Аватара пользователя
Snake_sx_1
 
Сообщения: 9
Зарегистрирован: 25 ноя 2007, 20:21

Re: Не работает ни один программатор!

Сообщение =DeaD= » 11 янв 2008, 11:09

Может контакты где-то всё-таки не так зацеплены? Почти всегда с программаторами нормальными в этом дело. Прозвоните все цепи.
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Не работает ни один программатор!

Сообщение Snake_sx_1 » 20 янв 2008, 16:12

В купленном программаторе думаю с цепями все впорядке,а провод прозвонил,там нормально!В самодельном заменил микросхему,он кое как работает,записывает не то что надо,в конце записи и чтения выдает ошибку,по сути тоже не пашет!
Аватара пользователя
Snake_sx_1
 
Сообщения: 9
Зарегистрирован: 25 ноя 2007, 20:21

Re: Не работает ни один программатор!

Сообщение -= Александр =- » 21 янв 2008, 18:04

У меня такое было с длинным кабелем. Провод от программатора до контроллера должен быть не длиннее 20 см.
Ниндзя - круче всех. Они умеют ходить по воде, делить на ноль и угадывать шаффл в АйПоде.
Аватара пользователя
-= Александр =-
Мастер Самоделкин
 
Сообщения: 3664
Зарегистрирован: 11 окт 2004, 19:20
Откуда: Россия, СПб
прог. языки: C++, VB, asm
ФИО: Курмис Александр Андреевич

Re: Не работает ни один программатор!

Сообщение galex1981 » 18 дек 2008, 18:25

У меня аналогичное было с удлинителем LPT. Без него все работает...
if(!Operate) Read(pDatasheet);
Аватара пользователя
galex1981
 
Сообщения: 4360
Зарегистрирован: 04 дек 2008, 22:44
Откуда: Камышин
Skype: galk-aleksandr1
прог. языки: C, C++, Assm, BasCom, VB, php
ФИО: Галкин Александр Владимирович

Re: Не работает ни один программатор!

Сообщение tmx-pirate » 30 июн 2011, 17:57

доброго времени суток! у меня дикая проблема !!! ни один из подтыкаемых программаторов не прошивает !!! изночально был собран ultrapic работающий на СОМ вполне не плохо читает контроллеры но не пишет! перебрал его на LPT та же история, собрал другой программатор тоже самое и 3-й и 5-й в общем начиная думать на свою кривизну рук купил программатор так этот то же самое выдаёт !!! собрал второй комп и перепробовал там всё железо тот же эффект!!! HELP!!!!!!!!!! :O:
tmx-pirate
 
Сообщения: 1
Зарегистрирован: 30 июн 2011, 17:05

Re: Не работает ни один программатор!

Сообщение =DeaD= » 01 июл 2011, 10:39

На современных матерях надо LPT порт в биосе переключить в обычный режим из расширенного.
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24053
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: Pascal / C++ / PHP / 1C
ФИО: Антон Ботов

Re: Не работает ни один программатор!

Сообщение Full-scale » 29 ноя 2011, 10:50

Если читает но не пишет или пишет с ошибками, вероятнее всего отсутствует или недостаточное питание на контроллере.
Аватара пользователя
Full-scale
 
Сообщения: 3
Зарегистрирован: 24 авг 2010, 18:04
Откуда: Челябинск
Skype: Full-scale
прог. языки: asm-avr, Perl, C/C++
ФИО: Андрей

Re: Не работает ни один программатор!

Сообщение iburo » 30 апр 2012, 01:58

У меня работает, вот с картинками тут даже всё нарисовано, как раз ATTtiny2313
OpenRobo.ru роботы для производства. Открытые проекты.
Аватара пользователя
iburo
 
Сообщения: 81
Зарегистрирован: 01 май 2011, 01:15


Вернуться в Осторожно — грабли ;)

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter