roboforum.ru

Технический форум по робототехнике.

 

DataVision16230

Учиться можно на своих ошибках, но учиться на чужих — быстрее и дешевле ;)

DataVision16230

Сообщение Atmega16 » 23 июн 2007, 21:56

дисплей DataVision16230.Война с неведомым.у него нет подсветки.проблема молчания дисплея была решена путем глубокого рассмотрения фьюзов контроллера.не смотря на то что была указана частота тактирования 4мгц,контроллер исправно отмерял секунды на внутреннем генераторе 1мгц(до сих пор не понимаю как).я так и не понял как выставить их верно,и взял готовые фьюзы частоты у avr123 в курсе.после этого все работает.
Atmega16
 
Сообщения: 58
Зарегистрирован: 03 май 2007, 12:45
Откуда: Аксай(Рост.обл.)
прог. языки: C

Сообщение avr123.nm.ru » 23 июн 2007, 22:46

Ну и славненько !
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение SSG » 25 июн 2007, 10:25

[off]АВР заработал очередной чупа-чупс [/off] :lol:
Аватара пользователя
SSG
 
Сообщения: 1058
Зарегистрирован: 15 янв 2007, 19:23
Откуда: Беларусь, Барановичи
прог. языки: С для МК, Delphi для ПК

Сообщение 40inD » 29 июн 2007, 10:20

ээээ.... ммм... а причем тут дисплей?
Аватара пользователя
40inD
 
Сообщения: 265
Зарегистрирован: 17 июн 2005, 08:08
Откуда: Москва

Сообщение Atmega16 » 01 июл 2007, 17:35

да собственно ни при чем.но должны же люди знать о возможных проблемах.вчера еще одну победил:на экране не результат ацп а какаято ахинея.оказалось все просто:нужно добавить вывод на дисплей после результата ацп строки с числом пробелов (число знаков значения ацп-1).иначе при малом результате преобразования старое значение на дисплее вносит путаницу
Atmega16
 
Сообщения: 58
Зарегистрирован: 03 май 2007, 12:45
Откуда: Аксай(Рост.обл.)
прог. языки: C


Вернуться в Осторожно — грабли ;)

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter