roboforum.ru

Технический форум по робототехнике.

 

не срабатывает реле....

Резисторы, транзисторы, конденсаторы, микросборки, чип компоненты ...
Вопросы согласования управляющих модулей с периферией.

не срабатывает реле....

Сообщение MihailHomykov » 17 окт 2008, 17:30

Здравствуйте! Хотелось бы узнать у уважаемых участников конференции сталкивался ли кто нибудь с подобной проблемой и как ее возможно устранить! Дело вот в чем! Имеется небольшой хобийный станочек подключаемый к компьютеру через лпт и управляемый программой турбо цнц из под дос, программой предусмотренно автоматическое включение и отключение шпинделя после выполнения программы и беда в том что с одним комьютером все ок! а с тем который был специально приобретен для управления станком(старенький пень2 ) эта функция не работает не срабатывает реле управляющее питанием шпинделя, висит оно на 14 пине! как с этим бороться? Заранее благодарен за дельные советы!
MihailHomykov
 
Сообщения: 5
Зарегистрирован: 17 окт 2008, 16:59

Re: не срабатывает реле....

Сообщение Vooon » 17 окт 2008, 17:45

Не ясно как реле подключено к ЛПТ. Нарисуйте схему.
Linux user | Firefox user
Аватара пользователя
Vooon
Site Admin
 
Сообщения: 3324
Зарегистрирован: 09 фев 2006, 15:36
Откуда: Москва
Skype: vooon341
прог. языки: Python, C, Bash, JavaScript, C++, PHP
ФИО: Владимир Ермаков

Re: не срабатывает реле....

Сообщение MihailHomykov » 17 окт 2008, 18:08

Нарисовать нет никакого редактора , да и в схемотехнике не силен. Но там стоит опторазвязка она встроена в контроллер. Отчасти от нее и сложности - без нее порог срабатывания около 2мА, а с ней - 10-12мА. Зато от нее защита порта компьютера. Что бы такое придумать что бы усилить сигнал...
MihailHomykov
 
Сообщения: 5
Зарегистрирован: 17 окт 2008, 16:59

Re: не срабатывает реле....

Сообщение avr123.nm.ru » 17 окт 2008, 18:26

MihailHomykov писал(а): не срабатывает реле управляющее питанием шпинделя, висит оно на 14 пине! как с этим бороться? Заранее благодарен за дельные советы!

Посмотрите меняется ли исгнал на этом пине. Во многих ЧПУ прогах пины в LPT можно назначать самому - попробуйте другой если этот не работает.

Для теста LPT есть прога Кофтуна - смотрите на http://avr123.nm.ru/z4.htm

MihailHomykov писал(а): Что бы такое придумать что бы усилить сигнал...
эмтерный повторитель можно добавить на КТ3102 или bc547 (он на 0.7 вольт вых сигнал снизит) или ключик на паре транзисторов и 3-4 резисторах. Опишите логику работы пина и входа контрллера и напряжения.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: не срабатывает реле....

Сообщение -= Александр =- » 17 окт 2008, 20:08

Один конец обмотки реле вешается на + питания, а второй через переход сток-исток полквика какого-нить, например IRLZ44 - купить не проблема. А затвор полевика идет к контроллеру. Ну, для безопасности с затвора на землю 10 кОм повесить можно...

Ну а если с пина порта ничего не выходит - можно в Биосе попробовать другие рехимы работы порта. Там ECP EPP SPP и т.п.
Ниндзя - круче всех. Они умеют ходить по воде, делить на ноль и угадывать шаффл в АйПоде.
Аватара пользователя
-= Александр =-
Мастер Самоделкин
 
Сообщения: 3664
Зарегистрирован: 11 окт 2004, 19:20
Откуда: Россия, СПб
прог. языки: C++, VB, asm
ФИО: Курмис Александр Андреевич

Re: не срабатывает реле....

Сообщение Victorovych » 17 окт 2008, 23:04

+1
Настроить в биосе нужный режим порта
Аватара пользователя
Victorovych
 
Сообщения: 491
Зарегистрирован: 20 сен 2007, 11:44
Откуда: Харьков
Skype: Victorovych_FF
прог. языки: ASM
ФИО: Иван ВикторОвич

Re: не срабатывает реле....

Сообщение MihailHomykov » 18 окт 2008, 18:15

ковыряю биос рзультат пока нулевой :(
MihailHomykov
 
Сообщения: 5
Зарегистрирован: 17 окт 2008, 16:59

Re: не срабатывает реле....

Сообщение avr123.nm.ru » 18 окт 2008, 18:42

Да че там ковырять то. Вы на ножке напругу померяйте и написшите сюда результат и что контроллеру надо и будет ясно че делать.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: не срабатывает реле....

Сообщение MihailHomykov » 18 окт 2008, 19:10

дык а как ее поменять я понять и не могу... :pardon:

Добавлено спустя 4 минуты 24 секунды:
есть закладка communicftion в ней
1/ ecp printer port
2/ 16550a com port
3/ Generic fast infared port
на сколько я понимаю мне нужен пункт 1 а вот как внем поменять напругу на 14 ногке я понять не могу...
MihailHomykov
 
Сообщения: 5
Зарегистрирован: 17 окт 2008, 16:59

Re: не срабатывает реле....

Сообщение avr123.nm.ru » 18 окт 2008, 19:18

Измерять мультиметром надобно или тестером или вольтметром.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Re: не срабатывает реле....

Сообщение MihailHomykov » 18 окт 2008, 20:19

ой не поменять , а померить :o все понял.... до мультиметра доберусь померю ...
MihailHomykov
 
Сообщения: 5
Зарегистрирован: 17 окт 2008, 16:59

Re: не срабатывает реле....

Сообщение Mazayac » 18 окт 2008, 20:29

MihailHomykov писал(а):...
есть закладка communicftion в ней
1/ ecp printer port
...

Порт работает в режиме ECP, а если я не ошибаюсь, то крайне желательно устанавливать SPP (или Standard)
Аватара пользователя
Mazayac
 
Сообщения: 377
Зарегистрирован: 25 апр 2008, 17:40
Откуда: Нижний Новгород
ФИО: Непочатов Алексей Николаевич


Вернуться в Электроника, электротехника

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter