roboforum.ru

Технический форум по робототехнике.

 

Проблема с L293D

Резисторы, транзисторы, конденсаторы, микросборки, чип компоненты ...
Вопросы согласования управляющих модулей с периферией.

Проблема с L293D

Сообщение Lockdog » 27 июн 2008, 19:50

Проблема собственно вот в чём:
когда подаю питание и меряю вольтметром напряжение на контактах двигателей, то на всех "+" - соответственно они не вращаются.
Двигатели питаю от 9-ти вольтовой "кроны", а саму микросхему от 3-ёх плоских батареек...
В чём может быть проблема? Косяков с контактами вроде нету...
Пробовал на двух микросхемах - результат один и тот же...
Вложения
DSC01212.JPG
Аватара пользователя
Lockdog
 
Сообщения: 639
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с L293D

Сообщение space » 27 июн 2008, 21:11

Ну во-первых они крутится ни когда не будут пока не появится сигнал на одной из ножек(INPUT1-INPUT4).
Ну а во-вторых собери вот эту схемку всё же правильней будет.
Вложения
27947.jpg
Принципиальная схема
60386.jpg
ТО что должно получиться
60386.jpg (60.13 КиБ) Просмотров: 377
L293D.rar
Разводка платы и принципиальная схема в формате splan 6.0. 0. 1
(107.25 КиБ) Скачиваний: 52
Аватара пользователя
space
 
Сообщения: 548
Зарегистрирован: 17 июн 2007, 23:44
Откуда: Тула
прог. языки: Bascom AVR Basic, CodeVisionAVR
ФИО: Замотаев Кирилл Игоревич

Re: Проблема с L293D

Сообщение Myp » 27 июн 2008, 21:17

space писал(а):они крутится ни когда не будут пока не появится сигнал на одной из ножек(INPUT1-INPUT4).

причём обязательно чтоб на одной ноге было +5 вольт а на другой ноге небыло
и также для второй половины
а если тупо на все 4 ноги подать + то ничо крутицца не будет так же как если на все 4 ноги подать -
<telepathmode>На вопросы отвечает Бригадир Телепатов!</telepathmode>
Всё уже придумано до нас!
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 15942
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Re: Проблема с L293D

Сообщение Lockdog » 27 июн 2008, 21:29

В том то весь и прикол, что я на ноги 2, 7, 10, 15 ничего не подаю, я просто питаю схему и двигатели и на всех ногах, идущих к двигам подаётся "+"... Так то и я знаю что должны разные полюса быть =)
Та схема не катит, потому что она большая, а я собрал маленькую платформу (6 см) на 3-ёх колёсах.
Аватара пользователя
Lockdog
 
Сообщения: 639
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с L293D

Сообщение Myp » 27 июн 2008, 22:04

а если запитать? то моторы крутятся?

а чем тебя смущает что там на ногах на всех + ?
он те что мешает чемто?
<telepathmode>На вопросы отвечает Бригадир Телепатов!</telepathmode>
Всё уже придумано до нас!
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 15942
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Re: Проблема с L293D

Сообщение Lockdog » 28 июн 2008, 01:11

Смущает, то что я сигналов никаких не подаю...
Если запитать 2 и 15, то всёравно не крутятся, на других ногах двига тоже остаются плюсы, хотя 7 и 10 я не запитывал...

Ведь должно быть так, если я не подаю "1" на 2, 15 или 7, 10, то на контактах к двигателю должно быть "0"...

Добавлено спустя 2 часа 37 минут 5 секунд:
Померил вольтметром все ноги и на всех (кроме "земли") есть напряжение... о_О
Аватара пользователя
Lockdog
 
Сообщения: 639
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с L293D

Сообщение SSG » 28 июн 2008, 11:15

Lockdog писал(а):Померил вольтметром все ноги и на всех (кроме "земли") есть напряжение... о_О

Отсюда вывод - логический ноль - это не отсутствие сигнала, а низкий уровень относительно земли. Поэтому чтобы для тестирования подать ноль подключайте ножки к схемной землице. :)
I live My life!
Аватара пользователя
SSG
 
Сообщения: 1058
Зарегистрирован: 15 янв 2007, 19:23
Откуда: Беларусь, Барановичи
прог. языки: С для МК, Delphi для ПК

Re: Проблема с L293D

Сообщение yak-40 » 28 июн 2008, 21:10

Lockdog писал(а):Смущает, то что я сигналов никаких не подаю...
Если запитать 2 и 15, то всёравно не крутятся, на других ногах двига тоже остаются плюсы, хотя 7 и 10 я не запитывал...


На них уже присутствуют логические единицы.
Поэтому их надо не "запитывать", а подавать логические нули.
И будет тебе счастье)))
- Этот человек - не человек! это робот!
- Как? уже делают?!
- Делают!!!
Аватара пользователя
yak-40
 
Сообщения: 3019
Зарегистрирован: 23 окт 2007, 22:03
Откуда: Москва
прог. языки: С
ФИО: Евгений Яковец

Re: Проблема с L293D

Сообщение Lockdog » 28 июн 2008, 23:04

Подключил выводы 2 и 15 к "земле", моторы вращаются, но когда размыкаю, то они продолжают вращаться...
Аватара пользователя
Lockdog
 
Сообщения: 639
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с L293D

Сообщение yak-40 » 28 июн 2008, 23:23

Lockdog писал(а):Подключил выводы 2 и 15 к "земле", моторы вращаются, но когда размыкаю, то они продолжают вращаться...

Во первых: нельзя оставлять эти выводы неподключенными.
Надо или подавать единицу (плюс) или ноль (земля)
Во вторых: это делать надо не только с 2 и 15 но и с 7 и 10.
например, 2-0 7-1 ткрутится в одну сторону, 2-1 7-0 крутится в другую сторону.
2-0 7-0 стоп, 2-1 7-1 стоп.
Повторяю, свободными (неподключенными) выводы оставлять НЕЛЬЗЯ!
- Этот человек - не человек! это робот!
- Как? уже делают?!
- Делают!!!
Аватара пользователя
yak-40
 
Сообщения: 3019
Зарегистрирован: 23 окт 2007, 22:03
Откуда: Москва
прог. языки: С
ФИО: Евгений Яковец

Re: Проблема с L293D

Сообщение Lockdog » 28 июн 2008, 23:47

А если я просто хочу подключить фотодиоды к выводам 2 и 15, чтобы бот поворачивал в сторону света?

Просто около года назад, когда я делал такую же схему, всё работало...
Аватара пользователя
Lockdog
 
Сообщения: 639
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с L293D

Сообщение yak-40 » 29 июн 2008, 00:01

Lockdog писал(а):А если я просто хочу подключить фотодиоды к выводам 2 и 15, чтобы бот поворачивал в сторону света?

7 и 10 к земле намертво. 2 и 15 подтянуть тоже к земле через резисторы (резисторы подбирать опытным путем по уверенному срабатыванию. номиналы зависят от типов фотодиодов) и всё заработает.
Удачи!!!
- Этот человек - не человек! это робот!
- Как? уже делают?!
- Делают!!!
Аватара пользователя
yak-40
 
Сообщения: 3019
Зарегистрирован: 23 окт 2007, 22:03
Откуда: Москва
прог. языки: С
ФИО: Евгений Яковец

Re: Проблема с L293D

Сообщение Lockdog » 29 июн 2008, 00:11

Спасибо, буду пробовать...

Добавлено спустя 2 минуты 46 секунд:
А фотодиоды я подключаю к плюсу и к 2 и 15, правильно понимаю?
Аватара пользователя
Lockdog
 
Сообщения: 639
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с L293D

Сообщение Lockdog » 29 июн 2008, 15:32

Сделал всё как ты посоветовал, но при включении (и при неподключённых фотодиодах) моторы вращаются...
Аватара пользователя
Lockdog
 
Сообщения: 639
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

Re: Проблема с L293D

Сообщение Lockdog » 29 июн 2008, 22:35

Посмотрел разные схемы в интернете, везде делается так же, как и у меня было изначально...
И у меня когда я давно делал такую схему впервые, то делал так же...
Вот например:
Вложения
56907.jpg
Аватара пользователя
Lockdog
 
Сообщения: 639
Зарегистрирован: 06 июл 2006, 20:42
Откуда: Москва
прог. языки: C/C++, Pascal, Delphi
ФИО: Анатолий Зимин

След.

Вернуться в Электроника, электротехника

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter