roboforum.ru

Технический форум по робототехнике.

 

Электромагнитные помехи от моторов и как с ними бороться.

Резисторы, транзисторы, конденсаторы, микросборки, чип компоненты ...
Вопросы согласования управляющих модулей с периферией.

Электромагнитные помехи от моторов и как с ними бороться.

Сообщение Ruslan » 14 авг 2007, 07:01

Народ,
Помогите справиться с помехами. Начал строить робота для сумо и обнаружил, что при работающих моторах сенсоры показыают погоду вместо расстояния :?. Пока попробовал припаять конденсаторы 0.1 мкФ между выводами моторов и корпусами - безрезультатно. При этом мозг (AVR 168) работает нормально.
Что еще посоветуете?

Моторы Maxon (http://www.banebots.com/pc/MP-MISC/MP-13017)
Сенсоры Шарп GP2Y0A21YK и  Maxbotics LV-MaxSonar-EZ1.

Спасибо!
Аватара пользователя
Ruslan
 
Сообщения: 588
Зарегистрирован: 03 июн 2007, 22:32
Откуда: Москва
ФИО: Руслан

Сообщение avr123.nm.ru » 14 авг 2007, 11:31

конденсатор обычно паяют между выводами мотора.  можно провода от мотора пару раз пропустить вокруг ферритового колечка, можно пару дросселей поставить.

Питание у тебя сделано так же как в апноуте на avr123.nm.ru/01.htm  ?  рекомендую.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8

Сообщение SSG » 14 авг 2007, 17:05

Я ставлю керамические конденсаторы по 0.47 мкФ, как Вы и писали: один между выводами мотора, и по одному от каждого вывода на корпус мотора. Хватает. А как напряжение стабилизируется, может стабилизатор на издыхании?
Аватара пользователя
SSG
 
Сообщения: 1058
Зарегистрирован: 15 янв 2007, 19:23
Откуда: Беларусь, Барановичи
прог. языки: С для МК, Delphi для ПК

Сообщение Ruslan » 14 авг 2007, 19:51

Стабилизатор вроде в порядке. Буду эксперименировать с конденсаторами и дросселями. А как сделать правильный дроссель и как подобрать конденсатор? Моторы будут работать в режиме ШИМ.
Аватара пользователя
Ruslan
 
Сообщения: 588
Зарегистрирован: 03 июн 2007, 22:32
Откуда: Москва
ФИО: Руслан

Сообщение The_Kurs » 15 авг 2007, 12:29

Попробуй дроссели использовать с компьютерных БП или дроссели с питания процессоров на материнских платах может помогут...)))
The_Kurs
 
Сообщения: 161
Зарегистрирован: 16 фев 2007, 16:33
Откуда: Петропавловск-Камчатский

Сообщение Ruslan » 16 авг 2007, 20:46

Тут добрые люди подсказали, что регулятор напряжения не справляется с моторами и сенсорами одновременно. И точно - повесил сенсор на + батареи и всё заработало. Так что проблема решилась.  8) Спасибо всем за советы!
Аватара пользователя
Ruslan
 
Сообщения: 588
Зарегистрирован: 03 июн 2007, 22:32
Откуда: Москва
ФИО: Руслан

Сообщение avr123.nm.ru » 16 авг 2007, 20:56

RiO писал(а):И точно - повесил сенсор на + батареи и всё заработало.


Я и писал - питание проверяй.
Аватара пользователя
avr123.nm.ru
отсылающий читать курс
 
Сообщения: 14200
Зарегистрирован: 06 ноя 2005, 04:18
Откуда: Москва
Предупреждения: -8


Вернуться в Электроника, электротехника

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter