roboforum.ru

Технический форум по робототехнике.

 

Гироскоп GY-521

Резисторы, транзисторы, конденсаторы, микросборки, чип компоненты ...
Вопросы согласования управляющих модулей с периферией.

Гироскоп GY-521

Сообщение ivpo » 13 янв 2014, 09:42

Здравствуйте.

Пытаюсь освоить GY-521 (на базе MPU6050). Есть несколько вопросов. Если у кого-нибудь есть опыт использования - поделитесь пожалуйста.

1) В разных источниках указывают разное допустимое напряжение питания - либо 3.3 В, либо 3.3/5 В. Никак не пойму можно ли его использовать с пятивольтовым Arduino. К тому же тут нужно согласовывать как напряжение питания, так и напряжение сигнала?

2) Достаточно ли данного гироскопа, чтобы обеспечить прямое движение небольшой тележки (типа dagu 4wd/6wd) без энкодеров?

3) Какие есть улучшенные аналоги данного модуля? Может быть посоветуете что-нибудь?

Заранее огромное спасибо!
ivpo
 
Сообщения: 14
Зарегистрирован: 06 ноя 2013, 03:48

Re: Гироскоп GY-521

Сообщение elmot » 13 янв 2014, 10:16

2) нет. MEMS гироскопы врут все, причем неслабо так врут. Их как правило используют в комплекте с чем-то еще, позволяющем компенсировать плывущий ноль гироскопа. чаще всего с акселерометрами. Причем мне кажется что направление по горизонтали держать таким гироскопом вообще нереальченко.
Аватара пользователя
elmot
 
Сообщения: 5674
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: Гироскоп GY-521

Сообщение Angel71 » 13 янв 2014, 10:22

1) единственный источник информации о питающем напряжении - это офсайт и даташит http://invensense.com/mems/gyro/mpu6050.html. vdd 2.375V..3.46V, vlogic 1.71V..VDD.
http://playground.arduino.cc/Main/MPU-6050
2) сложный вопрос, есть нюансы. придерживаться кураса поможет. с утра плохо думается, но модуль по идеи нужно распологать вертикально, а не горизонтально. в общем лучше эксперементально посмотреть, я с ним пока что мало работал.
3) для лучше/хуже нужны критерии. в 9xxх серии ещё есть компас. полный каталог тут http://invensense.com/mems/gyro/catalog.html. из советов пока только один - не спешите покупать другие модули вместо этого, максимум можно взять модуль с магнетометром. поработайте с этим чипом, вполне возможно, что сможете добиться желаемого результата.
elmot, в 6050 есть аксель, гиро и датчик температуры + из плюшек "digital motion processor" и дополнительная i2c шина для получения данных с других датчиков
6050.jpg
Аватара пользователя
Angel71
 
Сообщения: 9232
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: Гироскоп GY-521

Сообщение CyberLab » 27 янв 2014, 13:18

Для прямолинейности движения робота, MPU6050 будет достаточно.
Человек даже пример своего кода выложил
Аватара пользователя
CyberLab
 
Сообщения: 280
Зарегистрирован: 02 фев 2013, 12:50
Откуда: Москва

Re: Гироскоп GY-521

Сообщение elmot » 03 фев 2014, 09:39

хм, странно. У меня на stm32f3-discovery наоборот было - аксель стабилен, а гироскоп плавает.
Аватара пользователя
elmot
 
Сообщения: 5674
Зарегистрирован: 10 ноя 2011, 12:02
Откуда: Turku, Finland
Skype: elmot73
прог. языки: Java и все-все=все
ФИО: Илья

Re: Гироскоп GY-521

Сообщение ongleb » 03 апр 2015, 14:10

Привет всем
у меня тут возник вопрос
может кто то сталкивался
есть желание подключить 2 штуки gy-521 к одному контроллеру (due)
что то делаю явно не правильно (пробовал AD0->3.3 и непосредственно и через резистор)

суть ситуации
поотдельности:
- каждый гироскоп нормально отвечает с адреса 0x68
- каждый гироскоп примерно секунд 10-15 нормально отвечает с адреса 0x69. через 10-15 секунд складывается ощущение что гироскоп сваливается с адреса 0x69 на 0x68

т.е. перестает отвечать
нет ли каких то тонкостей для работы через адрес 0x69 ?
ongleb
 
Сообщения: 7
Зарегистрирован: 25 июн 2010, 11:11

Re: Гироскоп GY-521

Сообщение Angel71 » 03 апр 2015, 15:13

Аватара пользователя
Angel71
 
Сообщения: 9232
Зарегистрирован: 18 апр 2009, 22:18
Предупреждения: -1

Re: Гироскоп GY-521

Сообщение ongleb » 08 июн 2015, 17:43

Angel71 писал(а):ongleb, а так http://playground.arduino.cc/Main/MPU-6050#multiple?

прошу прощения за тупрсть
но я уже подтягивал я AD0 через резистор 4.7к
и к GND
и к VCC
и все равно
несколько секунд работает потом перестает
не знаю в чем подвох

на адресе 0x68 сидит как влитой и пропадать не пытается
с адреса 0x69 через несколько секунд работы пропадает
ongleb
 
Сообщения: 7
Зарегистрирован: 25 июн 2010, 11:11


Вернуться в Электроника, электротехника

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 8

Mail.ru counter