roboforum.ru

Технический форум по робототехнике.


Отсутствует сигнал PUL при движении назад

Обсуждение технологии печати на 3D принтерах. Самостоятельное изготовление и приобретение. RepRap и его последователи.

Отсутствует сигнал PUL при движении назад

Сообщение Борман » 07 янв 2017, 11:10

Комплект 3д принтера:
arduino mega 2560
Ramps 1.4
экран lcd 12864
Прошивка 1.1.0-RC6
Драйвера будут использоваться 4-5 амперные не родные.
Экран с прошивкой работает нормально но если зайти в движение по осям то шаговый двигатель в одну сторону крутится исправно но в другую сторону издает писк как у комара.При более детальном рассмотрении обнаружилось
что отсутствует сигнал PUL при движении назад и загорается какой-то красный светодиод на ардуино плате.
Сигнал DIR меняет свою полярность при движении вперед назад.
Не могу понять что неисправно.
Борман
 
Сообщения: 2
Зарегистрирован: 07 янв 2017, 10:45

Re: Отсутствует сигнал PUL при движении назад

Сообщение setar » 07 янв 2017, 11:37

уточните локацию светодиода, на рампсе их всего ничего, и ни один из них не имеет отношения к шаговому двигателю.
значит косяк в конфиге прошивке (например конфиг ног не верно выбран).
все красные светодиоды касаются нагрева или вентилятора (дублируют силовые линии HOT END , FAN , BED).
мотор управляется тремя сигналами EN (Enable - готовность,активация), STEP - (шаг), DIR (направление).
кроме прочего имейте ввиду что для запуска 3 моторов требуется минимум 3 концевика (обычно в минимумах), ибо пока не запаркуешься по оси командой G28 ( G28 X, G28 XY , G28 XYZ) то и движение по ней будет только в сторону увеличения координаты
Аватара пользователя
setar
Site Admin
 
Сообщения: 10488
Зарегистрирован: 04 окт 2004, 12:58
Откуда: St.Petersburg
Skype: taranenko.sergey
ФИО: Сергей Тараненко

Re: Отсутствует сигнал PUL при движении назад

Сообщение Борман » 07 янв 2017, 12:04

При движении назад мигает светодиод RX на плате arduino .
Как точно убедиться что все шаговые двигатели работают исправно?
Получается нужно запарковать ШД , но как это сделать?

Добавлено спустя 15 минут 11 секунд:
Огромное Спасибо!
3 месяца изысканий думал плату уже менять надо ардуино.
Оказалось небыло парковки как вы и говорили.
Борман
 
Сообщения: 2
Зарегистрирован: 07 янв 2017, 10:45

Re: Отсутствует сигнал PUL при движении назад

Сообщение setar » 07 янв 2017, 12:38

незачто, обращайтесь
Аватара пользователя
setar
Site Admin
 
Сообщения: 10488
Зарегистрирован: 04 окт 2004, 12:58
Откуда: St.Petersburg
Skype: taranenko.sergey
ФИО: Сергей Тараненко


Вернуться в 3D печать

Кто сейчас на конференции

Сейчас этот форум просматривают: Yandex [Bot] и гости: 1

Mail.ru counter