roboforum.ru

Технический форум по робототехнике.

Непонятки ramps 1.4

Обсуждение технологии печати на 3D принтерах. Самостоятельное изготовление и приобретение. RepRap и его последователи.

Непонятки ramps 1.4

Сообщение pirat777knj » 17 авг 2015, 01:10

Доброго времени суток, господа.
Помогите новичку.
Собираю свой первый 3д принтер, выбрал в качестве основы ramps 1.4 и дуину мега2560.
Прошил все это дело марлином. Строку с контролем температуры закоментил, концевики настроил... вообщем и пошаманил с бубном уже прилично,
а дождь все не идёт. :cry:
Проблема такая: Наотрез отказывается шевелить движками, в pronterface пишет
------------------------------------------------------------------------------
: Extruder switched off. MINTEMP triggered !
Error:Printer stopped due to errors. Fix the error and use M999 to restart.
------------------------------------------------------------------------------
Но при подаче команды на включение нагрева ничего не происходит! Просто ничего не включается! Ни стол, ни экструдер!
Пытаясь шевелить двиглам экструдера имею дикое дерание туды-сюды и нагрев драйвера. Поначалу шевелил осью Z потом перестал... Почему не ясно.
Да и чего он цепляется к температуре ,контроль же отключен.

Всю прошивку вложил в архив.
Вложения
Marlin.zip
(373.36 КиБ) Скачиваний: 0
pirat777knj
 
Сообщения: 112
Зарегистрирован: 16 авг 2015, 00:22

Re: Непонятки ramps 1.4

Сообщение setar » 17 авг 2015, 02:00

pirat777knj писал(а):Строку с контролем температуры закоментил

горе от ума, там контроль на всех уровнях (чтобы не сгорело ничего не дай бог от перегрева)
* M302 - Allow cold extrudes, or set the minimum extrude S<temperature>.

Добавлено спустя 1 минуту 8 секунд:
в общем без термистра не запустится
Аватара пользователя
setar
Site Admin
 
Сообщения: 10946
Зарегистрирован: 04 окт 2004, 12:58
Откуда: St.Petersburg
Skype: taranenko.sergey
ФИО: Сергей Тараненко

Re: Непонятки ramps 1.4

Сообщение pirat777knj » 17 авг 2015, 12:09

подаю команду, и опять...
Код: Выделить всёРазвернуть
>>> m302
SENDING:M302
>>> g1 z100
SENDING:G1 Z100
Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

Ничего не изменилось, проблема в том, что он даже нагрев не начинает. В pronterface даёшь команду, он её проглатывает и ничего не происходит.
Двигателями не шевелит через неё, а вот если на самом принтере через менюшку пытаться - они дергаются...
pirat777knj
 
Сообщения: 112
Зарегистрирован: 16 авг 2015, 00:22

Re: Непонятки ramps 1.4

Сообщение p.Omelchenko » 17 авг 2015, 16:06

у меня поначалу что-то подобное было. ставил вместо термисторов =0 (вот тут https://github.com/MarlinFirmware/Marli ... #L107-L110) чтобы он на нагрев не работал и после этого начинал шевелить всем кроме экструдера (вроде)

Это мне дало настроить передвижения ровно столько сколько надо. Потом уже шаманил нагревом и тп.

Добавлено спустя 1 минуту 11 секунд:
А вот последующая настройка хотэнда была через боль и страдания, 2 jhead'а спалил пока настроил правильно =)
Prusa i3 (arduino mega2560 + ramps 1.4 + a4988) @ klipper
Voron Switchwire (skr 3 ez + ez2209) @ klipper
Аватара пользователя
p.Omelchenko
 
Сообщения: 241
Зарегистрирован: 29 окт 2014, 15:14
Откуда: Питер - Москва - Подольск
прог. языки: php
ФИО: Павел Омельченко

Re: Непонятки ramps 1.4

Сообщение pirat777knj » 17 авг 2015, 21:34

Ай спасибочки. Пишет mendel ready, моторчиками зашевелил. Тока что-то поддуривает экструдер. Дергается и все. Подключил другие - они норм, а этот дергается. Неужели бракованный?
pirat777knj
 
Сообщения: 112
Зарегистрирован: 16 авг 2015, 00:22

Re: Непонятки ramps 1.4

Сообщение Vovich70 » 17 авг 2015, 22:14

Так ему может тока не хватает?В другую колодку подключить пробовал вместо любого движка и подвигать с компа?
Printer: Prusa
Firmware: Marlin
Host: Pronterface
Slicer: Kisslicer Slic3r1.2.9
Filament: ABS - 1.75
Nozzle: 0.2-0.4 mm
Electronics: Arduino MEGA 2560 + RAMPS 1.4
Vovich70
 
Сообщения: 462
Зарегистрирован: 30 окт 2013, 03:50
Откуда: Москва
ФИО: Владимир

Re: Непонятки ramps 1.4

Сообщение pirat777knj » 18 авг 2015, 00:24

Все проще оказалось. Китайцы перепутали провода местами.)))
А вот нагрев по прежнему поддуривает. Почему пишет mintemp и отказывается включать... Ведь я же его включаю!
pirat777knj
 
Сообщения: 112
Зарегистрирован: 16 авг 2015, 00:22

Re: Непонятки ramps 1.4

Сообщение barakuda62 » 18 авг 2015, 00:32

pirat777knj писал(а):Все проще оказалось. Китайцы перепутали провода местами.)))
А вот нагрев по прежнему поддуривает. Почему пишет mintemp и отказывается включать... Ведь я же его включаю!

Ясно же ответили что без термисторов небуит работать !!!, поставь вместо термисторов подстроечные сопротивления, и имитируй ими.
Printer: H-Boot cube aluminium (промежуточный вариант), Firmware: Marlin
Delta all aluminium, Firmware: Marlin
Electronics: Arduino MEGA 2560 + RAMPS 1.4
barakuda62
 
Сообщения: 292
Зарегистрирован: 28 дек 2014, 02:33
Откуда: Рязань
прог. языки: С#, JAVA

Re: Непонятки ramps 1.4

Сообщение pirat777knj » 20 авг 2015, 13:02

Получил сегодня термисторы, подключил.
Пишет
Err:MINTEMP
Наотрез отказывается включать нагрев экструдера и стола.
Прописал минимальную температуру стола и экструдера 5 градусов и заработало.
Вопрос: Это нормально? Ведь стояли другие значения.
pirat777knj
 
Сообщения: 112
Зарегистрирован: 16 авг 2015, 00:22

Re: Непонятки ramps 1.4

Сообщение setar » 20 авг 2015, 13:07

нет не нормально, в конфиге термистры не соответствуют реально имеющемуся типу = врет безбожно
Аватара пользователя
setar
Site Admin
 
Сообщения: 10946
Зарегистрирован: 04 окт 2004, 12:58
Откуда: St.Petersburg
Skype: taranenko.sergey
ФИО: Сергей Тараненко


Вернуться в 3D печать

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 7