roboforum.ru

Технический форум по робототехнике.


Rover Wireless Spy Tank by Brookstone

Модераторы: 1970DenisT, Dmitry__

Re: Rover Wireless Spy Tank by Brookstone

Сообщение artoym05 » 26 янв 2013, 20:04

Dmitry__ писал(а):Вудернул камеру из разьема, найди 2 отличия в логе :)
Проверяй питание...


Попозже проверю. С виду все вроде целое.
Тоже отсоединил камеру и проверил

Код: Выделить всёРазвернуть
Sash command shell (version 1.1.1)
/> new USB device :80fb4004-fed6c0
hub.c: new USB device 2, assigned address 2
params length is 3572
sw version is 1.5.0.0
aw version is 1.1.0.0
open video device error
myreboot


Почему у меня нет этих строк как у тебя?
Код: Выделить всёРазвернуть
aw not exist !
aw version is 0.0.0.0
artoym05
 
Сообщения: 11
Зарегистрирован: 20 окт 2012, 18:03

Re: Rover Wireless Spy Tank by Brookstone

Сообщение Dmitry__ » 26 янв 2013, 21:51

artoym05 писал(а):Почему у меня нет этих строк как у тебя?

Вот на это не отвечу, на столько я не разбираюсь в этом. Я показал лог без камеры, все как у тебя, разница в одной строке. Не думаю что это принципиально. Может у тебя чуть другая прошивка.
У нас есть разница в логе:
Код: Выделить всёРазвернуть
Linux version 2.4.20-uc0 (root@maverick-linux) (gcc version 3.0) #1481 Èý 6ÔÂ 15
11:04:25 CST 2011

Если очень хочется, то заливай прошивку, может и поможет.
команды загрузчика:
forum104/topic11710-60.html#p254098
шпаргалки по заливке прошивки:
Код: Выделить всёРазвернуть
Image: 0 name:BOOT INFO base:0x7F010000 size:0x00000048 exec:0x7F010000 -af
Image: 7 name:linux base:0x7F020000 size:0x000AE264 exec:0x00008000 -acxz
Image: 6 name:romfs base:0x7F0E0000 size:0x00092C00 exec:0x7F0E0000 -a

del 7

fx 7 linux 0x7F020000 0x8000 -acxz
fx 6 romfs 0x7F0E0000 0x7F0E0000 -a

del 7 - удалить раздел линух
fx 7 - заливка новой прошивки х модемом (в виндовой терминалке выбрать: отправить файл, а там x модем

Все сумбурно, меня дергают во все стороны :pardon:
Аватара пользователя
Dmitry__
 
Сообщения: 7978
Зарегистрирован: 13 янв 2011, 15:25
Откуда: Санкт-Петербург

Re: Rover Wireless Spy Tank by Brookstone

Сообщение artoym05 » 27 янв 2013, 15:36

Прошил. Ни чего не изменилось. :(
Буду проверять камеру.
А wi-fi может не работать из-за камеры?
artoym05
 
Сообщения: 11
Зарегистрирован: 20 окт 2012, 18:03

Re: Rover Wireless Spy Tank by Brookstone

Сообщение Dmitry__ » 28 янв 2013, 01:20

Вот и я про то. Зато сколько всего узнал. :)
Тебе осталось только uclinux собирать из исчодников и можно открывать чепок :)
Камеру можно проверить на компьютере (теоретически), она же юсб, шнурок только спаять.
А еще можно попробовать на ровера повесить юсб камеру другую, только не из свежих...
Это если твоей камере точно кирдык.
artoym05 писал(а):А wi-fi может не работать из-за камеры?

Скрипт затыкается на камере, а wifi позже по логам инициализируется.
Аватара пользователя
Dmitry__
 
Сообщения: 7978
Зарегистрирован: 13 янв 2011, 15:25
Откуда: Санкт-Петербург

Re: Rover Wireless Spy Tank by Brookstone

Сообщение artoym05 » 28 янв 2013, 15:04

Dmitry__ писал(а):Вот и я про то. Зато сколько всего узнал.

Да и не говори. :)

Подключил камеру к компу. (не знаю правильно или нет)
Пояльника у меня нет, поэтому зделал просто скрутку. На обратной стороне платы контакты подписаны. Воткнул в комп, дыма нет, комп работает :D
Винда сказала - "усб устройство неопознано". (как-то так).
Менял местами D+ и D-, тоже самое.
Не знаю, говорит ли это о нерабочей камере?
Осталось найти веб камеру, чтобы подключить ее к роверу.
artoym05
 
Сообщения: 11
Зарегистрирован: 20 окт 2012, 18:03

Re: Rover Wireless Spy Tank by Brookstone

Сообщение artoym05 » 29 янв 2013, 18:24

Dmitry__ писал(а): А еще можно попробовать на ровера повесить юсб камеру другую, только не из свежих...


Я, честно сказать, незнаю как отличить свежие от не свежих :)

Как думаешь вот такая пойдет?

yuzhno-sakhalinsk.dns-shop.ru/catalog/i129089/veb-kamera-dns-dns-1306jb-13mpx-usb-20.html
artoym05
 
Сообщения: 11
Зарегистрирован: 20 окт 2012, 18:03

Re: Rover Wireless Spy Tank by Brookstone

Сообщение Dmitry__ » 29 янв 2013, 20:38

Подключил роверовскую камеру к компу. В вин7 драйверы нашлись сами, камера работает.
Драйверы поставились майкрософтовские, узнать название камеры по ним не смог.
В линух видится как "PixArt imaging inc. USB2_0Camera[100]"
Распиновку юсб на плате ровера "DN0" читать как "D-", а "DP0" как "D+"
Паять по картинке:
Изображение
artoym05 писал(а):Как думаешь вот такая пойдет?

Не знаю. :pardon:
Могу только рекомендовать искать камеры с аппаратным jpg кодированием и год выпуска <2006

Добавлено спустя 17 минут 30 секунд:
в winXP работает, свойства: "USB\VID_1D0F&PID_1801&MI_00\6&7590DD6&0&0000"
Составное устройство видео/аудио.
Попробуй подбирать камеры по vid, pid. в гугле "VID_1D0F&PID_1801"

Добавлено спустя 1 час 7 минут 53 секунды:
Попробовал 2 камеры подкл. к роверу. Не работают, но аудио подхватывает.
1-я A4tech: ID 0ac8:c40a Z-Star Microelectronics Corp.
2-я: L-pro ID 0ac8:3420 Z-Star Microelectronics Corp. Venus USB2.0 Camera

Родная камера: ID 1d0f:1801, все ссылки ведут на фоскамовскую камеру, или ломать фоскамовскую камеру для восстановления ровера или эпик фэйл :pardon:
Аватара пользователя
Dmitry__
 
Сообщения: 7978
Зарегистрирован: 13 янв 2011, 15:25
Откуда: Санкт-Петербург

Re: Rover Wireless Spy Tank by Brookstone

Сообщение artoym05 » 30 янв 2013, 07:13

Dmitry__ писал(а):Подключил роверовскую камеру к компу. В вин7 драйверы нашлись сами, камера работает.
Попробовал 2 камеры подкл. к роверу. Не работают, но аудио подхватывает.
1-я A4tech: ID 0ac8:c40a Z-Star Microelectronics Corp.
2-я: L-pro ID 0ac8:3420 Z-Star Microelectronics Corp. Venus USB2.0 Camera

Родная камера: ID 1d0f:1801, все ссылки ведут на фоскамовскую камеру, или ломать фоскамовскую камеру для восстановления ровера или эпик фэйл :pardon:


Попробую еще раз подключить камеру к компу. :o

Большое спасибо тебе за помощь! Столько времени на меня потратил! :good:
Можешь еще последнее посмотреть :) Если включишь ровера с откинутой камерой, wi-fi будет работать (будет гореть синий светодиод)?
artoym05
 
Сообщения: 11
Зарегистрирован: 20 окт 2012, 18:03

Re: Rover Wireless Spy Tank by Brookstone

Сообщение Dmitry__ » 30 янв 2013, 13:39

artoym05 писал(а):Если включишь ровера с откинутой камерой, wi-fi будет работать (будет гореть синий светодиод)?

Неа, wifi не работает, светодиод не зажигается. В логе после:
Код: Выделить всёРазвернуть
open video device error
myreboot

Происходит перезагрузка линух и в таком состоянии зацикливается. А у тебя не так?

Добавлено спустя 54 минуты 51 секунду:
Так, а чего это я туплю?
Камера на чипе PAP7501V (в первом посте упоминается)
Вот по чипу и подбираем рабочую камеру
нашел такие:
IP камера Tenvis JPT3815 (ой, она сама как ровер :) )
Genius i-Look 1321

В общем вот :)
http://www.google.ru/search?hl=ru&newwi ... 4gSw4oG4Ag
Аватара пользователя
Dmitry__
 
Сообщения: 7978
Зарегистрирован: 13 янв 2011, 15:25
Откуда: Санкт-Петербург

Re: Rover Wireless Spy Tank by Brookstone

Сообщение artoym05 » 31 янв 2013, 05:49

[quote="Dmitry__"][/quote]

Ура, работает! :Yahoo!:

Вообщем все оказалось намного проще. Я подключил камеру еще раз к компу с win7, и она оказалась рабочей. На XP почему-то не работает. Потом перекинул D- и D+ обратно на ровера, а питание оставил от usb. Включил ровера. Ничего не изменилось (синий не горел). Решил посмотреть лог. А лог загрузился полностью и синий огонек радостно замигал. Проблема оказалась в питании, как ты и говорил. :)
Попеременно перекидыая то "5+", то "землю" выяснил, что "5+" не приходит на камеру.
Буду искать где обрыв. Или запитаюсь от другого места на плате.

Да, почему-то ровер полностью включался только после ребута в терминалке?

Лог
Код: Выделить всёРазвернуть
Cache enabled!
Processing image 1 ...
Processing image 2 ...
Processing image 3 ...
Processing image 4 ...
Processing image 5 ...
Processing image 6 ...
Processing image 7 ...
Unzip image 7 ...
Executing image 7 ...
Linux version 2.4.20-uc0 (root@maverick-linux) (gcc version 3.0) #1481 Ey 6OA 15
11:04:25 CST 2011
Processor: Winbond W90N745 revision 1
Architecture: W90N745
On node 0 totalpages: 4096
zone(0): 0 pages.
zone(1): 4096 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/rom0 rw
Calibrating delay loop... 39.83 BogoMIPS
Memory: 16MB = 16MB total
Memory: 14616KB available (1278K code, 206K data, 40K init)
Dentry cache hash table entries: 2048 (order: 2, 16384 bytes)
Inode cache hash table entries: 1024 (order: 1, 8192 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
PTZ Driver has been installed successfully.
Winbond W90N745 Serial driver version 1.0 (2005-08-15) with no serial options en
abled
ttyS00 at 0xfff80000 (irq = 9) is a W90N745
Winbond W90N7451 Serial driver version 1.0 (2005-08-15) with no serial options e
nabled
ttyS00 at 0xfff80100 (irq = 10) is a W90N7451
I2C Bus Driver has been installed successfully.
Blkmem copyright 1998,1999 D. Jeff Dionne
Blkmem copyright 1998 Kenneth Albanowski
Blkmem 1 disk images:
0: 7F0E0000-7F172BFF [VIRTUAL 7F0E0000-7F172BFF] (RO)
S29GL032N Flash Detected
01 eth0 initial ok!
which:0
PPP generic driver version 2.4.2
Linux video capture interface: v1.00
Winbond Audio Driver v1.0 Initialization successfully.
usb.c: registered new driver hub
add a static ohci host controller device
: USB OHCI at membase 0xfff05000, IRQ 15
hc_alloc_ohci
usb-ohci.c: AMD756 erratum 4 workaround
hc_reset
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb.c: registered new driver audio
audio.c: v1.0.0:USB Audio Class driver
usb.c: registered new driver serial
usbserial.c: USB Serial Driver core v1.4
rtusb init --->
usb.c: registered new driver rt2870
dvm usb cam driver 0.0.0.1 by Maverick Gao in 2010-8-3
usb.c: registered new driver dvm
dvm usb cam driver 0.1 for sonix288 by Maverick Gao in 2009-4-20
usb.c: registered new driver dvm usb cam driver for sonix288
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 1024 bind 2048)
VFS: Mounted root (romfs filesystem) readonly.
Freeing init memory: 40K
BINFMT_FLAT: bad magic/rev (0x74202d74, need 0x4)
BINFMT_FLAT: bad magic/rev (0x74202d74, need 0x4)
Shell invoked to run file: /bin/init
Command: mount -t proc none /proc
Command: mount -t ramfs none /usr
Command: mount -t ramfs none /swap
Command: mount -t ramfs none /var/run
Command: mount -t ramfs none /etc
Command: mount -t ramfs none /flash
Command: mount -t ramfs none /home
Command: mount -t ramfs none /tmp
Command: mkdir /tmp/run
Command: camera&
[8]
Command: sh

Sash command shell (version 1.1.1)
/> hub.c: connect-debounce failed, port 1 disabled
new USB device :80fb4004-fed6c0
hub.c: new USB device 1, assigned address 2
probing sonix288 usb camera ...
dvm camera registered as video0
p1[7]:1,j 3,config->bNumInterfaces:4
usbaudio: device 2 audiocontrol interface 2 has 1 input and 0 output AudioStream
ing interfaces
usbaudio: valid input sample rate 16000
usbaudio: device 2 interface 3 altsetting 1: format 0x00000010 sratelo 16000 sra
tehi 16000 attributes 0x01
usbaudio: valid input sample rate 48000
usbaudio: device 2 interface 3 altsetting 2: format 0x00000010 sratelo 48000 sra
tehi 48000 attributes 0x01
usbaudio: registered dsp 14,35
usbaudio: warning: found 1 of 0 logical channels.
usbaudio: assuming the channel found is the master channel (got a Philips camera
?). Should be fine.
usbaudio: registered mixer 14,32
usb_audio_parsecontrol: usb_audio_state at 00ff3ae0
new USB device :80fb4404-fed6c0
hub.c: new USB device 2, assigned address 3
params length is 3572
sw version is 1.5.0.0
sw version is 1.5.0.0
video0 opened
4 0
wifi car mode is 1
SIOCSIFFLAGS: Unknown error 1
0x1300 = 00073200
inet_sr.c INET_rinput 321
action===1
options==33
inet_sr.c INET_setroute 75
*args===255.255.255.255
*args===netmask
*args===eth1
[29]
inet_sr.c INET_rinput 321
action===1
options==33
inet_sr.c INET_setroute 75
*args===default
*args===gw
*args===eth1
__pthread_initial_thread_bos:294000
manage pid:32
Prepare Audio Buffer


Еще не опробовал его в работе. Apple девайсов пока рядом не. На Андроиде не получилось завести. А прога Ez-Robot не работает, почему-то. Пишит:
Код: Выделить всёРазвернуть
Error: This computer culture has the Number Decimal Seperator set to a ','. This setting needs to be a Period '.' for all EZ-Robot software to work.

Пробовал на win7 и Xp.
artoym05
 
Сообщения: 11
Зарегистрирован: 20 окт 2012, 18:03

Re: Rover Wireless Spy Tank by Brookstone

Сообщение Dmitry__ » 31 янв 2013, 06:48

ЫЫЫЫЫЫЫЫ, круто, молодец :Yahoo!:
artoym05 писал(а):А прога Ez-Robot не работает

Может они софт допилили, чтоб не работал без их примочек?
В общем давно я это делал. Не в курсе что сейчас. Но если что, можно посмотреть.
Но, все протоколы ровера известны, можешь с любого броузера ломиться на адрес: "ip робота\Factory_motor.htm" и управлять им, камера тож работает через броузер. В первом посте все есть. Распокуй WebUI.bin_extracted.zip и посмотри все html страницы ровера.
Аватара пользователя
Dmitry__
 
Сообщения: 7978
Зарегистрирован: 13 янв 2011, 15:25
Откуда: Санкт-Петербург

Re: Rover Wireless Spy Tank by Brookstone

Сообщение Myp » 31 янв 2013, 09:28

artoym05 писал(а):А прога Ez-Robot не работает, почему-то. Пишит:
Код: Выделить всёРазвернуть
Error: This computer culture has the Number Decimal Seperator set to a ','. This setting needs to be a Period '.' for all EZ-Robot software to work.

у нас, у нормальных человеков, разделитель дробной части запятая, а у буржуев точка, поэтому прога и не работает.
надо в настройках даты и времени выбрать что разделитель точка
<telepathmode>На вопросы отвечает Бригадир Телепатов!</telepathmode>
Всё уже придумано до нас!
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 17818
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Re: Rover Wireless Spy Tank by Brookstone

Сообщение nivax » 13 мар 2013, 14:54

Подниму тему. Подумываю купить такого зверя в качестве робоконструктора) Вопрос Дмитрию: правда что говорят, что видео только 320x240? в спеке по чипу вроде пишут 640x480. Если да - может быть, разрешение установлено программно, не пробовал его менять? повлечет ли это тормоза?
nivax
 
Сообщения: 1
Зарегистрирован: 13 мар 2013, 14:47

Re: Rover Wireless Spy Tank by Brookstone

Сообщение Dmitry__ » 20 мар 2013, 03:19

Ой, пропустил вопрос :oops:
С разрешением трудно сказать, поставил сейчас прогу Ez-Robot, дает выбирать 3 разрешения. 120, 320 и 640. НА 120 заметны квадраты. При 320 и 640 - разницы не вижу. По тормознутности могу сказать, что и на 320*240 мало кадров. На глаз около 5 кадров в сек.

Добавлено спустя 3 минуты 51 секунду:
Ez-Robot заработал только с доработками Мура :)
Myp писал(а):у нас, у нормальных человеков, разделитель дробной части запятая, а у буржуев точка, поэтому прога и не работает.
надо в настройках даты и времени выбрать что разделитель точка
Аватара пользователя
Dmitry__
 
Сообщения: 7978
Зарегистрирован: 13 янв 2011, 15:25
Откуда: Санкт-Петербург

Re: Rover Wireless Spy Tank by Brookstone

Сообщение cameel » 05 июл 2013, 09:49

Проблема такого рода, купил себе танк доволен. Но работать он соглашается только с компьютером, а вот планшет (андройд 4.2.1) сеть видит но не подключается, телефон (android 4.1.3) же вообще вафлю не видит. А хотелось бы рулить с планшета стандартной утилиткой под Андройд. Как исправить эту несправедливость!!!
cameel
 
Сообщения: 3
Зарегистрирован: 05 июл 2013, 09:44

Пред.След.

Вернуться в КиберЗона - клуб боевых роботов

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

cron
Mail.ru counter