roboforum.ru

Технический форум по робототехнике.


iBoto Aqua V715 робот пылесос

iBoto Aqua V715 робот пылесос

Сообщение Макs » 12 фев 2019, 20:27

Достался с разобранной батареей (и этой заявленной неисправностью). После перебора сборки. Включается загорается синим (норма, готов к работе) При постановке на зарядку два раза мигает синим(типа начинает зарядку) серия из четырёх коротких писков. После горит красным.
В таком состоянии, нажимаю на пульт -уборка, он отьезжает от базы, разворачивается на 180 и начинает сигналить как описано выше. При этом не запускает турбину и не работают боковые щетки. Сопротивление движков боковых щеток 24 и 22 Ома. С пульта принудительно катается вперёд, разворачивается в обе стороны (движки колёс в норме) но не едет назад едет сантиметра 2 и встаёт. При этом пишит, как описано выше.
Вопросов несколько:
1) Алгоритм инициализации при команде на уборку (разворот-проверка радаров-запуск турбины-запуск щеток- запуск передвижения )???
2) Какие токи потребления должны быть на движках щеток.
Буду рад советам от опытных комрадов, в наличии тестер, осциллограф, умение читать схемы, кое-какой опыт в ремонте компьютерной техники (тут вся проблема в новизне и незнании алгоритма инициализации, какие режимы тестируются, типовой схемы и прочее..
Последний раз редактировалось Макs 16 фев 2019, 10:44, всего редактировалось 3 раз(а).
Макs
 
Сообщения: 7
Зарегистрирован: 12 фев 2019, 20:01

Re: iBoto Aqua V715 робот пылесос

Сообщение Макs » 13 фев 2019, 09:12

Посмотрел клипы, увидел, что оптику косвенно можно проверить с помощью телефона, посмотрел, все излучающие светодиоды светятся.
На механической оптике бампера появляются значения 5В на выходе в момент "столкновения".
Полазил тестером, силовые ключи целые.
ПРобовал управляя пультом, уронить его со стола, доезжает до края и дальше не едет (датчики, хотя-бы часть, рабочие).
Если сразу после включения нажать кнопки направления на пульте, турбина и боковые щетки кратковременно запускаются, напряжение питания проседает с 15,8 до 15,1В. (рабочие ключи, рабочая часть управления шим турбиной)
И через секунду начинает мигать красным и четыре серии по четыре пика. по описанию: "Другая неисправность Слишком низкий заряд батареи устройства, необходимо зарядить вручную."
При этом, если после включения кнопкой, нажать кнопку автоматизированной уборки, то он начинает сигнализировать о неисправности сразу, не запуская ни одного двигателя/турбины.
ВОзможно проблема именнно в части питания и заряда, может на вольт-сенс какая-нить фигня приходит, неправильно определяет ток/напряжение.
Учитывая, что он достался мне, со сгоревшей базой (кренка на 3,3 в КЗ и балластный резистор перед ней в обрыве) и дохлым аккумулятором ( возможно был овервольтаж по питанию), хотя хозяин уверяет, что до отключения и разборки аккумулятора он работал..

Вопросы несколько поменялись:
1) Нужна типовая схема питания (заряда от базы, заряда от разьёма, питания от аккума), там что-то понаворочено сложно без опыта въехать.?
2) Какое сопротивление и ток потребления х/х, у исправных моторов щеток и колёс ?
Последний раз редактировалось Макs 16 фев 2019, 10:37, всего редактировалось 1 раз.
Макs
 
Сообщения: 7
Зарегистрирован: 12 фев 2019, 20:01

Re: iBoto Aqua V715 робот пылесос

Сообщение Макs » 16 фев 2019, 10:20

В общем достал лабораторный б/п, осциллограф.
Похоже дело в схеме заряда (сенсора напряжения) батареи, собрана на LM358, трех микро транзисторах, и одном выходном полевике с индуктивностью. При подаче питания на вход заряда, кратковременно на индуктивности (выходная часть схемы заряда) появляется зарядное напряжение, после падает, и пылесос переходит в режим неисправности.
В первые моменты, когда происходит запуск всех двигателей, ток потребления от батареи, в пике, достигает 1,4А. Вроде норма?
Вопрос как реализована типовая схема вольт-сенсинга на банках аккумулятора? Контроль заряда по току или по напряжению?
https://my-files.ru/9uc0m2

Итого, проверил всё:
Двигатели колёс вращаются в двух направлениях (с пульта, делает разворот в обе стороны), двигатели щеток работают, турбина работает, сенсоры механического столкновения работают, оптические сенсоры поверхности(обрыва)-работают(перестаёт двигаться на краю стола), Оптика бампера работает (3 канала), меняется амплитуда импульсов в зависимости от расстояния, схема заряда кратковременно включается, и выдает нормальное напряжение заряда (>Uбат) но почти не выдает ток??(ток потребления на аккумуляторе падает с 30мА до -5мА(ОЧЕНЬ МАЛЕНЬКИЙ ТОК ЗАРЯДА), после уходит в ошибку..
Макs
 
Сообщения: 7
Зарегистрирован: 12 фев 2019, 20:01

Re: iBoto Aqua V715 робот пылесос

Сообщение Макs » 16 фев 2019, 15:40

Покурил форумы, некоторые роботы пишут состояние батареи в пзу, и после замены на новую, нужно сделать какие-то манипуляции?? типа зарядить на базе после ресета, замкнуть разьем питания на роботе, и прочие ухищрения, может и в моём случае так?
Макs
 
Сообщения: 7
Зарегистрирован: 12 фев 2019, 20:01

Re: iBoto Aqua V715 робот пылесос

Сообщение Medtech » 16 фев 2019, 19:55

никто пока не пишет питание в ПЗУ, простые китайские роботы ориентируется на напряжение, стоит подать питание с бп в параллель аккумулятору на проводах, а дальше видно будет, сопротивление движков никто не измеряет, меряют ток ХХ одного двигателя и с навешенным механизмом относительно какого либо напряжения которое и указывают.
Аватара пользователя
Medtech
 
Сообщения: 518
Зарегистрирован: 20 апр 2015, 22:02
Откуда: Москва
Skype: sergelola
ФИО: Сергей

Re: iBoto Aqua V715 робот пылесос

Сообщение linvinus » 17 фев 2019, 01:18

К сожалению проблема китайцев в том что их как тараканов, и все они разные,
есть ли ком порт и можно ли что то через него делать я не знаю.
R3 forum87/topic15337.html
R2 roboforum.ru/forum102/topic13980.html
R4 roboforum.ru/post336339.html#p336339
Делать надо хорошо - плохо получится само!
Аватара пользователя
linvinus
 
Сообщения: 1672
Зарегистрирован: 29 апр 2011, 12:37
Откуда: Москва
прог. языки: С

Re: iBoto Aqua V715 робот пылесос

Сообщение Макs » 17 фев 2019, 08:12

Спасибо за обратную связь.
Блок питания подключал параллельно, и вместо Акк, ставил до 18В не помогает (ток до 1,5А в пике, просто движение 250-350мА)..
Токи моторов 15,4 В:
1)щетки 1 40мА хх, 220мА пик(пуск) 2 40-хх 222-пик(пуск)
2)колёса 1 75-80 хх 220-пик, 2 100-120 хх 240-пик 8) может колесо? Добавлено: Мотор перебрал (продувка, полировка якоря ротора, смазка) "2" 80-90 хх 215-пик (удивительно неплохо сделан, ожидал, что будет как в модельках моего детства, а тут угольные щетки...)
3)турбина бесщеточная, крутится свободно, ток проверить проблематично (но запускается на несколько секунд, тоесть рабочая)
Колесо возможно и умирает, но пылесос переходит в режим "авария" сразу после нажатия кнопки пуск (двигатели при этом, даже не пытаются стронуться с места)

Сразу после включения тумблером, когда стоит в режиме авария на базе (зарядки при этом нет), если нажать авто на пульте, он отъезжает с базы разворачивается (готовится к уборке) и когда должен запускать турбину и щётки, переходит в режим авария.
Ещё у меня есть мысль по поводу бампера, робот почему-то не видит препятствия при работе с пульта вплоть до физического контакта со стеной.
В роликах я видел, люди снимают, ик светодиоды на бампере светят как прожектора. Когда я снимаю, у меня они еле видны (может так сильно от камеры зависит).
Померял постоянку на светодиоде 0,7В при дежурке и 1,4В в момент включения, кажется мало?
Но когда я тестировал бампер осциллографом, то на трех выходах (условно лево-перед-право) меняется амплитуда сигнала, я подносил руку, изменяться она начинает примерно с 3-х..4-х сантиметров..
Это нормально?
Ещё вопрос по базовой станции, я её восстановил, но не уверен какой группой датчиков робот видит базуху? По логике, если в базухе стоит микросхема пульта, то должен трёхвыводными(приёмниками пульта) или бампер тоже задействован?
добавлено:
Залез в бампер, светодиоды подключены последовательно (оказывается крайние группы были заклеены) 11 излучающих и 11 приемных, излучающие подключены последовательно (дожно быть порядка 20..22В)
Схема раскачки бампера собрана на рассыпухе, два плеча, на выходе (генератора?) два NPN SS8050, коллекторы через 6R8, посажены на землю ?(так звонится) на базах прямоугольники f=200Hz U=0,8V эмиттеры идут на цепочку светодиодов?
На эмиттерах 0,5V относительно земли.. Чето не въеду как оно работает..
добавлено:
Так нашелся (+) 14V относительно GND, тоесть это не цепочка светодиодов, а две "ветки" от плюса, питание коммутируется двумя ключами с f=200Hz
напряжение Peak/Peak между (+) и эмиттерами 4,8 и 5,8 V (я так понимаю для 5-ти и 6 светодиодов соответственно) f=200 в дежурном режиме Это норма?
Всё осложняет ужасный ЧЕРНЫЙ цвет текстолита. :bad:
А сенсоры напряжения батареи, заряда.. как построены в виденных вами моделях? Делитель на резисторах с отводом на ADC ногу процессора, или активный какой на ОУ?
Ещё такой вопрос, в виденных вами схемах, измеряется только ток потребления моторами, или ток заряда аккумулятора тоже? Я вижу две группы шунтов на плате, их цепи сложно прозвонить, без распайки сопротивление низкое.
Ситуация такая, ставишь например на базу, он пару секунд заряжается (ток батареи обратный) и тут-же уходит в ошибку..
Ещё вариант найти входы ADC, да и DAC, на процессоре и прозвонить их при отключенной батареи, на КЗ на GND и на +3,3Vcc. Если звонить обычным тестером не пожгу входы?
Макs
 
Сообщения: 7
Зарегистрирован: 12 фев 2019, 20:01

Re: iBoto Aqua V715 робот пылесос

Сообщение Макs » 19 фев 2019, 11:39

Вобщем, посидев с лупой и тестером три вечера, нашёл гнилой переход под защитным диодом батареи, этот переход, вёл к вольтсенсу. Пылесос работает нормально, стал заряжаться, стал работать в автоматическом режиме.
Для меня удивительно, сама плата с первого взляда была чистой, без признаков окислов, а вот под диодом "зацвело". Ужасный черный цвет лака крайне осложняет визуальную трассировку дорожек их видно только при освещении ярким фонариком под определённым углом.
Вольтсенс собран на том-же сдвоенном операционнике LM358, что и токовый сенсор.
Спасибо, что читали.
Макs
 
Сообщения: 7
Зарегистрирован: 12 фев 2019, 20:01

Re: iBoto Aqua V715 робот пылесос

Сообщение Medtech » 20 фев 2019, 11:36

Бывает, остаётся надеяться что это единственный гнилой переход.
Аватара пользователя
Medtech
 
Сообщения: 518
Зарегистрирован: 20 апр 2015, 22:02
Откуда: Москва
Skype: sergelola
ФИО: Сергей


Вернуться в Роботы-пылесосы

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Mail.ru counter