roboforum.ru

Технический форум по робототехнике.


Gutrend Joy 90 Pet

Gutrend Joy 90 Pet

Сообщение SDL2000 » 10 ноя 2017, 21:53

Приветствую всех!

Попался мне вот такой пылесос. Принес знакомый, отказали ему в гарантии, отдал на запчасти.
Ну и решил я его поковырять. (Ремонтами пылесосов не занимаюсь - просто интересно стало)

Первопричина неисправности - попала влага на плату.
Плату отмыл. Особой коррозии не было.

Подозрительные места пропаял.

Поведение пылесоса:

При нажатии на кнопку включения - загорается желтым. При повторном нажатии - просто два писка.
По мануалу - "неисправно сенсоры в бампере или клеммы зарядки"
С пульта - все то же самое происходит

Если поставить на базу, начинает мигать зарядка, при нажатии на кнопку включения
загорается зеленым, отъезжает с базы, поворачивает, буквально 5 см вперед едет, и останавливается.
Кнопка загорается желтым. Разворачивается и вроде как пытается ехать на базу. И отключается.
Если не трогать, то сек через 30 снова включается и делает попытки куда-то ехать.
Так раза три-четыре - и успокаивается.

Что делалось/проверялось:
Питание.
Аккум заряжен вполне. Показывает 12.5
При начале движения просадка до 12.4-12.3
Подкидывал просто другой аккум от компьютерного UPS
Подключал питание от лабораторного блока (ток потребления при начале движения в районе 0.3-0.4 А)
Все точно так же.

Двигатели на колеса - чистые. Вращаются легко.
На моторах датчики Холла. Энкодеров нету
Похожи на вот эти
download/file.php?id=45572&mode=view

Снимал драйвера двигателей, включал по очереди без правого/левого - поведение не изменилось (ну естественно по дуге едет только).

Моторчики щеток боковых
На одном был обнаружен пробитый диод. Заменен.
Ничего не поменялось. Как крутились оба, так и крутятся.

Датчики скалы
Все три горят.
Заклеивал задние черной изолентой - он начинает активно задом "убегать". Чуть дольше чем в штатном режиме двигается. Но тоже "глохнет"
Если пылесос просто поднять - загорается индикатор красным и пищит.
Т.е. получается видит, что в воздухе он.

Датчики в бампере - через смарт все светятся.
Микрики - отрабатывают нормально

Чего ему надо - не понятно.
И в какую сторону копать - тоже особо не соображу.

Может кто что подскажет?
Что ему не хватает? Чего он сразу останавливается?

P.S. Тут подумалось, может первый датчик пола (который посередине) неисправен?
Вот он вперед и не едет. Просто отключается.

Надо попробовать ему световодик там сделать.
Потому что просто прозванивал - диоды исправны

P.P.S
Попробовал направить диоды друг на друга.
Если просто около поверхности - выходное напряжение фотоприемника около 3В (3.1-3.3) - что мне кажется высоковато.

Направил друг на друга, напряжение стало 2.2 В
Поведение пылесоса осталось прежним.
2.2 для логического нуля вроде как многовато.
Хотя хрен знает, что тут за логический ноль принимают.
Менее 2В или менее 2.5В

P.P.P.S Пылесос отремонтирован. Всем спасибо за помощь :-) Был пробитый резик в цепи зарядка/питание от аккума
SDL2000
 
Сообщения: 2
Зарегистрирован: 08 июл 2016, 11:42

Re: Gutrend Joy 90 Pet

Сообщение Батыр » 09 апр 2018, 22:22

Добрый день! У меня у пылесоса такая же проблема. Что именно вы поменяли. Резик - это резистор?
Батыр
 
Сообщения: 1
Зарегистрирован: 09 апр 2018, 21:22


Вернуться в Роботы-пылесосы

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter