roboforum.ru

Технический форум по робототехнике.


Воскрешение мертвой ардуины

Как собрать и запрограммировать робота на Arduino(Freeduino, Roboduino, Seeduino ...). Используем Wiring и Processing.

Воскрешение мертвой ардуины

Сообщение ft-ninja » 02 апр 2012, 22:13

Замечательная история о восстановлении загрузчика в ATmega16U2 на борту Arduino UNO Rev3.

PS Она такая полудохлая с завода пришла.
Поздравляю, ft-ninja!
Изображение
Аватара пользователя
ft-ninja
 
Сообщения: 82
Зарегистрирован: 21 дек 2009, 15:21
Откуда: Inner Mongolia

Re: Воскрешение мертвой ардуины

Сообщение Myp » 03 апр 2012, 08:53

в чём замечательность?
взяли да перепрошили мегу, стандартный способ реанимации.
<telepathmode>На вопросы отвечает Бригадир Телепатов!</telepathmode>
Всё уже придумано до нас!
Аватара пользователя
Myp
скрытый хозяин вселенной :)
 
Сообщения: 17427
Зарегистрирован: 18 сен 2006, 12:26
Откуда: Тверь по прозвищу Дверь
прог. языки: псевдокод =) сила в алгоритме!
ФИО: глубокоуважаемый Фёдор Анатольевич

Re: Воскрешение мертвой ардуины

Сообщение ft-ninja » 03 апр 2012, 13:02

Мне, например, было интересно проследить за процессом поиска решения.
Поздравляю, ft-ninja!
Изображение
Аватара пользователя
ft-ninja
 
Сообщения: 82
Зарегистрирован: 21 дек 2009, 15:21
Откуда: Inner Mongolia

Re: Воскрешение мертвой ардуины

Сообщение GlassEagle » 04 апр 2012, 12:29

ft-ninja писал(а):... за процессом поиска решения.
А то ещё (в других ситуациях, например с Arduino Mini V3) перебираются бутлодеры, пока не заработает.
Когда я слышу слова "Первый закон робототехники", я вспоминаю анекдот про ноусэров.
GlassEagle
 
Сообщения: 159
Зарегистрирован: 14 окт 2009, 11:46
Откуда: Самара

Re: Воскрешение мертвой ардуины

Сообщение Manchiny » 04 янв 2013, 16:18

Всех с прошедшим и наступающими!
что-б не создавать новой темы спрошу здесь:
по недомыслию подал на Arduino UNO R3, на порт А0 напряжение 11,4в. теперь ее не видит IDE. В системе, при подключении по USB, порт появляется (Arduino UNO R3 (COM3), этот порт выбираю при загрузке. раньше все работало, моргал светодиодом, гонял туда-сюда по СОМ-порту байты... А вот после казуса с портом А0 - все пропало... при попытке залить - светодиоды RX и TX вообще не моргают. а IDE выдает "avrdude: stk500_getsync(): not in sync: resp=0x00"
с этим можно что-то сделать? или менять Atmega328 ?
Manchiny
 
Сообщения: 4
Зарегистрирован: 09 фев 2010, 20:57
Откуда: Гатчина

Re: Воскрешение мертвой ардуины

Сообщение ft-ninja » 04 янв 2013, 19:37

Спасибо. С Новым годом!

При таком раскладе, очень вероятно, что умер чип Atmega328. Рекомендую заменить на заведомо исправный с прошитым загрузчиком. Что-то вроде такого - ссылка. Или, если есть чем зашить загрузчик, берите чистый. Будет дешевле.
Поздравляю, ft-ninja!
Изображение
Аватара пользователя
ft-ninja
 
Сообщения: 82
Зарегистрирован: 21 дек 2009, 15:21
Откуда: Inner Mongolia


Вернуться в Arduino и другие Xduino

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter