roboforum.ru

Технический форум по робототехнике.


arduino IDE зависает при попытке открытия Tools

Как собрать и запрограммировать робота на Arduino(Freeduino, Roboduino, Seeduino ...). Используем Wiring и Processing.

arduino IDE зависает при попытке открытия Tools

Сообщение Dmitri Vladimirovich » 28 ноя 2011, 11:54

Всем привет!
Возникла проблема

Поставил arduino-0023 на Windows 7, и при попытке открыть меню Tools она очень долго думает.
Первое подозрение - в Win7 как то переделали обращение к COM-портам

В-общем, это можно как-то решить?

PS проверил это на arduino 1.0. - тоже самое!
#define TRUE FALSE
Dmitri Vladimirovich
 
Сообщения: 283
Зарегистрирован: 05 янв 2010, 23:07
Откуда: Красноармейск
Skype: dmitry.vladimirivich
ФИО: Дима.В.

Re: arduino IDE зависает при попытке открытия Tools

Сообщение dccharacter » 28 ноя 2011, 11:57

Поставить что-то типа regmon и посмотреть, на чем она вешается.
Кстати, у меня 0023 под 64-битной семеркой работает ОК
Мой волшебник это я сам. Всю архитектуру программы придумал лично, а ребята помогли воплотить её. Я бы и сам мог написать, но лень учить язык и его конструкции.
Аватара пользователя
dccharacter
 
Сообщения: 4995
Зарегистрирован: 10 дек 2010, 13:16
Откуда: Красногорск МО
прог. языки: C, Python, wiring/processing
ФИО: Андрей

Re: arduino IDE зависает при попытке открытия Tools

Сообщение SkyStorm » 28 ноя 2011, 11:58

У меня задумывается буквально на секундочку ...
Но в системе определено всего 2 COM порта.
у меня 0023 под 64-битной семеркой
Никто кроме нас!!!
4Robots.ru - Все для роботов!
Аватара пользователя
SkyStorm
 
Сообщения: 2681
Зарегистрирован: 05 фев 2008, 15:33
Откуда: St. Petersburg - Moscow
Skype: SkyStorm77
ФИО: Костюк Константин Вячеславович

Re: arduino IDE зависает при попытке открытия Tools

Сообщение =DeaD= » 28 ноя 2011, 12:09

Там вроде в 7-ке какие-то режимы совместимости с XP, может попробовать настроить, чтобы Arduino IDE в них запускался?
Проект [[Open Robotics]] - Универсальные модули для построения роботов
Аватара пользователя
=DeaD=
 
Сообщения: 24218
Зарегистрирован: 06 окт 2004, 18:01
Откуда: Ебург
прог. языки: C++ / PHP / 1C
ФИО: Антон Ботов

Re: arduino IDE зависает при попытке открытия Tools

Сообщение Dmitri Vladimirovich » 28 ноя 2011, 12:20

Попробовал запуск от имени администратора, в совместимости с WinXP, даже отключил лишние BT-порты, все равно тормозит!

regmon еще не пробовал

Добавлено спустя 40 секунд:
кстати винда тоже х64, НР.
#define TRUE FALSE
Dmitri Vladimirovich
 
Сообщения: 283
Зарегистрирован: 05 янв 2010, 23:07
Откуда: Красноармейск
Skype: dmitry.vladimirivich
ФИО: Дима.В.

Re: arduino IDE зависает при попытке открытия Tools

Сообщение boez » 28 ноя 2011, 12:47

а там случаем в настройках нигде нету какой-нить галки "автоматически искать программаторы"? Похоже именно на полный скан com-портов, а среди них часто встречаются всякие мертвые души типа блютус-портов от телефонов и т.п., на них и висит.
boez
 
Сообщения: 1981
Зарегистрирован: 27 авг 2008, 10:45
Откуда: Харьков
прог. языки: С/С++

Re: arduino IDE зависает при попытке открытия Tools

Сообщение dccharacter » 28 ноя 2011, 12:52

А, еще вспомнил, в чем была похожая проблема. Если Ардуина подцеплена к компу, но выбран неправильный тип платы, то ИДЕ довольно-таки долго и настырно пытается ардуину "уломать" быть той платой, которая стоит в настройках. Та ломается до упора ессно...
Мой волшебник это я сам. Всю архитектуру программы придумал лично, а ребята помогли воплотить её. Я бы и сам мог написать, но лень учить язык и его конструкции.
Аватара пользователя
dccharacter
 
Сообщения: 4995
Зарегистрирован: 10 дек 2010, 13:16
Откуда: Красногорск МО
прог. языки: C, Python, wiring/processing
ФИО: Андрей

Re: arduino IDE зависает при попытке открытия Tools

Сообщение Dmitri Vladimirovich » 28 ноя 2011, 14:01

Всем спасибо!

Во-первых я отключил в настройках проверку обновлений.
Потом поставил по умолчанию свою плату (файл preferences.txt)
И выкинул файл для программаторов.

Да, и еще - у меня кроме стандартных плат когда использовались неофициальные, на других чипах.
Ядро к ним лежало в "моих документах". И походу каждый раз при открытии Тулз Ардуина пытылась до них достучаться

В итоге время сократилось до 5 секунд
#define TRUE FALSE
Dmitri Vladimirovich
 
Сообщения: 283
Зарегистрирован: 05 янв 2010, 23:07
Откуда: Красноармейск
Skype: dmitry.vladimirivich
ФИО: Дима.В.

Re: arduino IDE зависает при попытке открытия Tools

Сообщение ganushak » 29 ноя 2011, 13:30

Удалите еще все порты блютус-устройств из Диспетчера Устройств.
ganushak
 
Сообщения: 40
Зарегистрирован: 09 апр 2011, 22:58

Re: arduino IDE зависает при попытке открытия Tools

Сообщение Dmitri Vladimirovich » 29 ноя 2011, 16:01

Отключил, стало быстрее! Спасибо! Но Ардуина видит еще какой то COM3 которого в диспетчере нету
Как его тоже отключить?
#define TRUE FALSE
Dmitri Vladimirovich
 
Сообщения: 283
Зарегистрирован: 05 янв 2010, 23:07
Откуда: Красноармейск
Skype: dmitry.vladimirivich
ФИО: Дима.В.

Re: arduino IDE зависает при попытке открытия Tools

Сообщение dccharacter » 29 ноя 2011, 16:10

Поставить галочку "показывать скрытые/отключенные устройства" в диспетчере.
Мой волшебник это я сам. Всю архитектуру программы придумал лично, а ребята помогли воплотить её. Я бы и сам мог написать, но лень учить язык и его конструкции.
Аватара пользователя
dccharacter
 
Сообщения: 4995
Зарегистрирован: 10 дек 2010, 13:16
Откуда: Красногорск МО
прог. языки: C, Python, wiring/processing
ФИО: Андрей


Вернуться в Arduino и другие Xduino

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

Mail.ru counter